• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1329
  • Last Modified:

FTP Put command will not work from command line

We are trying to put files to an ftp web site.
When we attempt to do this from the command line we get

200 Port Command successful
150 Opening ASCII mode data connection for /bin/ls

and then it just sits there.

I have tried the dir, ls, and get commands with the same result.

Now, if I use a 3rd party ftp software such as globalscape's cuteftp professional I can access this
ftp website and put, get files and such.

What is the difference between the command line and the 3rd party software?

Any help would be appreciated.
  • 3
  • 3
1 Solution
Do you have any firewall setup ? May be the third party software is being given permission by the firewall ..

Disable firewall and check if it would work and make sure to post back
Also if you donot have any third party firewall , check the ICF that comes with windows xp.

Right-click and go to "properties" of the internet connection you are using.
go to "Advanced" and uncheck "internet connection firewall" .
Now check if the FTP would work.
msilkaAuthor Commented:
I have the ICF unchecked under the "internet connection firewall"
We have a CISCO 2620 router with an IOS firewall.

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Is this home or office machine ? Can you connect your machine directly to LAN without the router and test if the FTP command line would work fine. That way We can figure out if the router is the one that needs to be tweaked.
msilkaAuthor Commented:
This is an office machine on a LAN.
The router is between the LAN and the Internet.

I had this same thing happen a few months ago I think...

I think the problem often is that the ftp server only allows passive mode transfers.  Most ftp software products allow this (and many default to it).  I think that the DOS ftp program does not allow for passive mode.

Other command line ftp programs can switch to passive (from active) by simply typing PASV at the command prompt.

Sorry its no Expert answer but I think it may be the problem.
msilkaAuthor Commented:
I found the problem.  The third party software had a setting for passive mode.  I checked it and now everything is fine.
Thank you for your help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now