[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now


PIX 506 problem : no traffic going through

Posted on 2004-04-27
Medium Priority
Last Modified: 2013-11-16
I'm recent to Cisco firewall config but having good network background in other topics.
We just purchased a  Cisco PIX 506E that we connect to our DSL modem to protect our LAN from Internet.
We have no need for inbound connection to our LAN so config is rather simple and standard.
According to the documentation and what I have seen on the web, that should be up rather easily but I cannot get it to work.
I have configure the interfaces, the pppoe connection on the pix following this procedure : http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00801055dd.shtml

and the PIX shows the DSL connection is up and running.

However : from the PIX console, I am able to ping the Internet but from the workstations on my LAN behind the pix, I'm not able to reach the Internet.  The traffic between my workstations are not going through the PIX to reach the Internet.
My workstations have the PIX as default gateway and I have enable all ICMP traffic to pass through for testing but it is still not working.

What am I doing wrong ?

Here below is the config of the PIX :

Building configuration...
: Saved
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100

hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps
floodguard enable
telnet inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoex request dialout pppoe
vpdn group pppoex localname myusername
vpdn group pppoex ppp authentication pap
vpdn username myusername password *********
dhcpd address inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80

Question by:NicolasBE
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +1
LVL 23

Expert Comment

by:Tim Holman
ID: 10929635
This line doesn't give much for your users to play with !

dhcpd address inside

Try this instead, and set all your clients to DHCP so they pick up the settings:

dhcpd address inside

Also make sure these are MANUALLY set to either 10 or 100, rather than auto.

interface ethernet0 auto
interface ethernet1 auto

Author Comment

ID: 10929922
Sorry, I forgot to stop DHCP.
I'm not using DHCP from the PIX since I have another DHCP running on our servers.
This is because I have reset the factory settings to default several times for testing and forgot this DHCP settings.

So, I have stop the DHCP server.
I have manually set the interface :
DSL modem to 10baset
to the hub : 100full

The PIX inside IP is
My workstation IP is
Mask is FFF0

The connection pppoe is established on the outside interface.

I'm still not able to ping the internet from my workstation ... BUT I can from the PIX console.

Any ideas ?

Expert Comment

ID: 10930634
Have you applied your ACL's to allow the ICMP echo-reply, back through your outside interface?

access-list outside_access_in permit icmp any any echo-reply
access-list outside_access_in permit icmp any any unreachable
access-list outside_access_in permit icmp any any time-exceeded
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

LVL 23

Expert Comment

by:Tim Holman
ID: 10932536
By default, a PIX will allow everything out, but nothing in.  ICMP replies should be coming back OK.
There's nothing wrong with your config - I suspect something inside is causing an issue.
Just to be doubly sure, take the PIX out of the loop and connect directly ?
ICMP may have problems, so could you test using 'telnet www.yahoo.com 80', and type 'get index.htm' ?
Are you sure there isn't a name resolution problem (eg DNS) ??

Author Comment

ID: 10933627
You're right, ICMP is set by default and configured to go through the pix so it should come back with no problem.
I have check ... and re-check the config several times and I see nothing different from what the standard samples are saying.  What I'm trying to do is just simple but it is not working.

When I'm attempting to ping, I'm just using a IP address so I'm even not involving DNS.
I'm able to ping a IP address from the PIX console but not from the workstations behind.

I'll try to telnet that ip address on port 80 to see if ICMP is having problems.

I have try to do a tracert to this IP from the workstation ...
It should show me the inside interface of the PIX as a first hop but it is not.
The default gateway of the workstation is correctly set to the pix (

I think this tracert result is rather strange ... How can I check that I have traffic between my inside and outside interfaces on the PIX ?

Thanks for your assistance... I'm being working on this since 2 days and cannot find out what is wrong so some help and advices are welcome.

Author Comment

ID: 10933677
Forgot to mention : I have no static IP.  I get the IP dynamically from the ISP.

Thanks for any further help ...

Accepted Solution

hawgpig earned 150 total points
ID: 10934268
I hate to differ guys....but ping is not allowed through the pix by default...
remember the echo reply is a seperate packet and the pix will drop it by default if it is not allowed....

I think the issue is that he is testing using ICMP.....

I'll bet this is a dns issue....
I think he needs another dhcpd statement
dhcpd dns [dns address 1] [dns address 2]
the dhcp scope also needs to be extened...like Tim said
and this should get him running
the simple way to test to see if this is the issue is to type in a known ip address in the browser address bar
like cisco....
If you want to get ping to work through the pix use the statements above......by Val
Personaly I prefer to see this
access-list inbound permit icmp any any echo-reply
access-list inbound permit icmp any any unreachable
access-list inbound permit icmp any any time-exceeded
but dont forget this also
access-group inbound in interface outside
Good Luck, Nicolas

Expert Comment

ID: 10934281
I know everyone is going to say the auto config should do the DNS set up.....
but if the ISP is not sending the info....the pix cannot pick it up...
Good Luck

Author Comment

ID: 10940746
Personaly I prefer to see this
access-list inbound permit icmp any any echo-reply
access-list inbound permit icmp any any unreachable
access-list inbound permit icmp any any time-exceeded
but dont forget this also
access-group inbound in interface outside

ICMP is not enabled by default ...

Featured Post

Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Let’s face it: one of the reasons your organization chose a SaaS solution (whether Microsoft Dynamics 365, Netsuite or SAP) is that it is subscription-based. The upkeep is done. Or so you think.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question