Solved

Phantom LAN connection

Posted on 2004-04-27
10
237 Views
Last Modified: 2010-04-11
This is a difficult scenario since I can't replicate this problem at will. I have a computer setup in a remote office that will lose its connection to the web whenever it "wants" to. This is a small office setup behind a Cisco firewall and DSL modem. There are no servers, just the Cisco router. The computer worked fine for the 2.5 years we've had it. Well, about a month ago it started losing it's connection to the web. It will still get an ip ok - It get's the 192.168.x.x IP range. I had them ping 127.0.0.1, and the card quickly without any packet loss. It talks to the gateway just fine. It always gets an IP address and the gateway address. I ran the ipconfig /flushdns - ipconfig /registerdns command, but still no results. The computer has been rebooted, which worked on time, the router has been turned off and then on several times, which seemed to work once or twice, and I'm out of ideas. One of the things that is confusing about it is that the user would use it one day, wouldn't do anything different to the computer itself, and the next day (or maybe even an hour later), he may or may not be able to get a connection. Something similar happened to another computer here in the main office. I could get a connection to my domain server and get an ip address like 192.168.x.x, but it all of the sudden was not able to connect to the web. I tried flushing the DNS and re-registering it, but nothing worked. It wasn't a big deal at the time because we were sending it to a remote office to be used by another user, so were just reformatted it, and it has worked fine ever since.

I'm sure it's something simple, like some sort of routing table, that is messed up, but I don't know what else to do. I would prefer suggestions NOT related to replacing the NIC. I don't think the NIC is the problem since there is no packet loss to 127.0.0.1, and good response time. I've had NICS go out before, but this is something different from a bad NIC.

This machine is running Windows 2000 Professional. So was the one that gave us problems a couple months ago. There are other computers in this remote office that get a connection just fine. I'm almost 100% sure that something just needs reset, but I'll let you more experienced experts tell me what it is! Thanks!
0
Comment
Question by:mckeough
  • 3
  • 3
  • 2
  • +2
10 Comments
 
LVL 31

Accepted Solution

by:
Gareth Gudger earned 175 total points
ID: 10931974
You have tried power cycling the Cisco router, leaving it down for a good 30 secs.

Also try updating to the latest NIC drivers or reinstalling the current ones?
0
 
LVL 7

Expert Comment

by:magus123
ID: 10932718
have you tried using the tracert command and seeing where the connection gets lost or blocked.
as you say that computer can ping the gateway.

have tried  in cmd

ipconfig/release
ipconfig/renew

and seeing if that helps any.

have you tried the command pathping
ABOUT PATHPING

Similar to the tracert command, pathping  provides users with the ability of locating spots that have network latency and network loss.


also have you consider your  network cable running to that pc could be defective , try ping the gateway , or router
with a paramenter to ping it more than its defualt.

ill check back
0
 
LVL 3

Expert Comment

by:Tele_tech
ID: 10932721
Clarify please... when it looses it's connection to the WEB it still can ping the router?
Can it ping other computers on the LAN?

When this occurs How do  you or the user restore the connection?
0
 
LVL 1

Expert Comment

by:axelt
ID: 10936461
pinging 127.0.0.1 is just a basic "ip-stack up and running" test, you can still have a hardware problem
Pinging the router is a better test

Do a ping -t to the router and pull a little in the network cable, If this gives you timeouts, well it's either the cable or the jack in the network card. If all this is ok, find the WAN ip on the router, f.ex by going to this page: http://www.whatismyip.com/

Ping -t the wan address from another location (enable ping from this location in the firewall if it is blocked)
And just wait for the next failure to occur....

Also, set up three ping sessions in commad prompts on the computer.
One to the router
One to a internet dns address
One to a internet ip-address

When the pc "loses" internet connection, where does the pings timeout?

If all are ok. Try running nslookup to see if there are dns resolution problems....



0
 

Author Comment

by:mckeough
ID: 10938661
I will try all your suggestion today. Tele Tech, funny as it is, we pull the cable out of the NIC and put it back in. This makes me think it could be a bad cable. It will be a pain to replace it since nobody in that office knows how to crimp a new end on it. The first thing I did though (after the user pulled the cable and put it back in again) was had him update drivers. Ever since we updated drivers we haven't had a problem, but I don't think it's a driver problem since we do get a connection, and since pulling the cable and putting it back in again temporarily fixes the problem. I'll have the user move the cable around and see if he loses his connection again. If we don't lose the connection again within a week, I'll consider this issue closed and award digisaur with the points since it would be drivers. However, if we do lose the connection again, I'll run some more ping tests including about pathping. Thanks for all your input everybody! If anything changes I'll post it immediately.
0
Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.

 
LVL 3

Expert Comment

by:Tele_tech
ID: 10940431
is the cable a jumper to the wall?  if so try exchanging it with another one on a different computer and see if the problem follows it.  You also can purchase a patch cable pre-made.

good luck
0
 

Author Comment

by:mckeough
ID: 10940777
Tele Tech - No, it's rather long cable directly to the firewall. That's why it would be better to re-crimp the end of it if the cable is indeed the problem. I don't even mind spending the money on a Belkin (or similar) cable, but it's just that since it goes directly to the router, it's going to be a headache to run a new one.
0
 
LVL 3

Expert Comment

by:Tele_tech
ID: 10946138
one last idea.. If it drops check the link lights at BOTH ends of the cable before doing anything.. if one is out.. the problem is the cable.  as rare as it is.. have seen a cable that allowed a link light on one end and not the other.....and you don't go anywhere like that....

0
 

Author Comment

by:mckeough
ID: 10982071
Diggisaur's driver update worked. I haven't had a single connectivity issue since we updated the drivers. Thanks to everyone else that participated in this forum!
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 10982596
Great :)
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Some time ago I was asked to set up a web portal PC to put at our entrance. When customers arrive, they could see a webpage 'promoting' our company. So I tried to set up a windows 7 PC as a kiosk PC.......... I will spare you all the annoyances I…
Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now