Solved

LoadBalancing Two T1's from Same ISP on one 2610 router.

Posted on 2004-04-27
8
624 Views
Last Modified: 2010-04-17
Planning for a network change in the near future:

I have two T1’s, from the same ISP, connected to two T1 WIC cards on a 2610 internet router. Each T1 is on its’ own subnet. The ISP uses CEF per packet load balancing on all incoming packets. They have assigned us a block of public IP’s pointed to the two subnets. I’ve one inside Ethernet interface installed pointed back toward our Pix. The IP assigned to e0/0 is from the block of IP’s provided from the ISP. I’ve included a copy of the simple config from the router. Any suggestions on how I might use CEF on the outgoing packets?   I was originally leaning toward ppp multilink, but now now.

 !
interface Ethernet0/0
bandwidth 1536
ip address 64.XX.XXX.65 255.255.255.224
no ip directed-broadcast
no fair-queue
no cdp enable
!
interface Serial0/0
ip address 64.XX.XXX.170 255.255.255.252
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
!
interface Serial0/1
ip address 64.XX.XXX.174 255.255.255.252
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip route 0.0.0.0 0.0.0.0 Serial0/1
no ip http server


I mentioned that the ISP uses per packet load balancing. We receive an enormous amount of incoming FTP traffic to DMZ FTP servers.  Since a lot of these files are over 500MB compressed would it not be wise to use per destination over per package?

Thanks for the Help!
0
Comment
Question by:jhhaley
8 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 10933920
I would strongly discourage you from trying multilink ppp. CEF is much faster.
Have you enabled CEF? I don't see it in your config snippet.
If the ISP is doing per-packet, you should match on your end. This will keep the load balanced whereas if you use per-destination, you might peg out one line with a 500Mb upload...
My suggestion would be to use MRTG or something to monitor the two interfaces to see if you are getting true load balancing.


0
 
LVL 79

Expert Comment

by:lrmoore
ID: 10935106
>ip route 0.0.0.0 0.0.0.0 Serial0/0
>ip route 0.0.0.0 0.0.0.0 Serial0/1

Also suggest that you use the upstream IP address vs the interface

ip route 0.0.0.0 0.0.0.0 64.XX.XXX.169
ip route 0.0.0.0 0.0.0.0 64.XX.XXX.173
0
 
LVL 12

Expert Comment

by:Scotty_cisco
ID: 10939994
What about using a routing protocol with the ISP... even if you use BGP and only recieve partial routes or just a default route it would help with your soltion....

Thanks
Scott
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 1

Author Comment

by:jhhaley
ID: 10940587
Thanks for both comments...I'm in process of enabling CEF. I'll then post a new config later today.
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 10944518
> Also suggest that you use the upstream IP address vs the interface

Why?  

Cisco in fact recommends the interface form for point-to-point connections, since it (a) saves the effort of resolving the address to an interface, and (b) will only be added to the running route table when the interface is up.

So I'd be interested in any reasons you have for recommending otherwise.

0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 10945578
Au contrair, my friend:
Quote from:
http://www.cisco.com/en/US/tech/tk365/tk80/technologies_tech_note09186a00800ef7b2.shtml

If you point a static route to a broadcast interface, the route will be inserted into the routing table only when the broadcast interface is up. This configuration is not recommended because when the next hop of a static route points to an interface, the router considers each of the hosts within the range of the route to be directly connected through that interface. For example, ip route 0.0.0.0 0.0.0.0 Ethernet0.

With this type of configuration, a router will perform Address Resolution Protocol (ARP) on the Ethernet for every destination the router finds through the default route because the router will consider all of these destinations as directly connected to Ethernet 0.

This kind of default route, especially if it is used by a lot of packets to many different destination subnets, can cause high processor utilization and a very large ARP cache (along with attendant memory allocation failures).

Specifying a numerical next hop on a directly connected interface will prevent the router from performing ARP or each destination address.

0
 
LVL 5

Expert Comment

by:epylko
ID: 10945596
BGP (or any routing protocol) isn't going to make a difference for load balancing. If the ISP is doing per-packet load balancing, the T1's must be terminating on one router. Since there is only one ISP, a routing protocol won't help anything.

ppp multilink might work fine, except you need to have your ISP run it on their side too. 2xT1 will not create enough load to worry about. Plus, a sufficiently new IOS will have a fast switching implementation of ppp multilink.

Finally, static routes that go out an interface will not be in the routing table if the interface is down. For frame relay, you wouldn't want to use the interface since a PVC might be down but not the interface.

-Eric
0
 
LVL 1

Author Comment

by:jhhaley
ID: 10992933
I've been side tracked by another project, but back to this one.
I've upgraded the IOS from 12.0 to 12.2. CEF has been enabled. ip load-sharing per-packet has been enable on e0/0, s0/0, and s0/1. After doing the show adjacency command I can see the attached serial interfaces (*.169 and *.173) for the ISP.

Is there anything you would recommend turning on or off on on the interfaces?
I've removed the ppp encapsulation. I'm not using ip route-cache cef.

This looks pretty straight forward. I've read the comment on Cisco's site pertaining to the static addressing and I can change the  ip route to reflect the destination ip instead of the serial interface.

I am going to try to bring this up live tomorrow.  I'll let you know how it goes.

If you've anyother suggestions please let me know.  

Thanks a Bunch!!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Port forwarding in Cisco RV215w 2 60
HSRP needed? 4 56
Connecting LAN to a new leased line 2 62
snmp-server enable traps gdoi ks-rekey-pushed 3 21
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

789 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question