Booting Fedora from Grub Boot Disk on Dual-Boot (XP) Machine

Posted on 2004-04-28
Last Modified: 2013-12-06

I installed Fedora Core 1 on an XP machine, intending to create a boot disk, as I had for RedHat 8. But when I got to that point in the installation process, I was informed that the kernel would not fit on a floppy disk. So I created a grub boot disk. I tested it on my old RedHat 8 (also dual-boot) machine and it works fine.

But I have yet to successfully boot Fedora.

My boot partition is /dev/sda3, (hd0,2) on grub.
My root partition is /dev/sda6, (hd0,5) on grub.

This is what I have tried:

grub> root (hd0,5)
    Filesystem type is extfs, partition type 0x83

grub> kernel (hd0,2)/vmlinuz root=/dev/sda6
    [Linux-bzImage, setup=0x1400, size=0x1305b5]

grub> boot

kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno=2
VFS: Cannot open root device "sda6" or 08:06
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:06

Any ideas will be appreciated.


Question by:s1m0ne
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
LVL 17

Expert Comment

ID: 10936681
Your problem is the fact that you have a scsii drive. Scsii modules need to be loaded in an intial ramdisk before linux can access the filesystem. Im guessing your old system has an ide drive. Why not just install fedora and use grub to dual boot? Its pretty painless.

Accepted Solution

da99rmd earned 200 total points
ID: 10936815
I have the same config on my machine, and the problem for me where that the disk had diffrent hd numbers when started and when i booted it up.
I think this have some thing to do with bios setup.
Try doing a find for for a file on your root partition and get the hd number of it.

are you sure about the sda6 partition number ?

And i think
you should write like this:
root (hd0,2)
kernel /vmlinuz root=/dev/sda6
initrd /initrd-2.4.*-*.*.img
then boot


Author Comment

ID: 10944854

That did it! Thanks a lot!

You'll get the points. I'll increase them if you can tell me how to automate the process.

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.


Assisted Solution

da99rmd earned 200 total points
ID: 10946789
Just add this to your grub.conf on the disk 3.5" or on the computer /etc/grub.conf:

title Red Hat Linux (Newest)
   root (hd0,2)
   kernel /vmlinuz ro root=/dev/sda6
   initrd /initrd-2.4.*-*.*.img

title Windows XP
      rootnoverify (Put XP patition number here)
      chainloader +1

If you dont want to boot from disk just make it a double boot system by typing:
grub-install /dev/hda (if you have a first ide disk intsalled)
Type this after you have edited the /etc/grub.conf



Author Comment

ID: 10956456

That looks promising, but I am having trouble getting my floppy to mount. (And there is no /etc/grub.conf on the computer -- which I am guessing would be relevant only if I were intending to install grub as the boot loader on the computer, which I am not -- at least not at this time.)

Since I created the grub boot disk in the first place using mke2fs, that would make the filesystem ext2, right?

But when I try:

# mount -t ext2 /dev/fd0 /mnt/floppy

I get:

mount: wrong fs type, bad option, bad superblock on /dev/fd0,
       or too many mounted file systems

If I omit '-t ext2' then I get:

mount: you must specify the filesystem type

In fstab I have:

/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0

Any ideas?

Thanks for your continuing help.


Expert Comment

ID: 10975367
Nope it should work fine i can mount my boot disk but i think i got fat on my disk dooh.
But it should mount as a ext2 disk to but its usaly best to have fat on all boot disks.
So try making it fat and then install grub on it.


Author Comment

ID: 11038090

How did you create your grub boot disk?

I used 'cat stage1 stage2 > /dev/fd0' but that seems to overwrite the filesystem. So even if I use mkfs.vfat instead of mke2fs, the result is (apparently) the same.


Author Comment

ID: 11084047

I finally got it working. Here is what I did:

$ fdformat /dev/fd0
$ /sbin/mkfs -t vfat /dev/fd0

# mount /dev/fd0
# mkdir -p /mnt/floppy/boot/grub
# cp /usr/share/grub/i386-redhat/stage* /mnt/floppy/boot/grub
# umount /mnt/floppy

# /sbin/grub

grub> root (fd0)
grub> setup (fd0)
grub> quit

# cd /mnt/floppy/boot/grub
# vi grub.conf

And then I typed in the lines from the grub.conf you gave in your answer of 4/29/2004.

It works great now! Thanks again!


Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question