Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Local Security Policy - ASP_USER - log on as batch job

Posted on 2004-04-28
11
Medium Priority
?
627 Views
Last Modified: 2010-05-18
System: windows xp pro with all service packs and .net framework installed.


We are having a problem with a scheduled task running.
I have seached all over and I have found a site that outlines the problem we are having.

http://www.microsoft.com/resources/documentation/WindowsServ/2003/standard/proddocs/en-us/Default.asp?url=/resources/documentation/WindowsServ/2003/standard/proddocs/en-us/545.asp

and...

http://www.annoyances.org/exec/forum/win2000/1029775337

When a scheduled task is supposed to run, we check it the next day and it says "could not start"
We have tracked the problem down to the account the scheduled task is supposed to run under is not listed in the 'Log on as batch job' section of the local security policy.

I would change this to correct the problem, however, it is uneditable... the only user listed is asp_user and the boxes that would be used to add other users are grayed-out and those options are not available.

Here is a link to a screen shot of the window I am referring to:
http://www.tuscano.com/batchuser.gif

We've been tracking this problem for months and it seems that we are getting close to the answer, but now we are stuck not being able to change the settings for the 'log on as batch job'

Why would this security setting be locked out from being able to edit it?
We need to be able to add other users the ability to log on as batch job.
0
Comment
Question by:toedrag
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
11 Comments
 
LVL 67

Expert Comment

by:sirbounty
ID: 10938845
Are you logging on as administrator?
Have you tried via Start->Run->GPedit.msc ??
0
 

Author Comment

by:toedrag
ID: 10938936
We are logged on as administrator.
I need to be able to edit a setting in the Local Security Policy.
I am able to edit the Group Policy, but just that one setting in the Local Security Settings is not able to be edited.
Thanks
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 10939028
Click Start->Run->%Systemroot% <enter>
Right-click on the Security folder and choose properties.
Check the security tab for specific permissions for your administrative account - perhaps a write/full control permission is missing for some reason?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:toedrag
ID: 10939473
Administrators have control of that directory.
The problem  seems more to do with not being able to edit that one specific setting.
0
 

Author Comment

by:toedrag
ID: 10960041
This problem is also happening one our intranet server (windows 2003 server with .net framework installed) - we are also unable to edit that setting in the local security policy.

I can't find any answers to this on the internet and need help bad - it is critical that these scheduled tasks run.
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 10965502
I wonder if you can set the schedule service back to local system account?
At least for testing purposes.
Does the scheduled job need network access?
0
 

Author Comment

by:toedrag
ID: 10976658
I have tried to set it to run as local system, local admin, domain admin.... you name it, I have tried the account.

I would say the problem seems to be that the accounts that I have tried are not listed in the local security policy with permission to run batch jobs.

Thanks

0
 

Author Comment

by:toedrag
ID: 10977607
I figured this out on my own.
The policy was locked out because a higher up policy was taking priority over it.
Once I changed the higher policy, I ran gpupdate /force on the workstations and they then had the settings I needed.

Thanks
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 11054119
Please see:
http:help.jsp#hs5
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 11557952
PAQed, with points refunded (500)

modulo
Community Support Moderator
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes people don't understand why download speed shows differently for Windows than Linux.Specially, this article covers and shows the solution for throughput difference for Windows than a Linux machine. For this, I arranged a test scenario.I…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question