Solved

Windows joining a Samba domain

Posted on 2004-04-28
8
15,087 Views
Last Modified: 2012-06-27
I am having a problem whereby I cannot make Win2k and WinXP machines join or leave a Samba 2.2 domain and they give the error message

"The following error occurred attempting to join the domain "MSEAG":

The specified domain either does not exist or could not be contacted.

This is despite the fact that
1. The machines that cannot join the domain can ping the domain controller
2. Machines that joined the domain before this problem occured can still long on the domain
3. Machines that cannot join the domain can still log on to shares on the domain via Windows Explorer

This is not caused by a bad username/password combo, I have tried every possible combo and plus I have seen that message before and it is different
The only event that I can think of that could have precipitated this problem is the fact that we have recent taken the firewall services off the server and installed a seperate IPCOP machine instead to do firewalling. So the domain controller is no longer doing DHCP/DNS.

A kind of sub-question is would installing Samba 3 solve this problem and is it a lot of hassle?

Thanks

Adam
0
Comment
Question by:adamdepledge
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 7

Accepted Solution

by:
sr_millar earned 500 total points
Comment Utility
Adam,

Sounds like the new workstations cant locate a domain controller to logon.  I am not familiar with Samba, but you need DNS running on your network that contains an SRV record pointing to a DC.  If that is not there you will have problems.  

Are you also sure you have updated the DHCP scope to point to the new DNS server aswell and that the PCs are not trying to contact the wrong DNS server?

Stuart
0
 
LVL 10

Expert Comment

by:anupnellip
Comment Utility
check this
http://nic.phys.ethz.ch/readme/45

also it is a good idea to upgrade Smba as 2.2 does not work very will as Domain controller . I dont thing it is a big hassel to upgrader to 3 .
0
 
LVL 7

Expert Comment

by:EmpKent
Comment Utility
You say that the clients can ping the DC. Using its IP address or its hostname?

Can they ping MSEAG?

Kent
0
 

Author Comment

by:adamdepledge
Comment Utility
Stuart

You seem to be the only one onto something so far. I don't understand what the SRV record is. The server had some DHCP problems and once those problems were sorted I managed to get one machine to join the domain. However another machine is still not joining and gives a different error message than before. The important part of the error message is included below.

The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.dc._msdcs.MSEAG

Common causes of this error include the following:

- The DNS SRV record is not registered in DNS.

- One or more of the following zones do not include delegation to its child zone:

MSEAG
. (the root zone)
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 7

Expert Comment

by:sr_millar
Comment Utility
Have a look at this section of a Microsoft TID :

DNS Server Requirements
Microsoft recommends that you use Microsoft DNS Server as supplied with Windows 2000 Server as your DNS server. However, Microsoft DNS is not required. The DNS server that you use:
Must support the SRV RR (RFC 2052).
Supports the dynamic update protocol (RFC 2136).
Version 8.1.2 and later of BIND (a popular DNS server implementation) supports both the SRV RR and dynamic update. (Version 8.1.1 does support dynamic updates but it has flaws that were fixed in 8.1.2.) If you are using a version of BIND that does not support dynamic update, you need to manually add records to the DNS server.

NOTE: Microsoft DNS, as included with Microsoft Windows NT 4.0 Server, does not support the SRV record. Use DNS Server that is provided with Windows 2000 Server.

I am not familiar with Samba, but is the DNS Bind 8.1.2 or later?  Active directory uses what is called a SRV record to locate domain controllers - without it you might be in trouble.

What is the possibility of running DNS on a W2K box?

I will look further into this for you.

Stuart


0
 
LVL 7

Expert Comment

by:sr_millar
Comment Utility
0
 
LVL 10

Expert Comment

by:anupnellip
Comment Utility
go to c:\winnt\system32\drivers\etc ( C:\WINDOWS\SYSTEM32\DRIVERS\ETC for XP)

you have a file called lmhosts.sam in there

edit it and add the following entry in it

IP_ADDRESS_OF_SAMBA_SERVER      SERVER_NAME      #PRE      #DOM:MSEAG

now save this file as lmhost ( make sure u dont save it as txt or sam file )

reboot the machine & try to join again .

0
 

Author Comment

by:adamdepledge
Comment Utility
Thanks guys

we are going to solve the problem by going to Samba 3 so the points go to Stuart who gave me the most helpful info
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Join & Write a Comment

If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now