Improve company productivity with a Business Account.Sign Up

x
?
Solved

Access denied for user: 'nobody@localhost' (Using password: NO)

Posted on 2004-04-29
5
Medium Priority
?
2,710 Views
Last Modified: 2007-12-19
Hi,

I'm running mysql Ver 12.22 Distrib 4.0.18, for pc-linux (i686), under redhat. Am getting the following exception message when i try to access my database:

Error creating connection (Invalid authorization specification: Access denied for user: 'nobody@EmiRes' (Using password: NO))

I have setup my database, and created the correct user/permissions for the connection string i am using. I can connect to the database using mysql-front, but when i try to access through the application i get the above error.

Below are the current contection details:

user: emires

An initial thought was that a conflict between the server name and the user name might be causing a problem, however, changing the user name and creating a new account still gives tha same error.

Any help with this would be very welcome.

Thanks

Chris
0
Comment
Question by:n0702897
3 Comments
 
LVL 17

Accepted Solution

by:
Aleksandar Bradarić earned 172 total points
ID: 10948881
>  Access denied for user: 'nobody@EmiRes'
[...skip...]
> user: emires

The error says that you are trying to connect with user `nobody` from machine `EmiRes`. Try to change the user to `emires` and see what happens...
0
 
LVL 6

Assisted Solution

by:andreif
andreif earned 164 total points
ID: 10950884
Hi,

look at your error message:

Access denied for user: 'nobody@EmiRes' (Using password: NO)

It says you are not using password and user nobody probably means that you do not supply username (nobody is user who owns process). So, check your connection settings in your app. Which language is that and what is that piece of code for connection to the dababase? May be we can help :)
0
 
LVL 16

Assisted Solution

by:DcpKing
DcpKing earned 164 total points
ID: 10951218
Your application isn't running as EmiRes, but was already running from system startup. At a guess, you're running something like a web server as a daemon and it's the web server's ID that's being used (and refused).
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Password hashing is better than message digests or encryption, and you should be using it instead of message digests or encryption.  Find out why and how in this article, which supplements the original article on PHP Client Registration, Login, Logo…
In this blog, we’ll look at how improvements to Percona XtraDB Cluster improved IST performance.
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

595 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question