[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 646
  • Last Modified:

Adding Second Server In Windows 2003 Server Active Directory Structure

Hi

I am trying to add my second Windows XP 2003 server to an existing network.

The first server has windows 2003 SBS already set up and working fine.
The second server has Windows 2003 server with fileserver enabled on it.

How do I get the shares on the second machine to be accessable from users who are defined on the first?

Any help would be great!

0
BoltonWanderer
Asked:
BoltonWanderer
  • 4
  • 4
  • 2
  • +1
1 Solution
 
ewtaylorCommented:
Just make it a part of the domain. In other words when you setup the networking  add it to the domain.
0
 
BoltonWandererAuthor Commented:
Hi

Thanks for the response.

I have added it as a server to the Small Business Server domain and it can be seen there as a server, but when I come to share the directory, the only place it looks for user details etc. in locations is the second server.

I am well stuck.
0
 
rhandelsCommented:
Did you give the users on the domain access to the folders??

Normally, you should make sure to give everyone the full access permissions on the share and create ACL's with NTFS permissions. So make sure that sharing permissions are good and also make sure the domain users are selected, you can see it like this, the user who has access must be called DOMAINNAME\username. If you added the local users, it's called LOCALPCNAME\username.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
BoltonWandererAuthor Commented:
Hi

No, the problem I have is that when I bring up the sharing box, it only looks in the local server for user objects and not the domain.

So if the Domain Controller is 001 and the file server is 002 then when I try to share a folder on 002 i only see the users that are defined on server 002. I cannot change the locations field because it is greyed out and if I type 001\userid it comes back with the user unknown error.

0
 
rhandelsCommented:
Are you using a domain?? If not, then you'd better upgrade to a domain by typing in dcpromo at the command prompt. If you are in a domain, please try to reboot the server and log in at server 2 as the domian admin. Then try to set the permissions again.
0
 
ewtaylorCommented:
Are you logged in as a domain admin or as a local admin? Make sure you log into the domain as a domain admin  then try sharing it out.
0
 
BoltonWandererAuthor Commented:
Hi

I logged in as the administrator of the domain and checked all of the settings on the network of the second machine. It is set to be in the same domain as the first server.

I can log into the second server as the domain admin.

When I come to share a directory and it asked for the permissions I enter the details of a user on the domain controller in the format domain\userid and it comes back with the standard 'unknown user or object error'

0
 
ewtaylorCommented:
If you click the drop down box at the top it is the domain is greyed out? Can you check the event log and see if there are any entries both on the domain controller and the new server.
0
 
BoltonWandererAuthor Commented:
Yes the domain is greyed out. I have decided to reload the server from scratch and see if this solves it.

We are in the middle of doing that now.

Since you have done your best to help I will accept your responses ewtaylor - many thanks.

Lets hope this fixes it!
0
 
ewtaylorCommented:
Thanks, post here if it does not.
0
 
jdippelCommented:
Your DNS is off.  Point your new File server dns info to the existing DC for name resolution.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now