[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1905
  • Last Modified:

No Advanced Tab on Properties screen of LAN Connection

I recently installed XP Pro on my desktop and am having trouble connecting
to my VPN.  In trying to troubleshoot the problem, I decided to try to be
sure that the firewall within Win XP Pro was not in operation.  So, I went
to the Local Area Connection Properties screen, expecting to find an
Advanced tab there (as is on my other XP Pro machine).  After clicking that
tab, one can check to see if the box is checked for the firewall.

However, my XP Pro on my desktop does not have an Advanced tab (only a general tab
and an authentication tab).  Can somebody tell me how to fix this?

Thank you.

0
bobsing060797
Asked:
bobsing060797
  • 11
  • 10
  • 2
1 Solution
 
gemartiCommented:
Are you logged on with an account that is a member of the administrator's group?

START | RUN | LUSRMGR.MSC
Click on the Groups Folder
Click on the Administrator's group

If you are not a member then logon to the system with username=administrator and add your account to the administrator's group.

Then see if you can see the "Advanced" Tab.

I'd recommend demoting the account back to Power User after your done.
0
 
bobsing060797Author Commented:
I am in the Administrator's group but am not in the power users group.  
0
 
gemartiCommented:
Here is a script that should disable the firewall settings on your system. If you want to enable the firewall set objItem.AllowInboundEchoRequest= True

+++++++++++START VBS SCRIPT

strComputer = "."
Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\microsoft\homenet")
Set colItems = objWMIService.ExecQuery("Select * from HNet_FwIcmpSettings")
For Each objItem in colItems
    objItem.AllowInboundEchoRequest = False
    objItem.Put_
Next
'©2004 Microsoft Corporation. All rights reserved.
++++++++++END VBS SCRIPT

Save in a notebook document, but save with a vbs extenstion, not a txt extension.
FILE | SAVE AS...
Select "All Files (*.*)
Name the file like EnumFirewall.vbs

Then
START | RUN |CMD
Enter:
cscript enumfirewall.vbs

0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
gemartiCommented:
Sorry the above is not a complete script. It only blocks ping requests. One moment while I research the missing advanced tab.

0
 
bobsing060797Author Commented:
Do I save only what is between the two lines of ++++, include the two lines of ++++ or include everything you said in the file entitled EnumFirewall.vbs ?
0
 
gemartiCommented:
Okay. Try this:
START | RUN | SERVICES.MSC
Locate:
Internet Connection Firewall (ICF)/Internet Connection Sharing (ICS)
If it is a started service set it to manual and stop it.
0
 
gemartiCommented:
Funny how I forget things. This may be a policy that was set on your system.

START | RUN | GPEDIT.MSC
Navigate to:
User Configuration | Administrative Templates | Network | Network Connections
Look for enabled policies. Specifically "Prohibit Access to the Advanced Settings Item on the Advanced Menu"
0
 
bobsing060797Author Commented:
I checked the Group Policies and found the one you were referring to.  All of them said "Not configured".  
A little history may help in eliminating possibilities.  
I am the only one using this computer.  It is on a home-network (4 computers) with a router and a cable-modem that I setup.  

During the past week I did a clean reinstall of XP Pro (F-disk, Format (NTFS).  
I also installed (a few months ago, on top of Win 98) XP Pro on my laptop.  It is also on the LAN and does have the Advanced tab and can access my VPN.  

Does any of that help?


0
 
gemartiCommented:
Have you tried deleting the network connection and then recreating it?
0
 
bobsing060797Author Commented:
No, how would I recreate it?  
0
 
gemartiCommented:
First I would gather internet settings information:

START | RUN | CMD
enter:
IPCONFIG /ALL >c:\IPCONFIG.TXT

This writes the IP COnfiguration information to a txt file called ipconfig.txt in the root of C:\

Now Print out the IPCONFIG.TXT File you created.

Next:
Right Click Network Neighborhood (on your desktop)
Select Properties

A folder will open with Icons in it. Select your LAN connection.
Right Click the LAN connection
Select Properties

Note what is installed (i.e. Microsoft Client for Networks; QOS Packet Scheduler, File and Printer Sharing, TCP/IP Properties)
Close the dialog box that appeared when you selected properties.
Delete the LAN Connection ICON

++++++++++++++++++
Locate and follow the instructions "Install and configure the network software" at this link:
http://support.microsoft.com/default.aspx?scid=%2Fdirectory%2Fworldwide%2Fen-gb%2Fhnetwork.asp#XSLTSection123121121120

The IP information you printed earlier will be useful when setting your TCP/IP configuration settings.
0
 
bobsing060797Author Commented:
Wow, that sounds confusing.  

Are you simply suggesting that I delete the Local Area Connection and then clicking the button for Create a new connection and then running the wizard to "Set up a home or small office network"?  I have run the wizard several times to set up the LAN initially.  

If that is what you are talking about, why do I need the data from IPconfig?  I do not recall that info being needed in the past.
0
 
gemartiCommented:
I was ensuring that you had the necessary data to reconnect to your data.

I wasn't aware of your attempts to recreate the Lan Connection.

0
 
bobsing060797Author Commented:
Any other suggestions?
0
 
gemartiCommented:
If this computer is connected to your other computer that is connected directly to your modem and is using Internet connection Sharing to allow your problem PC to connect to the internet then this may be where your problem lies.

ICF cannot be enabled on the private connections of the Internet Connection Sharing host computer.

0
 
gemartiCommented:
Last try:
START | CONTROL PANEL
Click on the "Network and Internet Connections" link
Click on the "Network Connections" Link
Right-Click your Local Area Connection
Select Disconnect from Ethernet Bridge
Close all windows
0
 
bobsing060797Author Commented:
Both my problem computer and my laptop are connected to a router (Linksys BEFSR41).  The router is connected to the Cable Modem (RoadRunner).  

0
 
bobsing060797Author Commented:
Thanks gemarti.  It was the Ethernet Bridge that was causing the problem.  I am not sure how it got there in the first place.  But with it gone, I now find the Advanced tab and my VPN is working as well.  
0
 
gemartiCommented:
Thank you.
0
 
VSACITCommented:
Hello,

I have do the above and the Advanced Tab is not visable.

Do you have any suggestions?

Thanks for your help,

Ed
0
 
bobsing060797Author Commented:
Hi Ed,
Read the accepted answer for the steps to disconnect from the Ethernet Bridge.  That did it for me.  
0
 
VSACITCommented:
Hello!

When I right click on  the LAN, disconnect from Ethernet Bravailable, but it ask me if I want to create one.


Thanks,

Ed
0
 
bobsing060797Author Commented:
I am not an expert, only a person who asked a question.  You will probably need to post a question for the experts.  
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 11
  • 10
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now