SLOW SPEEDS ON WIN2K & GIGABIT NETWORK



i JUST UPGRADED MY 100Mbps WIN2K NETWORK TO A GIGABIT NETWORK.  I ALSO REMOVED MY RAID CONTROLLER FROM THE SERVER AND ADDED 2 SIGNLE HDD's INSTEAD.  IN THE SOFTWARE PROGRAM WE ARE USING, BEFORE I DID THIS CHANGE, IT WAS TAKING 4 MINUTES TO SAVE OUR 3D MODELS UP TO THE NETWORK.  NOW, AFTER THE 'UPGRADE', IT IS TAKING BETWEEN 10 AND 14 MINUTES.  PLESAE HELP ME!!!


ROKKS

sjs@lannomsteel.com
steormannAsked:
Who is Participating?
 
PaulADavisConnect With a Mentor Commented:
set those nics to both on and asym and sym flow control respectively.... if you can manage the switch at all you can see if you can increase the recieve buffers at all...

0
 
akbossCommented:


you have posted this same question in another TA already.

You need to post a zero point question in community support asking that they delete one or turn it into a pointer question
0
 
PaulADavisCommented:
do you have any volumes set up? generally,  stripped volumes write a little faster, so if you had a stripped volume before, that could be one factor in the speed.... other factors include the hd cache size and it's speed.

what did you do to upgrade the network? if you put some gigabit switches in place but still have a 10mb nic, you might not see that much better performance.
did you had new nics? if you did, check on the settings and make sure that they are set to their maximum speed and duplex.

you can use system monitor to monitor the disk queue length when you are saving your models...
http://windows.about.com/library/weekly/aa001119a.htm

http://www.computerperformance.co.uk/HealthCheck/Disk_Health.htm#Basic%20counters%20to%20monitor%20disk%20activity
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
PaulADavisCommented:
other things include: defraging the disks, checking how many people are connected to the machine/how busy the machine is when you are saving, and monitoring the network itself to see how much traffic is present at times when you are saving. if someone else is  downloading/uploading data, streaming media, etc, that can really sap up your bandwith.
0
 
steormannAuthor Commented:

I added all new 32 bit gigabit nics, a new gigabit unmanaged switch and CAT5e cabling.  

Where can I check to see if they are set to their maximum speed and duplex?
0
 
PaulADavisCommented:
right click network places----right click local area connection-----properties
at the top look for configure, click on that----click the advanced tab.... look for media type or link speed (or something to that effect. alot of time they come set to auto in the value drop down column on the right.... you can select the fastest speed and full duplex....
0
 
PaulADavisCommented:
sorry... :-) when you right click on network places and local area connection, select properties both times
0
 
chicagoanCommented:
> I ALSO REMOVED MY RAID CONTROLLER FROM THE SERVER AND ADDED 2 SIGNLE HDD's INSTEAD

What was the setup on your raid array versus your new configuration?
Chances are your disk channel isn't handling the load.
Take a look at your performance counters for the network and the disks and see
http://www.acnc.com/benchmarks/nbench.zip
to see what your disk throuput is.

0
 
shahrialCommented:
I sure hope you had a proper backup solution cause 2 single HDD is kind off risky...
What happens if the HDD fail...do you have a disaster recovery plan?

Anyway, 3D models are bandwidth hungry....at work, we are running Autodesk Inventor...(RAID5).
1.) check that you have set a higher Paging File on your server.
2.) try replacing the UTP cable connected to your server.

What kind of Hard-disk technology are you using ? SCSI U160, U320, 10K rpm, 15K rpm
These makes a difference too... ;-)
0
 
steormannAuthor Commented:


Okay,   my drives are runnning perfectly with no errors.  Eveything seems fantastic except for the fact that while I'm saving this big 3D Model,  It transfers over the network for about 90 seconds, waits 30-45 sec, transfers, waits, etc...  What would cause this sporadic trasfer-hold-transfer situtation.  

Thank you everybody for all of the help so far!




.steormann
0
 
PaulADavisCommented:
how did you verify this?

are your nic's set to full duplex?
0
 
steormannAuthor Commented:

Yes they are set to Full Duplex..

I monitored this by opening up my LAN status dialog box while I was doing a save up to the server.

And watched the counters under the packets sent and packets received.

.
0
 
PaulADavisCommented:
check on the documentation of your nic.... if it has flow control then this behaviour could be by design..... with flow control the sending nic can pause transmission if it senses that recieve buffers are full...

what nics are you using by the way?

has the transfer time improved or is it the same 10-14 minutes?
0
 
steormannAuthor Commented:


I am using Linksys Instant Gigabit (EG1032) NICs

The transfer time has improved from 10-14 minutes down to  7-10 minutes.  but this is still much slower than
the 100mbps network before.  I also replaced my old drives with (2) 80 GB WD 7200 rpm drives.

What should my flow control be set at for optimal performance.

.steormann
0
 
steormannAuthor Commented:

On the Linksys,  I have the following options for flow control:
                                  - Asymmetrical & Symmetrical
                                  - Asymmetrical Flow Control
                                  - No Flow Control
                                  - Symmetrical Flow Control

Now,  My server is running an Intel Pro/1000 MT MIC.
I have the following flow control options on it:
                                  - Both ON
                                  - Generate
                                  - Hardware Default
                                  - Off
                                  - Respond

Is this sounding more like a NIC config problem now?

Thanks.

.steormann
0
 
PaulADavisCommented:
trying to tweak the nic's is one thing to look into....

take a look at the manual for the nics if you still have them...it could shed some light on options available with each nic.... does the linksys have a pause frames count?

not familiar with the options, but be carefull of setting no flow control as that could lead to packet loss.....

i'll take a look at the options....
0
 
steormannAuthor Commented:

I'll do it.

I'm using a Netgear GS108 Gigabit Switch - unmanaged.


.steormann
0
 
ispeed-jeremyConnect With a Mentor Commented:
Netgear Gigabit switches are hopeless. We have endless problems with all Netgear products, in our company we now have a saying "Netgear ages 3 and up", it is simply toy equipment.

If you really want to get good performance out of your gigabit network, you've started at the right place with your server running an Intel Pro1000 NIC, but really, you should look at upgrading all your NIC's to Intel Pro1000 and getting a decent 1000MBPS switch ... probably Intel or Cisco are your best options. In your server, you should be running a RAID controller. I'd recommend if you want to stick with IDE, move to a 3ware IDE Raid card, and have a minimum of 3 drives in Raid5 mode.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.