Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 187
  • Last Modified:

Quad xeons showing up as 8!!

I have a wierd situation with our PowerEdge 6600, we upgraded the OS to Windows Server 2003 and now the 4 xeons show up as 8, even though these peticular processors were not supposed to have HT yet. Now I may be wrong in this assumption but it seems that HT was enabled but Intel never marketed these as HT enabled procs until later? Anyways this server runs a 4gb SQL database and obviously it's trying to use 4 real proccessors and 4 logical ones, this isnt really what I want...and since there is no way to turn off HT in the bios (because it doesnt exist) I cant find any other way to disable it. Whats funny is, if im correct, Windows Server 2003 standard only supports 4 processors anyways..so how is this happening and what can I do to disable it?

Thanks for any help
Joe
0
JoeDW
Asked:
JoeDW
  • 2
1 Solution
 
Netman66Commented:
You're kind of correct - Server 2003 supports 4 physical processors - if Hyperthreading is enabled then 8 is the number.  Update the BIOS - there should be a setting to turn off HT.

There might be a tool on Intel's site - but I can't be certain.

Here is a link to the Xeon's that have HT:

http://developer.intel.com/products/server/processors/server/xeon/index.htm
0
 
Netman66Commented:
The new BIOS version is A14.  Your server has Xeon MP processors, which are all HT.

Here is the KB article from Dell Premier Support:

How Do I Enable or Disable Hyper-Threading Technology?

You can enable or disable HT Technology through the System Setup (BIOS) program.


  NOTE: If your processor does not have the HT Technology, there will be no option in the System Setup program to enable or disable Hyper-Threading.


To enable or disable HT Technology, perform the following steps:

Reboot the computer.

When the Dell logo screen appears, press the <F2> key until the computer enters the System Setup program.

Press the <Down Arrow> key until CPU Information is highlighted.

Press the <Enter> key to display the available choices.

Press the <Up Arrow> key or the <Down Arrow> key to highlight Hyper-Threading.

 NOTE: For PowerEdge servers, the entry to highlight is Logical Processor.


Press the <Spacebar> to toggle between Enable and Disable.

Press the <Esc> key to exit from the CPU Information menu.

Press the <Esc> key to Save and Exit.

Press the <Enter> key when you are prompted to Save changes and exit now.

When the computer reboots into the operating system, general system information programs such as Device Manager and Task Manager will show two processors if you enabled HT Technology. If you disabled HT Technology, the system information programs will show one processor.


  NOTE: The General tab of System Properties will show one processor regardless if HT Technology is enabled or disabled. This is normal.



Hope this helps.
0
 
JoeDWAuthor Commented:
Thanks for the information...I looked over the Intel page, and according to that the processors I have do not have HT...these are the Xeon 1.5ghz w 256kb of L2 Cache. I will surley look into upgrading the BIOS, but I will have to find a time to do it since this is a mission critical server, I cant just take it down right now. Thanks for the help. Give me a day or so since the weekend is coming up, by then I will know...thanks again
0
 
rhrowsonCommented:
Is showing 8 CPU's an issue. Microsoft certainly only license per physical CPU, rather than per virtual one (so your server would be licensed as per a 4 CPU server, not 8). If your applications are SMP aware, hyper threading effectively throes more processors at the issue (albeit, not as effectively as real processors - but better than none)
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now