Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

missing last record in report

Posted on 2004-04-29
8
Medium Priority
?
220 Views
Last Modified: 2008-03-06
I use a msaccess97 temp table for my report.
It is a very simple report.
The crystal report 8 is connected to this temp table and display the information direct from this table.
The information in the temp table is all correct but when I use the vb6 aplicattion to call out this report the last record is missing.
0
Comment
Question by:anpeco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
8 Comments
 
LVL 42

Expert Comment

by:frodoman
ID: 10953536
Are you sure that the last record isn't just being displayed on another page?  There could be a slight difference in the spacing / fonts so a report that previews in one page in the developer may spill over to a 2nd page when using the activex viewer.

0
 
LVL 101

Expert Comment

by:mlmcc
ID: 10953999
listening
0
 

Author Comment

by:anpeco
ID: 10957000
this isn't the problem. i've tried diferent number of records. For example temp tables with 1 record will show empty reports.

If i re-order records from table to report last record table is missing in report, not last record in re-ordered report.
0
On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

 
LVL 42

Accepted Solution

by:
frodoman earned 200 total points
ID: 10958951
Is it possible that the last record hasn't been commited yet or is still in a "locked" state when the report is executed?
0
 

Author Comment

by:anpeco
ID: 10961667
That's ok.  EUREKA !!!!!
Adding "CommitTrans" instruction before report call works fine.

Now all records are displayed.

THANK'S
BEST REGARDS.
0
 
LVL 42

Expert Comment

by:frodoman
ID: 10961758
That's what I meant by the last record hasn't been committed.  So it's working now, right?
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
There have always been a lot of questions related to when Crystal Reports evaluates report components (such as formulas, summaries, cross-tabs, charts, to name a few examples). Crystal Reports uses a two-pass reporting process to provide greater …
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question