Solved

IIS6.0 UNC Shared Virtual Directory 401.3 Error

Posted on 2004-04-29
6
756 Views
Last Modified: 2013-12-04
Hey all,

I have the current setup:
- Web server (machine name "server") IIS6.0 Windows2003
- Web server has a header of "users.domain.com"
- Virtual directory named "Test"
- Virtual directory has passthru credentials enabled (the Always user the authenticated user's credentials when validating access to the network directory is checked)
- Virtual directory pointing to \\shares\Users
- Virtual directory has anon access removed
- Only Windows Authentication is enabled

- File server (machine name "shares") running Windows2003
- Share of "Users" has Everyone permissions and security set to Full Control

Both of these machines are in the same domain.

When I try to access http://users.domain.com/Test I get a credentials box which I fill out w/ the Administrator's credentials.  However, after that I'm greeted by 2 more attempts which then lead to a 401.3 error.  Does anyone know why on earth I can not for the life of me get access to that UNC share through a web browser?  Is there a local security policy that I have to set?  When I add the share to the "Shares that can be accessed anonymously" list, then I can get through, however the user is not the authenticated user, it's the ANON USER.

Thanks!
0
Comment
Question by:TivexExchange
6 Comments
 
LVL 4

Expert Comment

by:matalyn1016
ID: 10956274
Ok, this is a lot of reading but well worth it and it answers your question. - http://www.serverwatch.com/tutorials/article.php/3113161
0
 

Author Comment

by:TivexExchange
ID: 10964419
Right... I just don't understand how i'm applying FULL PERMISSIONS to Everyone both on the share and on the file system and yet I'm still getting 401.3 errors.  It would be really handy to see what exactly is being checked for and the credentials that are being used....
0
 
LVL 4

Accepted Solution

by:
WerewolfTA earned 250 total points
ID: 11597544
I'm guessing you're using this like an Intranet site, right?  We had a similar issue here.  Even though we were pointing to http://servername.domainname, which was clearly on our internal domain as the domain name ended in .local, the browser would treat it like it was in the Internet Security Zone, and refuse to pass AD credentials, prompting for logins and in some cases still refusing to let us into certain locations.  We added *.servername.domainname into the Local Intranet security group in IE, and everything cleared up.  After that, we set the same thing through Group Policy and now everyone gets the permissions they're supposed to as set with ntfs permissions on various folders using their cached credentials, no login prompts.
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Recently, I read that Microsoft has analysed statistics for their security intelligence report. It revealed: still, the clear majority of windows users do their daily work as administrator. An administrative account is a burden, security-wise. My ar…
Container Orchestration platforms empower organizations to scale their apps at an exceptional rate. This is the reason numerous innovation-driven companies are moving apps to an appropriated datacenter wide platform that empowers them to scale at a …
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now