Solved

Server has only one eye

Posted on 2004-04-29
8
214 Views
Last Modified: 2010-04-11
I have a development server that is also used for SUS updates.  SUS stopped working when I added a new NIC and site.  The new site address is .55 and the SUS server is .9.  All systems can see our intranet on .9 but if I'm at the dev server and I put in http://servername, I get the .55 site.

I unchecked dynamic update on the .55 NIC and verified that there are no .55 entries in DNS.  I put in a record in the hosts file as well pointing http://servername to .9 - still goes to the .55 site.  I've been told that if the SUS server can't see it's own site that it won't work.  How can I force this server to look at .9 when pointed to http://servername??
0
Comment
Question by:zenportafino
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 67

Expert Comment

by:sirbounty
ID: 10957327
Anything in the LMHOSTS file?
Did you flush the dns cache?
0
 
LVL 23

Expert Comment

by:rhandels
ID: 10957769
Also, if you have more DNS servers, make sure to flush on all servers and/or do a Synchronisation.
0
 
LVL 5

Expert Comment

by:richy92
ID: 10959964
*********I put in a record in the hosts file as well pointing http://servername to .9

try putting "servername       .9" in the lmhosts file (make sure it saves as just lmhosts not lmhosts.txt)

also try putting "servername.domain.domain         .9" into the hosts file (checking the filename as above)

then try accessing the server using both http://servername and http://servername.domain.domain if the entries are correct both of these should then point to .9 - this can be checked by pinging servername & servername.domain.domain at the command prompt

you need to edit the hosts file on the machine you are using to access the server (.9) - check youre not using a proxy

check the DNS domain of the machine you are trying to access from - then in that domain take a look for a host record "servername" make sure its not set to 55 - if using ddns then just delete the entry and create it manually (referencing .9)

if you cant ping the name and get the correct ip resolved at the command prompt - it will never work

0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 1

Author Comment

by:zenportafino
ID: 10966040
Did/checked  all of the above and it still goes to .55 so I disabled the .55 NIC and it goes to .9. Yeah!

When I re enable the NIC it still goes to .9 for about a minute then goes over to .55. Boo!

Again, this is only on the server that has cards  .9 and .55.  All client and server systems go to .9 which corresponds with a records on the DNS server.

The way I am verifying this is by pinging the server by name and by opening up http://servername - both always correlating. I wonder if there is a way to use the route command to force the .55 address with a higher metric and if that would work.

0
 
LVL 23

Accepted Solution

by:
rhandels earned 250 total points
ID: 10967067
Hi zenprtafoni,

Here's the command to give the 55 a higher metric.

route add 0.0.0.0 mask 0.0.0.0 x.x.x.55 metric 2

But maybe something else is wrong. If you have two network adapters, you can also try to give the NIC with the .9 address s higher priority. To do this, try the following.

1. Go to start, settings Network and Dial up connections.
2. Go to the advanced menu and choose "Advanced Options"
3. Make sure to give the .9 NIC a higher priority then the .55 NIC (you do this by choosing the .99 NIC and press the arrow up button. Make sure to have the .9 NIC above al others.

This could explain why other connect to the .9 (because of DNS) and the server itself goes to .55 (it's got a higher priority).

I see you have SUS, so i assume that u use 2003. I'm not sure if it is in the same place, but for 2000 it is, so it will probably be there.
0
 
LVL 1

Author Comment

by:zenportafino
ID: 10970612
I works!! I never saw the "advanced" pull down in network places.  Totally psycho!  Thanks again rahandels.  Know anything about Veritas logon account issues?
0
 
LVL 1

Author Comment

by:zenportafino
ID: 10970620
By the way, no need to place a route in the table. The advanced tab was the trick.
0
 
LVL 23

Expert Comment

by:rhandels
ID: 10970630
Hi Zenportafino.

Nice to know that it works. It justed kinda popped into my head... We had to install a server once and on the paper it was stated that you had to reconfigure the order. I searched for over an hour to find it. Microsoft is so nice to let use search where they put their stuff now... ;)

But no, i don't know anything about Veritas logon account issues. I assume you mean the back-up software??? You could try and post a new thread in the Storage area.
0

Featured Post

PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question