Solved

Error Occurred Reading Records?

Posted on 2004-04-30
13
1,198 Views
Last Modified: 2007-12-19
Hi everyone

I have another problem with Crystal Report 10: if I try to open some report that I could open with the previous version, it gives me the error:

"Error Occurred Reading Records: This group section cannot be printed because its condition field is nonexistent or invalid. Format the section to choose another condition field."

All the reports that give me this error, are built with subreports.
This is the only difference between the reports that I can open.

Any ideas?
Thanks
0
Comment
Question by:aletheia1
  • 4
  • 4
  • 3
  • +2
13 Comments
 
LVL 42

Assisted Solution

by:frodoman
frodoman earned 30 total points
Comment Utility
It sounds like a conditional field has an error.  Open Section Expert and click any conditional buttons that have an attached formula (they should be a different color).  Once in the formula editor click the 'check' button to check the formula for error.
0
 
LVL 100

Accepted Solution

by:
mlmcc earned 60 total points
Comment Utility
It may also be that you need to open the reports and either reimport the subreports or relink them.

mlmcc
0
 

Author Comment

by:aletheia1
Comment Utility
@ Frodoman: I don't think there is a field error, because with Crystal Report 9 it works correctly

@ Mlmcc: What do you mean with "reimport the subreports or relink them"?
What should I do exactly?

Thanks
0
 

Author Comment

by:aletheia1
Comment Utility
Mlmcc, I tried to delete and add again the subreport, but it gives me the same error...

I don't understand: after installing Crystal Report 10, only the reports including subreports stop working... what's the difference with normal report?
0
 
LVL 100

Expert Comment

by:mlmcc
Comment Utility
Have you opened the subreports individually to see if CR10 can display them?

mlmcc
0
 

Author Comment

by:aletheia1
Comment Utility
I changed the datasource within Crystal Report, and now it works... how strange, I already changed the datasource in the ASP page, why it doesn't work with CR10...
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 100

Expert Comment

by:mlmcc
Comment Utility
In the ASP page did you change the source for the subreports?

mlmcc
0
 

Author Comment

by:aletheia1
Comment Utility
Yes, I changed, and everything worked fine with CR9...

With the same syntax, with CR10, it gave me this strange error.

Now everything seems ok... to tell you the truth the order of same report is changed, I think this CR10 has many bugs (-_-)
0
 

Expert Comment

by:dtomlin
Comment Utility
We have same issue on CR10..... The developer who made this report shows it works.  All other machines ger this error - Ill watch for a solution and if we come up with one we will post for you all to see.
0
 

Expert Comment

by:dtomlin
Comment Utility
PS... We are NOT using sub reports
0
 

Assisted Solution

by:dtomlin
dtomlin earned 20 total points
Comment Utility
Hey Guys, We solved the problem... It is security  settings in IIS and the folder for the user - Thats it!  Try it and Im sure you can closeout this thread

Dan
0
 
LVL 100

Expert Comment

by:mlmcc
Comment Utility
Glad I could help

mlmcc
0
 

Expert Comment

by:ciemat
Comment Utility
Comment from ciemat
Date: 08/24/2004

Hey Guys!!!
I have the same problem with Crystal Report 10: if I try to open some report that I could open with the previous version, it gives me the error:

"Error Occurred Reading Records: This group section cannot be printed because its condition field is nonexistent or invalid. Format the section to choose another condition field."


Could you tell me how can I change the setting from IIS and the folder for the user.  

thanks
ciemat
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
There have always been a lot of questions related to when Crystal Reports evaluates report components (such as formulas, summaries, cross-tabs, charts, to name a few examples). Crystal Reports uses a two-pass reporting process to provide greater …
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now