Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 346
  • Last Modified:

Can't network WinXP computers with Windows 2000 Server

I'm trying to get Windows XP workstation computers to talk to a Windows 2000 Server, and get the 5 computers on the internet.  The setup is DSL with a modem and then an 8 port switch/router.  The workstations are set for static IP addresses.  The DLink router seems to like DHCP.  The workstations can share files/printers with the server computer, however they can't get on the internet.  When I switch the workstations from static IP to DHCP, they can get on the internet but no longer see the server.

How should I fix this so that the workstations can get on the internet and see the server?  I have read other posts and one pointed out the server should not be set for DHCP.  But I sure like this idea if I can figure out how to turn off static IP and switch to DHCP with the Window 2000 server.  

OR, should I reconfigure the router to be on the same gateway, 192.168.1.1??

I know just enough to be dangerous, but not enough about win2000 server.  

Thanks for your help
0
ChicagoComputers
Asked:
ChicagoComputers
  • 4
1 Solution
 
Pete LongTechnical ConsultantCommented:
sounds like you need to set the clients DNS settings to the SERVER then set DNS on the server to "enable forwarders" and point it to your ISP's DNS server
0
 
jonoakleyCommented:
Do you have DHCP setup on your server? XP 2000 98 and ME use an autocofigure scheme which will allow them to acces the internet without going through the server.

http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/Q220/8/74.ASP&NoWebContent=1
0
 
jonoakleyCommented:
To Test: At an XP machine open Programs--> Run--> on the resulting line type CMD
this will get you a command prompt
at the prompt type ipconfig see if the address is similar to 169.254.xxx.xxx
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
jonoakleyCommented:
Whatever your routers internal IP, make that your Default Gateway. Follow PeteLong on the DNS advice
Your router will get all packet not destined for unresolved addresses  and forward them to the external connection.
0
 
jonoakleyCommented:
opps didn't mean to make that double negative
Your router will get all packets not destined for addresses on the internal IP scheme or NAT.
0
 
ChicagoComputersAuthor Commented:
Thanks guys, when keeping the static IP addresses, it was as simple as making the gateway IP setting on the router the same as the server and workstations.  Then the workstations could use the internet and 'see' the server.  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now