Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8614
  • Last Modified:

Distributed Transaction Coordinator 2003 cluster can't online


I am following KKB article 301600 of How to configure Microsoft DTC on
Windows 2003 Cluster.

When I try to online the MSDTC Group that I created, even though all
other resources (IP,Name,Disk) are online this fails to go online.

I tried manually onlining DTC service from control panel and I get
error
"Could not start the DTC service on local Computer"

Wondering if that has anything to do with it and how do I fix it.

Thank you.

UNC
0
Unix_NT_Consultant
Asked:
Unix_NT_Consultant
  • 5
  • 5
1 Solution
 
spareticusCommented:
look in your system log for events related to the DTC resource not coming online
What are the error codes?
0
 
Unix_NT_ConsultantAuthor Commented:
Event ID 4394
MS DTC'S log information has not been configured corrrectly in the shared cluster registry : Error Specific: d:\srv03rtm\com\complus\dtc\shared\mtxclu\mtxclusetuphelper.cpp:556: CmdLine: C:\WINDOWS\system32\msdtc.exe Pid 2984

Please note this is a brand new cluster with brand new machines just built
0
 
spareticusCommented:
delete the recent DTC resource
make sure the group you created (disk, name, IP) can fail over (how many nodes?)
then create the resource again...make sure you are creating it from the machine that owns the group
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Unix_NT_ConsultantAuthor Commented:
The System Even is

The Distributed Transaction Coordinator service terminated unexpectedly. It has done this 1 time(s)

Event ID: 7034
0
 
Unix_NT_ConsultantAuthor Commented:
spareticus,

Deleted it 10 times, all groups are on the same side owned by this node.

now what ?
0
 
spareticusCommented:
0
 
spareticusCommented:
what is this mtxclusetuphelper?
0
 
Unix_NT_ConsultantAuthor Commented:
Yeah, followed everything .. I need to be able to troubleshoot since I did everything the correct way
0
 
Unix_NT_ConsultantAuthor Commented:
OK, I removed the node from the cluster and bing ! I am able to start the service.

At this point, I believe it's a bug, a cruel bug that they never tested.
0
 
spareticusCommented:
were you having this problem on just one specific node?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now