• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 980
  • Last Modified:

Installing Hard Drive (Says Unknown)

OS: Windows XP Home Edition

I am installing secondary 30GB Western Digital Hardive  in my Dell Dimension 2400. When I reboot my system it gives F1 to start windows and then in the Bios setting, the hardrive is "Unknown". After getting into the windows, it's not showing under My computer and not showing under Device Manager.

Please help me by solving this problem.

Thanks,
Paul
0
khalsa
Asked:
khalsa
  • 6
  • 6
  • 4
  • +5
1 Solution
 
Pete LongConsultantCommented:
Hi khalsa,
you need to get the BIOS to see it first or the OS never will!

is the setting for it in the BIOS set to autodetect? if so you might have to manually set its drive geometary consult the paperwork that came with the drive and ensure your BIOS is flashed to the latest version.

PeteL
0
 
CallandorCommented:
I think you need to go into disk mgmt and format it, and then Windows will see it.
0
 
CallandorCommented:
You will need it to be autodetected first, as Pete pointed out.
0
 
Pete LongConsultantCommented:
:) Not often We catch you out Callandor? have a coffee my friend

Pete
0
 
khalsaAuthor Commented:
In the Bios there two options come under this drive, the first is "Unknown" and second is none.

I don't have any paper work for this hard drive.

I thinks this topic is belong to following topic, but I could not understand how it is solved. Would you pleas read it and tell me in brief.

http://www.experts-exchange.com/Hardware/Desktops/Q_20632585.html 
0
 
compfixer101Commented:
tell you later
0
 
CallandorCommented:
Basically, the technique was to uninstall the IDE driver and install it again, without the new hard drive plugged in.  Once that happens, you shutdown, plug the new drive in, and boot.  Hopefully, your drive is recognized at that point.

Another thing you could do is reset the CMOS, in case it has some strange values that prevent the drive from being recognized.
0
 
CallandorCommented:
Pete, you caught me off guard!  ;-)
0
 
khalsaAuthor Commented:
How do you reste the CMOS?
0
 
Pete LongConsultantCommented:
unplug the pc and remove the battery from the motherboard for ten minutes :)
0
 
khalsaAuthor Commented:
I will  try this and will let you know
0
 
losgadasCommented:
Press Ctrl Alt D (not to be confused with delete) while the computer is booting up.  This is a Dell feature that allows it to configure the hardrive.

0
 
khalsaAuthor Commented:
I am able to connect secondary CD-Rom, which shows up in My computer.

I connect Hard Drive the same way, but it does not show up in My Computer and in Bois it shows "Unknown".

What could be the problem with hard drive?
0
 
CallandorCommented:
Did you try to uninstall the IDE driver and reinstall it, as the link said?
0
 
SnowguyCommented:
Is the hard rive on a ribbon by it self?
If so remove the MS/CS/SL jumper on the drive this will set it to a master only.

I assume that these are IDE drives (the most common type) and that you are trying to connect both to the same cable. When you put two drives on the one IDE cable one must be set as master and the other as slave. Or both drives to CS Cable select (I don't recommend) With only one on the cable it can be set either as master or only.

Take a look at the back of the drives near where the power and data cables plug in and you should see another small group of pins usually with a small black jumper across two of the pins (it might be a different color but black is most common). Which pair of pins this is across determines whether the drive is set to be the only one on the cable or is set to master or slave. You should find somewhere on the drive something that tells you which is which.

Put the drive that is master on the end of the cable and the slave in the middle the end that goes to the motherboard should have a grater distance from the center connector.

Also the pin 1 on the drives must match and pin one on the motherboard.
This is marked with a strip on the cable.

Also set in the BIOS to auto detect the drive(s).
0
 
tmj883Commented:
http://docs.us.dell.com/docs/storage/p40949/
Refer to this guide for Dell and WesternDigital IDE drives.
Note that Dell prefers to use CSEL settings for IDE drives. The setup is proprietary and differs from convention. Dell uses CSEL compatible cables with the Master position on the Middle connector, the Slave position is on the End. Jumper your WD drive as in the above link to CSEL. The use of IDE cables that were not supplied by Dell will complicate the setup: they should be CSEL compatible and have the correct M/S positions marked on the cable...usually different from Dell cables. Using convetional Master/Slave jumpering and cables with a Dell computer sometimes works but not always.
T
0
 
khalsaAuthor Commented:
Thanks everbody!! The problem is solved. I downloaded driver from Western Digital Hard Drive website which resolved this issue.
0
 
compfixer101Commented:
then close the question sorry about not getting to you sooner and well i was going to suggest drivers and contact dell support i had to go sorry you don'[t have to award the points to me anyhow since i was going to suggest it but didn't get it done in time
0
 
khalsaAuthor Commented:
I want to close this questoin. But don't know how, because I am new here.
0
 
CallandorCommented:
Post a note in Community Support with a link to this question, requesting a refund.
0
 
Pete LongConsultantCommented:
np - glad UR Fixed
0
 
PashaModCommented:
Closed, 125 points refunded.
PashaMod
Community Support Moderator
0
  • 6
  • 6
  • 4
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now