• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6057
  • Last Modified:

Change boot.ini in sort to boot from CD-Rom

My computer has a problem: if I will modify (or even only open) the BIOS at startup, the processor will "die". I replaced yet two processors, and I don't want to do it the third time.
By the way, the computer was configurated (before the problem appears) in sort to load directly from the hard disk, without searching for bootable floppies or CD-Roms. Now, I must to boot my computer from the CD-Rom. I think it must be possible to modify boot.ini in sort to be able to choose between booting from hard disk or CD-Rom.
For the moment, I have a menu of two OS, installed on D:\ and on E:\, two partitions of the hard drive. Now, I want to add the third item, the CD-Rom. How can I do it?

The original file is:
[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(3)\WINNT="Partition3->Work" /fastdetect
multi(0)disk(0)rdisk(0)partition(4)\WINNT="Partition4->Server" /fastdetect
2 Solutions
have you used any software overclocking programs that manipulate the BIOS to an exaggerated clock / multiplier?

if you use an Athlon, are you overclocking it (remember, a 2800XP only runs at 12.5*166FSB = 2075 ish - set it to 2800 physically, and it will refuse to boot - it is locked - if you reset the BIOS, it will 'spring to life' again...

more info is needed - at the moment you are doing the equivalent of calling a garage and saying 'it won't start' and not even telling them if it is a car of a bike  (is it red or blue??)
you tell it to boot via the BIOS - but you cannot boot to 'windows' , merely a recovery console - DOS based.
I'd recommend that you actually use the "boot from floppy" (if you can get there in the Bios) and then make a NTFS boot floppy . That way, you can edit the boot.ini file from any computer
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

boot.ini doesn't support booting from CD.  CDrom drives that will boot a computer up conform to a standard called El-Torito, this means the bios can query the device on bootup and if suitable startup files are found (boot.img) then the PC will startup from it.  The files contained in the boot.img are then expanded and the bios makes this file appear as the A:, meaning even though you booted from CD you still need to load the cd-rom drivers.

Once the harddisk has been initialised its too late to boot from CDrom.

Hope this helps
Paul SDesktop Support Manager / Network AdministratorCommented:
Try finding the manual to your motherboard. If you don't have it look on the internet. after finding it look for info on how to clear the CMOS. there should be a jumper somewhere on the motherboard.
MainMaAuthor Commented:
I am sorry, I couldn't answer before...

First at all, I solved the problem by reseting the CMOS after I "burned" the third processor. Finally, all three processors works!..

It's strange, because I didn't use overclock or something, which can "damage" CMOS. Visibly, it "burns" because there is a parameter of CMOS, that I changed, without knowing what does it mean: this is a good lesson for people like me, who like changing without understanding...

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now