• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 786
  • Last Modified:

Can't create a new database from Visual Studio .NET

I can't create database from "Server explorer" in Visual Studio .NET 2003, i get:

[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied

I have tested downloading and installing "MSDE 2000 for Developers Using Visual Studio .NET" but i get the same error.

Please help me
0
avatar-e
Asked:
avatar-e
1 Solution
 
arbertCommented:
Is this only when you create a database, or do you get connection errors when you do anything?
0
 
avatar-eAuthor Commented:
When i do anything after "Start SQL Server session" login. I try using [ ] Use integrated NT security, with my Windows login user and pass and with admin user and ever get the same error.
0
 
wengwashereCommented:
How bout using a valid SQL Server Account, like the SA? does it work if you use it?
0
2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

 
Melih SARICAIT ManagerCommented:
Check SQL server Running ..

if its running then on command Prompt Type
osql -E

see whats happening

0
 
avatar-eAuthor Commented:
How i can know my valid SQL server account? its the same than SA of my Windows XP?
0
 
Melih SARICAIT ManagerCommented:
Himmm...

SQL server account is SA.. Its the Administration User of SQL server..

U remember the password ?

Or..  check the Connection type .. Mixed mode or SQL mode ( Mixed mode = u can connect with win accounts or SQL Accounts, SQL mode = u can connect only with SQL accounts)

How to set it in MSDE 2000 ?
here is some explanation :
"Enable Mixed Mode Authentication After Installation
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
By default, the value of the LoginMode Windows registry subkey is set to 1 for Windows Authentication. To enable Mixed Mode authentication after installation, you must change this value to 2.

The location of the LoginMode subkey depends on whether you installed MSDE as the default MSDE instance or as a named instance. If you installed MSDE as the default instance, the LoginMode subkey is located in the following registry subkey:
HKLM\Software\Microsoft\MSSqlserver\MSSqlServer\LoginMode

If you installed MSDE as a named instance, the LoginMode subkey is located in the following registry subkey:
HKLM\Software\Microsoft\Microsoft SQL Server\Instance Name\MSSQLServer\LoginMode

To change the value of LoginMode to 2, follow these steps:
In Control Panel, open the Services tool to stop MSSQLSERVER and all other related services (such as SQLSERVERAgent)
To open Registry Editor, click Start, click Run, type regedt32, and then click OK.
Locate either of the following subkeys (depending on whether you installed MSDE as the default MSDE instance or as a named instance:
HKEY_LOCAL_MACHINE\Software\Microsoft\MSSqlserver\MSSqlServer\

-or-

HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Name\MSSQLServer\

In the right pane, double-click the LoginMode subkey.
In the DWORD Editor dialog box, set the value of this subkey to 2, make sure that the Hex option is selected, and then click OK.
Restart the MSSQLSERVER and the SQLSERVERAgent services for this change to take effect.
"

and the link
http://support.microsoft.com/default.aspx?scid=kb;en-us;319930

this ll help u
0
 
avatar-eAuthor Commented:
Hi non_zero, whit osql -E appear:

[Shared Memory]SQL Server does not exist or access denied.
[Shared Memory]ConnectionOpen (Connect()).

How i can start SQL Server?

(This test is without .NET running)
0
 
Melih SARICAIT ManagerCommented:
All informaiton is in here

http://download.microsoft.com/download/d/5/4/d5402c33-65de-4464-9d82-d1de2971d9db/ReadmeMSDE2000A.htm

But.

u can do this on command promt

net start MSSQLSERVER
and
net stop MSSQLSERVER <-- for stopping

or From Controlpanel->administrative tools->Services-> MSQSQLSERVER -> right click -> Start


0
 
avatar-eAuthor Commented:
MSSQLSERVER service does not exist... Studio 2003 .NET does not install it? i already have SQL Service Manager in taskbar, but say "Not Connected - \\"
0
 
avatar-eAuthor Commented:
LoginMode is in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\VSDOTNET\MSSQLServer i really change it?
0
 
Melih SARICAIT ManagerCommented:
oh ...

u create it with an instance....

thats the reason ...

u caonnto connect to SQL Server Directly ..

u must use
   "\VSDOTNET"  as the instance name. after ur serevrname..

On SQL Manager on ur task bar ..

open it... then Select ur instance..

if u cant see on the drop down list

Type localhost\Vsdontnet in the exit box... then
Connect and start it..

0
 
avatar-eAuthor Commented:
I try but i get this error:

"No se ha encontrado la ruta de acceso a red" (Spanish)

Like: "Network access not founded"

0
 
avatar-eAuthor Commented:
heeeeeeeee!!!

work with: 127.0.0.1\VSDOTNET (not with localhost\vsdotnet)

thaaaaaaaaaanks!!!! :D:D:D:D
0
 
Melih SARICAIT ManagerCommented:
ok ..

Controlpanel->administrative tools->Services ..
wot r the services starting with MSSQLSERVER ?

0

Featured Post

[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now