Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1231
  • Last Modified:

Google Home Page keeps changing from "Google.com" to a local area, i.e. Google Pilipinas or Google Australia?

What's going on with Google these days? I travel Internationally and I used a plain "Google.com" for such a long time, whereever I was. Now it seems, I'm being forced to accept "Google Pilipinas",(google.com.ph/) or "Google Australia",(google.com.au/). I've searched various questions and answers about browser hijackings but I don't think this is a hijacking.... Just something Google is trying to push over on us. I have changed my home page back to plain Google.com but it always sets itself back to the local Google, and in the local language! And even when I choose the "Google supplied option" of ENGLISH, it sometimes doesn't change. Needless to say, this is a major pain in the *SS! Is there a way for me to take back control of MY PREFERENCES to stop getting these "Local Area Googles" and get back to a plain "Google.com"?
0
GC747
Asked:
GC747
  • 7
  • 7
  • 3
  • +2
2 Solutions
 
CrazyOneCommented:
What languae is your XP? Pesonally I don't have the issue your describing.
0
 
GC747Author Commented:
My Windows XP is English. This problem has only started recently, (last few months) and I don't think you will get the same problem unless you're International.
0
 
CrazyOneCommented:
Yeah I am having a hard time visioning why this is happening unless from time to time you or somebody else that may use this machine specifies the other GOOOGLE sites.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
CrazyOneCommented:
I just know used the GOOGLE search bar it went to http://www.google.com/search?
0
 
CrazyOneCommented:
Same when I went to www.google.com
0
 
GC747Author Commented:
Additionally, I've just formatted my laptop hard drive and reinstalled Windows XP Pro from the ground up. Now, Internet Explorer on my laptop is being forced to the same Google Home page, (I'm in Manila) "Google Pilipinas" (google.com.ph/) My only suspicion is that Google has made some recent changes and is now forcing Internationally based computers to accept local Google home pages. On the Google Pilipinas home page there is an option to "Go to Google.com", but when clicked on, it doesn't work.... just stays on Google Pilipinas.
0
 
CrazyOneCommented:
Hmmm have you conversed with your ISP? Perhaps they have something to do with it.
0
 
GC747Author Commented:
No, I haven't approached them with it yet. Just for the heck of it I just clicked on the link you gave me, http://www.google.com/search? and I was taken to the regular Google.com/search. But when I edited the address bar to http://www.google.com my home page immediately went back to Google Pilipinas and in the Filipino language. When I'm at work (on my ship offshore) My Google home page is forced to Google Australia.
0
 
CrazyOneCommented:
Hmmm I am perplexed for sure but it comes across as an ISP issue to me though.
0
 
GC747Author Commented:
I posted this same question in the "Browser Issue" catagory and.....

I just received this Comment from cracky
Date: 05/01/2004 11:06PM PDT
 Comment  


A way to get around this is to type http://www.google.com/search into your address bar. This then forces Google to us .com when you type your search.

There has been much discussion as to Google's efforts to limit and control content in this manner. This brings rise to interesting censorship issues. An article worth a read on this subject:

http://cyber.law.harvard.edu/filtering/google/ 
0
 
CrazyOneCommented:
Yeah I am thinking that this may be a GOVERMENT thing. Not sure about this since I use and American ISP but it does come across as feasible. If it were me I would contact the ISP and see what they have to say about it.
0
 
GC747Author Commented:
Yes, I just took a few minutes to read the article on the below web page... very interesting.
http://cyber.law.harvard.edu/filtering/google/

I am seriously considering using Yahoo's new search engine now.
0
 
JimBsAsCommented:
Use this link: http://www.google.com/ncr

If you let is save cookies it will also save this for the future so typing google.com will work.

If you go to the foreign google.com homepage you will see "Google.com in English" which links to the page I described above.
0
 
JimBsAsCommented:
P.S. This is not a ISP/Browser Hijack issue.

This is Google's server trying to be clever.

In most cases I suppose it is the right thing to do - after all why would most people in Argentina (where I currently am) want to get google.com in English ?

I know they could use google.com.ar to get the Spanish version, the same as UK people can use google.co.uk to get a English UK version.  But google is trying to make the google.com brand universal.

So googles server determines where in the world you are (by your ISP address) and goes to that countres google.

But on all google.com pages wether in Spanish, Italian or Chinese you will see the text "Google.com in English" near the bottom as long as you got there by typing google.com

As a side note if I go to google.com/ncr (to set as US English) it tells me at the bottom "Go to Google Argentina"
0
 
gothicbloodyCommented:
1st: example my ISP data come from italy and when i go to
www.google.com it's open www.google.it
2nd :
check your regoinal and languge setting
 3rd : remove any tool bars from add/remove programm
0
 
JimBsAsCommented:
No, don't follow those examples - as I stated it is NOT a problem at your end or your ISP's end.
0
 
Andreas1975Commented:
As far as i know google analyses your current ip address. This will tell the google server where you are located at the moment (as each ISP has got it's own ip address ranges they can draw conclusions to the country / area) and they are going to redirect your browser to the local google service.
0
 
GC747Author Commented:
Hello everyone. My apologies for not getting back to this topic and finalizing but my computer gave up the ghost while I was last on line. The hard drive crashed so I have been down repairing things and upgrading my PC.
0
 
GC747Author Commented:
Hello JimBsAs. I read your answer here and at the other place I posted this same question and have given you the points here. Thanks for your input to my Google problem. I was aware of the choice on Google's home page to go to Google.com in English but it's still local unless I go through the other steps to get just plain Google.com. I agree that it may be convenient for people in various countries to have their local Google in their local language, but it would be nice if Google would let us, (the consumers) make the change if we choose and leave it at that till changed otherwise, and not force it upon us each time we log on.

My apologies for not getting back to this topic and finalizing but my computer gave up the ghost while I was last on line. The hard drive crashed so I have been down repairing things and upgrading my PC.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 7
  • 7
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now