Solved

XP laptop can't access workgroup

Posted on 2004-05-02
6
4,444 Views
Last Modified: 2012-06-21
Have a laptop that can access Internet but NO LONGER can join workgroup.  When I click "view workgroup computers", comes back with my workgroup "not accessible, check with admin on permissions".  But it does have internet access.  It has stopped working in last month and can't figure it out.

Home network has four PCs:  1) WIndows 2000 prof  2) XP home w/ problem 3) XP home w/o problem 4) XP prof on laptop also used at work.  This is a wireless network around a router connected to cable modem.  The system with Win 2K is set-up for file / print sharing.  I've no problem with #4 XP prof laptop accessing internet, seeing the workgroup (including the problem XP system), printing via the Win2K system, etc.   #3 can access the workgroup and the internet.  Just #2 has problems.  

Two other clues.  I can ping from #2 to #1 but not #1 to #2.  Also, the only thing I can think of in timing was that I changed from an Win2K work laptop to #4 roughly when the problem showed up ... although not clear cause / effect.
0
Comment
Question by:dkhydema
6 Comments
 
LVL 41

Expert Comment

by:stevenlewis
Comment Utility
check your firewall/anti virus. Usually a symptom of problems with either (some anti virus comes with firewall)
0
 
LVL 1

Accepted Solution

by:
ACSNS earned 250 total points
Comment Utility
Go to your network connection properties, click on "advanced" and make sure that the internet connection firewall is not checked.  I'm not positive, but I've seen where if this is checked, other computers on the network cannot see the computer.
0
 
LVL 1

Expert Comment

by:Nazarelfadil
Comment Utility
on computer w/proplem run the network setup wizard and restart the computer prowser service.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 11

Expert Comment

by:gothicbloody
Comment Utility
CAUSE
This issue can occur if all of the computers in a peer-to-peer workgroup do not have a common networking protocol, a common workgroup, and common user names and passwords.

TCP/IP is the default network protocol in Windows 2000, but early versions of Windows 95 and Windows 98 install the NetBEUI and IPX/SPX-Compatible Transport (Nwlink) protocols as the default protocols. Configuration settings on a computer that is running Windows 95 or Windows 98 are not retained unless you upgrade directly from Windows 95 or Windows 98 to Windows 2000 Professional. Therefore, the computer that is running Windows 2000 Professional might not have a common protocol with the existing computers on the network; this lack of a common protocol blocks connectivity. You also cannot browse the network without a common protocol.

Also, user accounts must match on the computers that are running Windows 95 or Windows 98 and the computer that is running Windows 2000 Professional. If the user name is not recognized in the Security Accounts Manager (SAM) database on the computer that is running Windows 2000 Professional, that computer cannot gain access to the shared resources.
RESOLUTION
To resolve this issue, configure the computer that is running Windows 2000 Professional to communicate with the existing peer workgroup by ensuring that all of the computers have a common networking protocol, a common workgroup, and common user names and passwords:
Check the configuration settings of the computers that are running Windows 95 or Windows 98 in Network properties:
Click Start, point to Settings, and then click Control Panel.
Double-click Network.
Review the items on the Configuration tab. Note the settings for Client for Microsoft Networks, File and Printer Sharing for Microsoft Networks, the network adapter, modem devices, and protocols such as NetBEUI, IPX/SPX-compatible protocol, and TCP/IP.

Note that peer-to-peer workgroup computers typically use NetBEUI for local LAN communication and TCP/IP for Internet connectivity.
Click the Identification tab and note the workgroup that is listed in the middle box. This is the workgroup name that the computers must have in common.
Click Cancel.
Change the network settings in Windows 2000:
Click Start, point to Settings, and then click Control Panel.
Double-click Network and Dial-up Connections.
Double-click Local Area Connection. On the File menu, click Properties. The default settings are Client for Microsoft Networks, File and Printer Sharing for Microsoft Networks, and Internet Protocol (TCP/IP). Modem settings are listed separately with a connection in the Local Area Connection Properties dialog box.
The protocols in the Local Area Connection Properties dialog box must match the protocols that you noted in step 1C (the protocols on the client computers that are running Windows 95 or Windows 98). To add a missing protocol, click Install, click Protocol in the Select Network Component Type dialog box, and then click Add. Click the protocol that you want to add, and then click OK. You might be prompted for the Windows 2000 Professional CD-ROM to install the appropriate files.
Click Close, and then click Close on the File menu.
Change the workgroup name to the workgroup name that you noted in step 1D (the workgroup name of the computers that are running Windows 95 or Windows 98). Double-click System in Control Panel, and then click the Network Identification tab. Note the current workgroup name (the default name is Workgroup), and then click Properties. In the Workgroup box, type the workgroup name that you noted in step 1D, and then click OK.
Windows 2000 generates the following message:
Welcome to the Workgroup_name workgroup.

Click OK. You receive the following message:
You must reboot this computer for the changes to take effect.

Click OK.
Quit any programs that are running, and then restart the computer that is running Windows 2000 Professional.
Validate connectivity with the other computers.
After the connectivity issues are resolved and the computers can browse each other on the common protocol and in the common workgroup, set up common user accounts:
For all of the computers that are running Windows 98, if the correct, matching user names do not exist:
Click Start, point to Settings, and then click Control Panel.
Double-click Users.
Click Next.
In the Add User dialog box, type a user name (preferably a one-word name: for example, type JDoe for John Doe), and then click Next. Type a password for the user account, and then type the password again to verify it. You can also leave the password boxes blank. The user name and password must be identical on the computer that is running Windows 98 and the computer that is running Windows 2000 Professional. Click Next.

NOTE: Passwords are case-sensitive in Windows 2000 Professional.
Select any personalized settings for the account, and then click Next. Click Finish.
For all of the computers that are running Windows 95, if the correct, matching user names do not exist:
Click Start, point to Settings, and then click Control Panel.
Double-click Passwords.
Click the User Profiles tab.
Click Users can customize their preferences and desktop settings. Click to select the Include desktop icons and Network Neighborhood contents in user settings and Include Start Menu and Program groups in user settings check boxes. Click OK to save the settings. Restart Windows 95 when you are prompted to do so.
When the computer restarts, you are prompted to log on. Type a user name (preferably a one-word name: for example, type JDoe for John Doe) and password. You can also leave the password box blank. The user name and password must be identical on the computer that is running Windows 95 and the computer that is running Windows 2000 Professional.

NOTE: Passwords are case-sensitive in Windows 2000 Professional.
After you set up a user name and password on the computer that is running Windows 95 or Windows 98, create the same user name and password on the computer that is running Windows 2000 Professional:
Click Start, point to Settings, and then click Control Panel.
Double-click Users and Passwords.
Click the Advanced tab. In the Advanced User Management section, click Advanced.
Click the Users folder. The current users are displayed in the right pane.
On the Action menu, click New User.
In the User Name box, type the user name that you created in Windows 95 or Windows 98. Type the same password (the password is case-sensitive) in the Password and Confirm Password boxes, or leave these boxes blank if you left them blank for the Windows 95 or Windows 98 user account.
Click to clear the User must change password at next logon check box. You may want to click to select the User cannot change password check box so that users cannot change the passwords at a later time. Click Create.
If you receive an error message that indicates that the password does not meet the password policy requirements, click OK, and then make the password longer (use eight characters, and consider also using numbers). After you type a longer password, click Create again. If you modify the password in Windows 2000, you must also modify the password where that password is used in Windows 95 or Windows 98.
After you create a user account for each user who logs on to the network from a computer that is running Windows 95 or Windows 98, and then create a user account for the user of the computer that is running Windows 2000 Professional, click Close. Review the user accounts that you created, and then close the Local Users and Groups dialog box. Click OK in the Users and Passwords dialog box to close it.
http://www.netswitcher.com/downloads.htm
0
 

Author Comment

by:dkhydema
Comment Utility
As a post-script, I initially skipped over the right answer, doublechecking everything others had said.  But when I changed from WLAN to LAN and I could access the workgroup, I hunted in the wireless connection properties for differences between it and a laptop that was working.  And sure enough the firewall was enabled.  And now things seem as they should.  I wouldn't say the mystery is 100% solved but I'm back in business.  Thanks very much.
0
 

Expert Comment

by:jtriley
Comment Utility
i had the exact same problem as you're describing (on a laptop with same network setup) and I just fixed it by turning the firewall off in the advanced tab as stevenlewis and ACSNS suggested.  Worked like a charm...I don't know.  
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

FIPS stands for the Federal Information Processing Standardisation and FIPS 140-2 is a collection of standards that are generically associated with hardware and software cryptography. In most cases, people can refer to this as the method of encrypti…
Trying to figure out group policy inheritance and which settings apply where can be a chore.  Here's a very simple summary I've written which might help.  Keep in mind, this is just a high-level conceptual overview where I try to avoid getting bogge…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now