?
Solved

Newbie Quest: Simple setup.

Posted on 2004-05-02
8
Medium Priority
?
244 Views
Last Modified: 2010-03-04
We are trying to set up an Apache 2.x web server. We are running SUSE linux. We have done the following and our basic sites display the apache "This page is here because the site administrator has changed the configuration of this web server" page:

*set up the following directory structure -

/usr/home/www_root/showsite/public_html/
/usr/home/www_root/showsite/public_html/cgi-bin
/usr/home/www_root/showsite/public_html/images

/usr/home/www_root/bigcompany/public_html/
/usr/home/www_root/bigcompany/public_html/cgi-bin
/usr/home/www_root/bigcompany/public_html/images

*put basic index.html in the public html dirs.

*used the following httpd.conf in the apache2 directory:

NameVirtualHost 192.168.1.18
<VirtualHost 192.168.1.18>
ServerName local.smallshop.com
DocumentRoot /usr/home/www_root/showsite/public_html/
ErrorLog /usr/home/www_root/showsite/error_log
DirectoryIndex index.html
ScriptAlias /cgi-bin/ /usr/home/www_root/showsite/public_html/cgi-bin/
<Directory /usr/home/www_root/showsite/public_html/cgi-bin>
Options +ExecCGI
AddHandler cgi-scripts .cgi .pl
</Directory>
</VirtualHost>
NameVirtualHost 192.168.1.18
<VirtualHost 192.168.1.18>
ServerName local.bigcompany.com
DocumentRoot /usr/home/www_root/bigcompany/public_html/
ErrorLog /usr/home/www_root/bigcompany/error_log
DirectoryIndex index.html
ScriptAlias /cgi-bin/ /usr/home/www_root/bigcompany/public_html/cgi-bin/
<Directory /usr/home/www_root/bigcompany/public_html/cgi-bin>
Options +ExecCGI
AddHandler cgi-scripts .cgi .pl
</Directory>
</VirtualHost>
0
Comment
Question by:TawVb
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 

Author Comment

by:TawVb
ID: 10974441
also added

192.168.1.18     local.showsite.com
192.168.1.18     local.bigcompany.com

to hosts (in etc/ dir) file to test the pages locally.
0
 
LVL 6

Expert Comment

by:philjones85
ID: 11005341
try the following httpd.conf configuration:

NameVirtualHost *
<VirtualHost *>
    ServerAdmin admin@showsite.com
    DocumentRoot /usr/home/www_root/showsite/public_html/
    ServerName local.smallshop.com
    ErrorLog /usr/home/www_root/showsite/error_log
    <Directory "/">
        AllowOverride All
        Options FollowSymLinks
        Order allow,deny
        Allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /usr/home/www_root/showsite/public_html/cgi-bin/
    <Directory "/usr/home/www_root/showsite/public_html/cgi-bin">
        Options +ExecCGI
        AddHandler cgi-scripts .cgi .pl
    </Directory>
    Alias /icons/ "/usr/home/www_root/showsite/public_html/images/"
    <Directory "/usr/home/www_root/showsite/public_html/images">
        Options Indexes MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>
<VirtualHost *>
    ServerAdmin admin@bigcompany.com
    DocumentRoot /usr/home/www_root/bigcompany/public_html/
    ServerName local.bigcompany.com
    ErrorLog /usr/home/www_root/bigcompany/error_log
    <Directory "/">
        AllowOverride All
        Options FollowSymLinks
        Order allow,deny
        Allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /usr/home/www_root/bigcompany/public_html/cgi-bin/
    <Directory "/usr/home/www_root/bigcompany/public_html/cgi-bin">
        Options +ExecCGI
        AddHandler cgi-scripts .cgi .pl
    </Directory>
    Alias /icons/ "/usr/home/www_root/bigcompany/public_html/images/"
    <Directory "/usr/home/www_root/bigcompany/public_html/images">
        Options Indexes MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>
0
 

Author Comment

by:TawVb
ID: 11011605
I tried this. When i did apachectl start it said:
invalid command <the command>. prehaps misspelled or module not included in the server configuration.

if i do
apache2ctl start it says:
(98)Adress allready in use_ Makesock.... etc...
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 6

Expert Comment

by:philjones85
ID: 11011741
make sure you don't already have apache running

type "ps -A" to see if your computer is already running "httpd"
   if it is, kill all of the "httpd" processes

is there other software already using port 80?
type "netstat -l" to see if your computer is already listening on port 80 (httpd)
  if it is, you'll need to find out what other software is using the port, and change the configuration of one of the programs


make sure apache is trying to start on port 80, httpd.conf should contain the following line:
     Listen 80
0
 

Author Comment

by:TawVb
ID: 11011824
I have tried this.
0
 
LVL 6

Expert Comment

by:philjones85
ID: 11014828
and what was the result?

is other software running on port 80? is apache already running?
0
 
LVL 15

Expert Comment

by:periwinkle
ID: 11785192
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:

    PAQ - no refund

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Periwinkle
EE Cleanup Volunteer
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 11812613
PAQed - no points refunded (of 125)

modulo
Community Support Moderator
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my time as an SEO for the last 2 years and in the questions I have assisted with on here I have always seen the need to redirect from non-www urls to their www versions. For instance redirecting http://domain.com (http://domain.com) to http…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question