• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1006
  • Last Modified:

Linksys 4 way router configuration

I have always shared my internet connection with a second PC using the win XP internt sharing facility.

I have now bought a Linksys 4 way router. In the set up I need to ask my ISP what my type of connection is.
1) DHCP
2) Static IP address
3) PPPoE
4) RAS,PPTP

Previously I used the DHCP so I assume it is DHCP for the router. Am I correct?
So, I have entered the Router MAC address into my blueyonder a/c webpage. I am still though having problems connecting via the router to the web. I can connect tot he internet fine directly attaching to my cable modem. But when I place the linksys 4 way router in between, I can not access the internet. Any help here or diagnostic tests to help me see the solution (ipconfig /all for example)?

Many thanks,
N Browning
0
nrbrowning
Asked:
nrbrowning
4 Solutions
 
sirbountyCommented:
Greetings nrbrowning,
It would help to post your ipconfig /all data
Start->Run->CMD /C IPCONFIG /ALL > C:\IP.TXT
Post the IP.txt here...

Also try these steps:

Disable all firewalls for testing.  This includes Zone Alarm, Norton Internet Security, etc.
  Including XP's ICF...
  From Control Panel, open Network Connections.
  Right-click Local Area Network from Control Panel's Network Connections and choose Properties
  Click the Advanced tab and deselect (remove the checkbox from) "Protect my computer..."
  Click OK and close out of Network Connections & Control Panel

Enable NetBIOS over TCP/IP:
  XP utilizes DNS for communication by default.  To enable the systems to communicate via NetBIOS,
  proceed as above to enter Network Connections.
  Right-click your Local Area Connection and click Properties
  Scroll down in "This connection uses the following items:" to find Internet Protocol (TCP/IP)
  Select it (highlight it) and click properties
  Click the Advanced button on the General tab.
  Click the WINS tab.
  Under NetBIOS setting heading
   Click Enable NetBIOS over TCP/IP
  Click OK, OK, OK and close out of Network Connections & Control Panel

Disable Simple File Sharing:
  Right-click the Start button and click Explore
  Click Tools then Click Folder Options
  Click the View tab
  At the bottom of the Advanced Settings list, deselect (remove the checkbox from):
   "Use simple file sharing (Recommended)"
  Click OK

Let Everyone's permissions apply to anonymous users as well:
   Click Start->Run->SECPOL.MSC /S <ENTER>
     Navigate to Local Policies/Security Options.
     Double click "Network Access:Let Everyone permissions apply to anonymous users"
     Click Enabled and click OK

Test your connectivity:
 Click Start->Run->CMD <ENTER>
    At the prompt that appears, type IPCONFIG <ENTER>
    Do you have an IP address listed (i.e. 192.168.1.100)?
    If so, try pinging the other machine by IP address:
      PING 192.168.1.101
    If you get a Reply successful, then try connecting to them...
      NET USE * \\192.168.1.101\C$ /USER:192.168.1.101\Administrator Password
    (where Administrator is an administrative account on the machine you're trying to get to)
    (and where Password is the appropriate password for that account).

Check these links for more information:
  http://www.practicallynetworked.com/sharing/troubleshoot/
  http://www.practicallynetworked.com/sharing/xp/addxp.htm
  http://support.microsoft.com/?kbid=308007

For windows XP Home edition: http://www.wmwoods.edu/ULIS/helpdesk/xpinstruct.htm
 How to Network Windows XP Home Edition (8 pages) http://support.microsoft.com/?kbid=813936

~sirbounty
0
 
ridCommented:
I assume this is a router/switch assembly with 4 ports.
Can the PC's see each other when they're connected to the router ports?
Can you browse to the router web interface (most have such a facility)?

If yes above, the network seems to work OK.

You could try using DHCP for the WAN connection of the router. Restart the modem and see what happens.

What did your ISP have to say about connection type?
/RID
0
 
Technicon-SGCommented:
nrbrowning,

In the linksys config there is an option to "clone" or "manually set" the MAC address.  Choose this option and enter the MAC address from the computer that is working correctly connected to the modem.  This can be found using "ipconfig /all"
0
 
fcislerCommented:
also, ipconfig /release on the working PC
plug modem it into router (wan)
plug PC into router (lan)
http://ip.of.the.router
look under status or dhcp or something similar, give it some time
if it dosen't take a lease, unplug modem for about 15 min (time vary's greatly, my 3com takes 2 mins...couple others i've used take forever)
plug back in modem, reset router (pull power for like 30 sec)
check IP again
if still no luck, follow Technicon-SG's suggestions to clone mac address

if you used DHCP on the NIC that the cable modem was connected to, then DHCP on the router....i am 100% positive it's now RAS or PPoE though
0
 
nrbrowningAuthor Commented:
All is fixed now. Thanks. The secret was to unplug the modem to reset which MAC address it was looking for. I also reset the router for good measure.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now