Solved

proftpd/internet explorer 'getting contents of folder' timeout error

Posted on 2004-05-03
3
2,423 Views
Last Modified: 2010-05-18
When someone tries to connect to my ftp server using internet explorer it times out with 'getting contents of folder'

using the ftp command from dos doesn't show any problems (proftpd asks for username and password and allows the user to log in and use any available ftp commands).  Only change that has been made since the time it worked is putting the ftpserver behind a linksys router.  From the router, ports 20 and 21(tcp and udp) are forwarded to the ftpserver.

The proftp logs show successful connections and nothing more.
0
Comment
Question by:Albert1809
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 500 total points
ID: 10977929
That sounds like IE trying to use PASV mode and ProFTPD & your Linksys aren't configured to allow that. What you'll want to do is to configure ProFTPD to use a limited range of the ephemeral TCP ports, say 50000-65535, and configure the Linksys to forward that port range to your FTP server. To limit ProFTPD's PASV port range you'll need to include something like:

PassivePorts 50000 65535

in the global section.
0
 
LVL 1

Author Comment

by:Albert1809
ID: 10983799
jlevie,

Your suggestion combined with the addition of 'MasqueradeAddress xxx.xxx.xxx.xxx' into proftpd.conf (http://www.castaglia.org/proftpd/doc/contrib/ProFTPD-mini-HOWTO-NAT.txt) worked.

Thanks for your help.
0
 

Expert Comment

by:Robert137
ID: 23403179
So I added this to my proftpd.conf file, then changed the firewall.

# Restrict the range of ports from which the server will select when sent the
# PASV command from a client. Use IANA-registered ephemeral port range of
# 49152-65534
PassivePorts 49152 65534
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Ubuntu Apache Webserver - File Permissions 5 73
Bash script - Exit out of choice loop 2 54
I NEED A "BARE" LINUX ... 9 86
simple bash script needed to unpack tar.gz 4 26
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question