We help IT Professionals succeed at work.
Get Started

Do I have my Frame Relay Routers Set up correctly?

HadokenShinryuken
on
452 Views
Last Modified: 2013-12-12
Hello and thank you for looking at this:
I recently cut over from one a QWEST frame cloud to a AT&T frame cloud.  All my hardware worked on the old frame cloud.

I have two sites I have connected  into my Frame Relay Cloud.  I have a seperate T1 that pipes in my I-Net traffic and I use a firewall in between.  I have both sites set up with the following configs and they both work.  I can get on the Internet.  I can access servers at both locations and everything seems to be thumbs up.. HOWEVER, a CISCO router person told me that I must not have my bridging set up properly and that is why my DTC servers do not work properly.  I guess DTC's are fairly "stupid" and are based on MAC address to allow connectivity over my WAN (we use them to print from another turn-key server).   These DTC's are known working DTC's and I have never had problems with them before until I switched over to the new frame cloud.

I pretty much pillaged the old router configs to get this to work so they are similiar to the previous frame cloud router configs.  I changed my IP address scheme and my DLC's changed.  One thing of note, my old frame cloud referred to PVC via one DLCI but when I switched to the new frame cloud provider, they gave me two dlci's, IE.  Router A (DLCI 100), Router B (DLCI 110).  Whereas I used to use DLCI 100 to connect between both Router A and Router B.  Not sure if this is causing confusion but I ended up putting on the sub interface that connected to A DLCI 100 and 110 on the sub interface of router B and it works...  Take a look at the configs if I have confused anyone.

My main router that I go through to connect to the Internet is Router "Nucla"
nucla#show run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname nucla
!
enable secret
enable password
!
!
!
!
!
ip subnet-zero
ip domain-name blahblah
ip name-server 12.127.17.72 <-- resolvers
ip name-server 12.127.16.68
!
!
!
interface Ethernet0/0
 ip address 192.168.2.1 255.255.255.0 secondary
 ip address 10.0.2.1 255.255.255.248
 no ip directed-broadcast
 no ip proxy-arp
 no ip mroute-cache
 full-duplex
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0/0.16 point-to-point
 description to ridgway
 ip address 10.0.3.1 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 frame-relay interface-dlci 105  
 bridge-group 1
!
router eigrp 100
 network 10.0.0.0
 network 192.168.0.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.2.2  <-- Out to the Internet through my firewall.. Firewall does NAT
ip route 10.0.2.0 255.255.255.248 Ethernet0/0
ip route 10.0.2.2 255.255.255.255 Ethernet0/0  <-- Not sure if I need this since I am routing all 10.0.2.0
ip route 192.168.3.0 255.255.255.0 10.0.3.2  <-- To Ridgway Router
no ip http server
!
bridge 1 protocol ieee
!
no scheduler allocate
end

==========================================
RIDGWAY router configuration:
Ridgway#show run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Ridgway
!
enable secret
enable password
!
ip subnet-zero
ip name-server 12.127.17.72
ip name-server 12.127.16.68
!
interface Ethernet0/0
 ip address 192.168.3.1 255.255.255.0
 no ip directed-broadcast
 bridge-group 1
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0/0.16 point-to-point
 description To Nucla
 ip address 10.0.3.2 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 100  
 bridge-group 1
!
router eigrp 100
 network 10.0.0.0
 network 192.168.3.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0.16
no ip http server
!        
bridge 1 protocol ieee
!
no scheduler allocate
end

Ridgway#

=======================
I am not sure if I have set this up ideally, but it DOES work.  The only thing it is having a problem with is accessing devices that use MAC addresses to get around the network.  Also, again.. the DLC's are odd.. Never used TWO DLC's to access the same PVC.. Usually just one.

I also run Voice over Frame Relay and that too no longer works even though I basically used the old working config.  Just something that might be worth mentioning.  To keep the example simple, this is just two of my sites, I do have 3 others and they two are up and working except for VOFR and the DTC Servers printing.

Edit: I failed to mention that on my old frame cloud the router was doing NAT and now this is handled by the Firewall.

Thanks for your help.
Comment
Watch Question
Systems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE