?
Solved

ftp xferlog is missing in Logwatch

Posted on 2004-07-30
7
Medium Priority
?
707 Views
Last Modified: 2012-06-21
I have logwatch (the latest version 5 ) installed in my Red Hat 9 and I receive the logwatch email everyday.

However the ftp xferlog (files that are uploading and downloading by users) is missing:

ie the following is missing:
 --------------------- ftpd-xferlog Begin ------------------------

TOTAL KB IN: 3188KB (3MB)

Incoming User FTP Transfers:
   123.123.123.1 -> /home/usr/public_html/something.jpg (User: usr)

I have already set Detail = High in the logwatch conf file but doesn't work.  How to fix this problem?
0
Comment
Question by:skinnyp
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
7 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 11687563
depending on your ftpd verison, you need to use speicial options when starting ftpd, probably -d
0
 

Author Comment

by:skinnyp
ID: 11718110
I'm using pureftp.  When I changed to proftpd I can get the ftp info from logwatch.  If using pureftp I won't get any ftp info.  I do, however when manually check at /var/log/xferlog

0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 11720048
as said before, you need to pass an option to ftp, logwatch just checks what had been written to the logfile
0
Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

 

Author Comment

by:skinnyp
ID: 11725315
How to pass the option to ftp? Which configuration has to be modified? And how?
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 2000 total points
ID: 11729081
depends on how ftpd is started.
Most likely it's started via inetd, then you need to edit /etc/inetd.conf.
Sometimes it's started via rc-script, then edit the corresponding script (in /etc/init.d usually)
0
 
LVL 97

Expert Comment

by:war1
ID: 15874158
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.
I will leave the following recommendation for this question in the Cleanup topic area:
Accept: ahoffmann (#11729081)

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

war1
EE Cleanup Volunteer
0

Featured Post

Want to be a Web Developer? Get Certified Today!

Enroll in the Certified Web Development Professional course package to learn HTML, Javascript, and PHP. Build a solid foundation to work toward your dream job!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With the rising number of cyber attacks in recent years, keeping your personal data safe has become more important than ever. The tips outlined in this article will help you keep your identitfy safe.
This article is written by John Gates, CISSP. Gates, the SNUG President-Elect, currently holds the position of Manager of Information Systems at Lake Park High School in Roselle, Illinois.
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question