How to delete SMTP connectors stuck in the queue for more than 10 days

I am using Exchange server 2003 with SBS 2003. Open relay is disabled.
My problem is,  at exchange server management console, under QUEUE there are many different domain SMTP connectors. All these connectors are at RETRY state.  I am trying to delete messages in each queue. I can only delete messages with a SENDER field. The "Delete with no NDR" is disabled.

And also most of those message that show SENDER information are from postmaster@"my domain".  

In window explorer, \exchsrvr\mailroot\vs1\queue folder is empty, \exchsrvr\mailroot\vs1\badmail folder is always filled with a lot of mails.

 
I'v been searching for solution for a while and just couldn't figure our what the problem is. Any help is greatly appreciated!


luttAsked:
Who is Participating?
 
SembeeConnect With a Mentor Commented:
Take a look at this article from Microsoft. It explains how to clean up the SMTP queues. While it is written for SBS it applies to standard Exchange as well.

http://support.microsoft.com/default.aspx?kbid=324958

Simon.
0
 
SembeeCommented:
postmaster@ are bounced email messages. Probably because the user doesn't exist. Almost certainly spam.

There are two things that you can do.
1. If you install SP1 for Exchange then the use of badmail is disabled by default. You have to do a registry hack to turn it back on. Personally I don't bother.

2. In Exchange there is the facility to drop emails sent to email address that aren't in your AD. This will wipe out a lot of spam messages. The messages are dropped at the SMTP communication level so they aren't even delivered to your system. If a legitimate user has misspelt an email address then they will get an email telling them that the user is unknown.
Enable this feature in ESM, Global Settings, Message Delivery. Right click and choose Properties. Click on Recipient Filtering and enable the feature.
Then on the SMTP virtual server (Admin Groups, <your admin group>, Servers, <your server>, Protocols, SMTP), right click, choose Properties. On the first tab click advanced, then edit. Enable "Apply Recipient Filter". Apply/OK out.

Simon.
0
 
luttAuthor Commented:
Hi Simon,

Thanks for your reply. Right now the problem is how to delete those SMTP connectors under ESM, Admin Groups, <my admin group>, Servers, <my server>, Queues.  All those connectors contain emails without SENDER information and I cannot delete them. Those are more than 10 days old.




0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.