Deleting a folder "Access is denied" and taking ownership does not work.

Posted on 2004-07-30
Last Modified: 2010-04-13
I have a server (2000) with a folder that I cannot gain back permissions and control over. The person that  previously managed the servers is no longer employed with me and I have added administrator and went to advanced and owner tab and took control but still denies me access. Is there a clobber approach I can use ? I do not need anything in this folder.

Question by:djalbright
  • 3
  • 2
  • 2
  • +3
LVL 65

Expert Comment

ID: 11682273
Hello djalbright =)

Have u tried to delete this folder thru Command Prompt ??

You receive an 'Access Denied' when you attempt to delete a folder from a mounted volume?

Author Comment

ID: 11682830
from the command prompt I still get the same thing. Either cannot find the object or access denied.

I am trying to prevent having to pull the drive out put it in another box as a secondary and delete it that way. After all it is a server with some critical applications so this would take place on the graveyard shift I suppose.

It seems like there would be a way to clobber this thing.

Expert Comment

ID: 11682973
was this directory once a part of a ftp site? A legit ftp server or non.
If your system was compromised and used as a hub to transfer illegal software, they could have manipulated the dir.
I know you can deny access or make dirs invisible through certain ftp servers.

If this happened, the only way to undo the dirs is to go through the ftp server, and use ftp raw commands.

Expert Comment

ID: 11683129

Expert Comment

ID: 11683135
before you try to find the file in a command prompt, be sure to check attributes of the file...... right click the file----select properties----uncheck read-only and hidden.....
after that, you should be able to find the file from a command prompt....

then proceed with the first method in my previous post....
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline


Expert Comment

ID: 11683140
often times when this happens it's because some program that is running has the file open.... you can also try to boot in safe mode then trying to delete the file while in safe mode......
LVL 65

Accepted Solution

SheharyaarSaahil earned 500 total points
ID: 11683499
hmmmmmmmm there is a tool called MoveOnBoot from this site >>
it says.....

Copies, moves or deletes files and folders on the next system boot. The utility is very useful when the user needs to replace or delete files which are locked by other applications, loaded into the memory or just cannot be changed until next system boot.

here is the download link >>

and here is the Description on how to use this tool(although they are talking abt another file) >>

so check it can see if u can delete that folder this way :-?

Expert Comment

by:Nabeeh ElDardery
ID: 11685439
Make sure of teh following

1. The folder is not shared and no one access any files or subfolder of it, if yes: disconnect all sessions from comp. managemt
2. try to create a new account and add it to the to the permission tab with Full control then logon with this account
3. try to rename the folder
4. check the Inheritance option
5. At last, you can make Scan disk, as if the Harddisk has a problem, will have no access to teh folder/ files located on the currepted section of teh harddisk

Expert Comment

ID: 11766424
How long is the path to the file name?  With long paths, sometimes you need to shorten the path to get rid of the file.  Start by renaming from top level and work your way down until the path name is short enough to permit deletion.  This typically happens on User Profiles but could happen elsewhere as well.

Author Comment

ID: 11834671
None of the answers were correct. I discovered that there were some DFS associations and once those were removed I was able to remove the folders without a problem.

But nevertheless, I thank all of you for your assistance. That did help me delve into the problem.


Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Restore SQL database from 8.0 to 11.00 ? 3 1,108
website 1 297
no logon server available 8 155
Can’t delete a file 14 83
NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Never store passwords in plain text or just their hash: it seems a no-brainier, but there are still plenty of people doing that. I present the why and how on this subject, offering my own real life solution that you can implement right away, bringin…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now