Solved

VB DLL Error 70 - Permission Denied in XP Pro

Posted on 2004-07-30
2
16,345 Views
Last Modified: 2011-08-18
Hi Experts

I have a custom DLL when trying to instantiate in a XP box, I get "Error 70 - Permission Denied". If i login as Administrator then this DLL works fine.

More info, I created a new folder, copied the dll into that folder, regsitered that DLL, still i got the same error.

Interesting factor i found was, I have another DLL, in another machine i got the same error, but then i figured that the if DLL file was read-only then i was getting "Error 70", after changing it to not read-only the problem was solved. But in this machine it does not work at all. The logged in user will be part of "Users" and "Powerusers" group.

I know that it is some permission setting with XP, but dont know what to change and where to change. Any help is greatly appreciated.

Application : VB6
DLL : VB6

Usage:
Dim obj as TestObject.clsTest
Get error in this line -> Set obj = New TestObject.clsTest

Thanks
Sandeep
0
Comment
Question by:Sandeepk1999
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 14

Accepted Solution

by:
aelatik earned 125 total points
ID: 11683192
Follow these steps :

1) Open Windows Explorer
2) Click on Tools
3) Click on Folder Options
4) Click on TAB "View"
5) Uncheck "Use simple file sharing"
6) Open the properties for that DLL and the groups as members
7) Open the registry and find the classname of your DLL in the HKEY_CLASSES_ROOT
8) Rightclick on the registry key you found and check the permisions on that folder.
9) If you are referencing other objects, files etc. through your DLL then make sure the groups have permissions on that to.

0
 
LVL 4

Author Comment

by:Sandeepk1999
ID: 11707269
Thanks for pointing to some direction... In registry the permissions were fine.

Found out the files themselves did not permission for the users group. Went to files, properties, security -> Add the "Users" group and give "Read and Execute" permission. This solved the problem.

Thanks
Sandeep
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most everyone who has done any programming in VB6 knows that you can do something in code like Debug.Print MyVar and that when the program runs from the IDE, the value of MyVar will be displayed in the Immediate Window. Less well known is Debug.Asse…
Article by: Martin
Here are a few simple, working, games that you can use as-is or as the basis for your own games. Tic-Tac-Toe This is one of the simplest of all games.   The game allows for a choice of who goes first and keeps track of the number of wins for…
Get people started with the utilization of class modules. Class modules can be a powerful tool in Microsoft Access. They allow you to create self-contained objects that encapsulate functionality. They can easily hide the complexity of a process from…
This lesson covers basic error handling code in Microsoft Excel using VBA. This is the first lesson in a 3-part series that uses code to loop through an Excel spreadsheet in VBA and then fix errors, taking advantage of error handling code. This l…
Suggested Courses
Course of the Month3 days, 15 hours left to enroll

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question