Solved

Upgrade to Windows XP Pro killed my home network

Posted on 2004-07-31
10
2,835 Views
Last Modified: 2013-11-16
Hello all,

Just wanted to preface this by saying I've never felt so frustrated or inadequate as a computer professional as when it comes to networking issues.

Yesterday, I got a router to replace my switch, and for a few shining hours, I actually had a bonafide home network, complete with file and print sharing.

Until I decided to upgrade our new PC from XP Home to XP Pro.

Some years ago, I had purchased a copy of Win XP Pro to upgrade an old PC, which we're now selling. This copy of Pro is one of the early versions, I bought it when it first came out.

Well, I guess my version of XP Home had newer system files or something, because when I first got it installed, several things stopped working, including the mouse and printer.

I got most everything fixed by deleting devices and letting the OS re-discover them. I even did this with the network adapter, even though my internet connection is working fine.

Anyway, I've checked all the standard stuff I can think of - worgroup name is same on both systems, I've disabled the Windows based firewall, checked TCP/IP settings.

From my other PC, I can see both PCs on the workgroup, but I cannot connect to the problem PC, nor can the problem PC see the workgroup or any shared files.

Can somebody please help me before I go bezerk?

Thanks,
Kurt
0
Comment
Question by:kurtiebird
10 Comments
 
LVL 67

Expert Comment

by:sirbounty
ID: 11685408
Can you ping from a DOS prompt?
Suggestions/steps for setting up your XP network can be found here: http:Q_21014637.html#11268699
Troubleshooting steps are listed here: http:Q_21014637.html#11268884
0
 
LVL 1

Expert Comment

by:crazynoodle
ID: 11685644
I would also be curious if you can connect from the 'problem PC' to the working machine using the ip address from

'Start' - 'Run'  then enter \\x.x.x.x    (x.x.x.x - being the ip address of the working machine)

~CN~
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 11685720
--------------------
Differences between Windows XP Home and Professional
http://www.wown.info/j_helmig/wxpdifs.htm

--------------------
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, PC-cillin (yes, some AV products have built-in firewall), VPN client (Raptor Mobile, Cisco VPN), et al.
-------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP (Pro only) machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
For complete explanation, see here:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;304040

----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines

http://www.wown.com/j_helmig/wxpwin9x.htm
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.
--------------------------

Windows XP (at least PRO) defaults a setting in Local Security Settings to something very unhelpful.
If all this does not solve your problem, check Local Security Settings, Network access: Sharing and security model for local accounts.  This may be set to (default) Guest only - local users authenticate as Guest.  Change this to Classic: local users authenticate as themselves.

Start/run: gpedit.msc
   Local Computer Policy
     Computer Configuration
      +Windows Settings
         +Security Settings
           +Local Policies
             +Security Options
         
          Double-click on Network Access:Sharing and Security Model for local accounts--
                 --change to "Classic - local users authenticate as themselves"

FOR HOME USERS ONLY WHEN ALL ELSE FAILS:
Look for and set these properties as shown also

Network access: Allow anonymous SID/Name translation     ==> Enabled
Network access: Do not allow anonymous enumeration of SAM accounts     ==> Disabled
Network access: Do not allow anonymous enumeration of SAM accounts and shares          ==> Disabled
Network access: Let Everyone permissions apply to anonymous users     ==>      Enabled

Now you may disable the Guest account as recommended for improved security (for the XP box).  Without this set properly nothing will work for XP!

---------------------------
REFERENCES:

http://www.annoyances.org/exec/show/article04-108

http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm

Troubleshooting:
http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/sag_TCPIP_pro_PingConnect.asp
http://support.microsoft.com/?id=169790
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q308007
0
 
LVL 11

Expert Comment

by:YohanShminge
ID: 11685777
Greetings kurtiebird,

You say this is an older version of XP pro...  Have you installed service pack 1 yet?  If not, I suggest you do that first, as it may solve your problems.  Just hop over to windows update and check it out: http://v4.windowsupdate.microsoft.com/en/default.asp

If that doesnt work, I suggest working through lrmoore's long, but good, list of suggestions.

-Yohan
0
 

Expert Comment

by:shautayl
ID: 11685913
how is your Network settings setup?,  Please describe what the Network information shows.  Do you have any bridged connections?

I could suggest that maybe going as far as making sure that the wires are not crossed in the wrong way may even fix the issue


ShauTayl
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 

Author Comment

by:kurtiebird
ID: 11689337
Wow - thanks everyone for the responses. I'll work my way through from top to bottom, this might take awhile.
0
 

Author Comment

by:kurtiebird
ID: 11689477
I found the following things from lmmoore's response, which fixed the problem:

1) Turned off ICF on the new PC (thought I had done that before, but it was on).
2) Uninstalled ZoneAlarm. I had taken it out of my startup group, but I forgot about the TrueVector service.
3) Enabled NETBIOS over TCPIP.

Network is working like a charm. Thanks a million, lmmoore!
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11689481
You are most welcome!
Glad you're up and running!
0
 

Author Comment

by:kurtiebird
ID: 11700537
Er, sorry about that... l-R-moore. hehe.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11701545
It's actually L-R-Moore, the font the site uses makes it look like an I.
I "R" more - hehe.. I like that.
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Suggested Solutions

This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now