Solved

pix 515e 6.3, cant access to dmz from inside

Posted on 2004-08-01
5
534 Views
Last Modified: 2010-04-09
I am not able to access dmz from inside although I can acess from outside, Im pretty confused.
I think I need some help here.. thanks


access-list acl_outside permit tcp any host 212.xx.xx.26 eq www
access-list acl_outside permit tcp any host 212.xx.xx.26 eq https
access-list acl_outside permit tcp any host 212.xx.xx.26 eq 8080

access-list acl_outside deny ip any any

access-list acl_inside permit ip host 177.xx.xx.202 any
access-list acl_inside deny ip any any
access-list 101 permit ip any 10.10.10.0 255.255.255.0
access-list acl_dmz permit ip host 126.xx.xx.9 any
access-list acl_dmz deny ip any any

ip address outside 212.xx.xx.18 255.255.255.240
ip address inside 177.xx.xx.254 255.255.248.0
ip address dmz 126.xx.xx.1 255.255.255.224

static (dmz,outside) 212.xx.xx.26 126.xx.xx.9 netmask 255.255.255.255 0 1000
static (inside,dmz) 126.xx.xx.9 177.xx.xx.202 netmask 255.255.255.255 0 1000
access-group acl_outside in interface outside
access-group acl_inside in interface inside
access-group acl_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 212.xx.xx.17 1
0
Comment
Question by:saksahin
  • 2
  • 2
5 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 11687624
You need an xlate for the dmz interface:

global (dmz) 1 interface
nat (inside) 1 177.x.x.202 255.255.255.255

Your deny statements are redundent and not necessary.
0
 

Author Comment

by:saksahin
ID: 11688668
still having the same problem. cant access to the dmz from inside.. let me post the config...



PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
enable password unQuHNVDDUkucuV/ encrypted
passwd unQuHNVDDUkucuV/ encrypted
hostname GHOPIX
domain-name alhamrani.net
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol http 8080
fixup protocol ils 389
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names

access-list acl_outside permit tcp any host 212.xx.26 eq www
access-list acl_outside permit tcp any host 212.xx.26 eq https
access-list acl_outside permit tcp any host 212.xx.26 eq 8080

access-list acl_inside permit ip host 177.xx.10 any
access-list acl_inside permit ip host 177.xx.15 any
access-list acl_inside permit ip host 177.xx.16 any
access-list acl_inside permit ip host 177.xx.17 any
access-list acl_inside permit ip host 177.xx.18 any
access-list acl_inside permit ip host 177.xx.56 any
access-list acl_inside permit ip host 177.xx.231 any
access-list acl_inside permit ip host 177.xx.232 any
access-list acl_inside permit ip host 177.xx.236 any
access-list acl_inside permit ip host 177.xx.200 any
access-list acl_inside permit ip host 177.xx.201 any
access-list acl_inside permit ip host 177.xx.205 any
access-list acl_inside permit ip host 177.xx.203 any
access-list acl_inside permit ip host 177.xx.19 any
access-list acl_inside permit ip host 177.xx.20 any
access-list acl_inside permit ip host 177.xx.21 any
access-list 101 permit ip any 10.10.10.0 255.255.255.0
access-list acl_dmz permit tcp host 177.xx.56 host 177.xx.202
pager lines 24
logging trap informational
icmp permit any inside
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside 212.xx.18 255.255.255.240
ip address inside 177.xx.254 255.255.248.0
ip address dmz 126.100.100.1 255.255.255.224
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 10.10.10.1-10.10.10.20
pdm history enable
arp timeout 14400
global (outside) 1 212.xx.113-212.xx.121 netmask 255.255.255.240
global (dmz) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 177.xx.15 255.255.255.255 0 0
nat (inside) 1 177.xx.16 255.255.255.255 0 0
nat (inside) 1 177.xx.17 255.255.255.255 0 0
nat (inside) 1 177.xx.18 255.255.255.255 0 0
nat (inside) 1 177.xx.19 255.255.255.255 0 0
nat (inside) 1 177.xx.20 255.255.255.255 0 0
nat (inside) 1 177.xx.21 255.255.255.255 0 0
nat (inside) 1 177.xx.202 255.255.255.255 0 0
static (inside,outside) 212.xx.22 177.xx.232 netmask 255.255.255.255 0 1000
static (inside,outside) 212.xx.19 177.xx.231 netmask 255.255.255.255 0 1000
static (inside,outside) 212.xx.21 177.xx.236 netmask 255.255.255.255 0 1000
static (inside,outside) 212.xx.24 177.xx.200 netmask 255.255.255.255 0 1000
static (inside,outside) 212.xx.20 177.xx.201 netmask 255.255.255.255 0 1000
static (inside,outside) 212.xx.23 177.xx.205 netmask 255.255.255.255 0 1000
static (inside,outside) 212.xx.25 177.xx.10 netmask 255.255.255.255 0 1000
static (inside,outside) 212.xx.29 177.xx.56 netmask 255.255.255.255 0 1000
static (dmz,outside) 212.xx.26 126.100.100.9 netmask 255.255.255.255 0 1000
static (inside,dmz) 126.100.100.9 177.77.16.202 netmask 255.255.255.255 0 0
access-group acl_outside in interface outside
access-group acl_inside in interface inside
access-group acl_dmz in interface dmz
route outside 0.0.0.0 0.0.0.0 212.xx.17 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
ssh timeout 5
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe 128 required
vpdn group 1 client configuration address local pptp-pool
vpdn group 1 pptp echo 120
vpdn group 1 client authentication local
vpdn username
vpdn username
vpdn username
vpdn username
vpdn username
vpdn username
vpdn username
vpdn enable outside
terminal width 80
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 11689480
Try this for troubleshooting:

no access-group acl_inside in interface inside
no access-group acl_dmz in interface dmz

You don't need the access-lists, and this is what is blocking you:
>access-list acl_dmz permit tcp host 177.xx.56 host 177.xx.202
The source host does not live on the DMZ subnet!
0
 

Expert Comment

by:NeverOutofTune
ID: 11700264
Can you be a little more specific of your problem.  Which node in the DMZ are you trying to access and what port/application are you wanting to use?  Are you wanting to use an inside translated address to access the node in the DMZ or the actual DMZ address?

You are blocking traffic with the ACL acl_dmz as lrmoore pointed out.
0
 

Author Comment

by:saksahin
ID: 11700814
access-list 101 permit ip host 177.xx.56 host 126.100.100.9
nat (inside) 0 access-list 101
static (dmz,inside) 177.xx.202 126.100.100.9 netmask 255.255.255.255 0 0
static (dmz,outside) 212.xx.26 126.100.100.9 netmask 255.255.255.255 0 0


with this way it started to work. yes lrmoore was right..
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
This video discusses moving either the default database or any database to a new volume.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now