Windows XP workgroup network : workgroup computers not visible

Hi, I have just upgraded an existing win98 network on 10base2 (coaxial) cable, to cat5E network, upgrading machines to XP. Only two machines can see and interact with one another. I have switched on netbios over tcp/ip, disabled the xp internet firewall and manually assigned TCP/IP addresses in the 192.168.1.X category, with appropriate subnet. THe two computers that do work seem to be able to function without problems, and intermittently see two of the other machines, but I am never able to "see" or access the workgroup from the remaining three computers. At the times that I see the other machines from either working machine, I get an access denied, you may not have permissions. I have browsing started, and anonymous access allowed for everyone. Simple file sharing has been switched off and permissions set at the drive root. I have tried a number of different approaches,that have been suggested, but none have resolved the issue. I note that the machines that don't work have sent packages, but have not received any. I cannot ping the machines that I can't see. I also have enabled lmhosts lookup. Advice would be appreciated.I have read similar earlier posts but none seem to have a resolution for this set of problems
abroughtAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
stevenlewisConnect With a Mentor Commented:
>>when I connect one of the "faulty machines" to the switch, using a known "good" cable, the data light on the adapter is on all the time, whereas with the working machines, it flashes - does this give any further info
yes, further indication the cable is the problem
100 mbit networks need 568 spec cable (eliminates cross talk between twisted pairs)
http://techrepublic.com.com/5102-6265-1041334.html

You might get away with non standard wiring in a 10mbit network, but 100mbit is much less forgiving
0
 
EmptyoneCommented:
If you cannot ping the computers you cannot see, then there must be something wrong with the IP setup, or there have to be som kind of firewall on. Have you installed antivirus software with built in firewall? Have you checked the cat4 cables?
0
 
abroughtAuthor Commented:
I have norton systemworks on the machines, but does norton's have an automatic internet firewall? The cables all work, cable tester showed all ok and cable swap from the outlets allows same result
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
EmptyoneCommented:
I am not that familiar with Norton, but I believe that their newest versions have firewall on as a standard yes.
0
 
PCableGuyCommented:
If a Norton firewall is on any of the problem computers, its default settings can block IP packets.

Is it Norton System Works? I don't believe System Works has a firewall. Norton Internet Security is the name of Notron's firewall.

Can the problem computers ping themselves?
0
 
PCableGuyCommented:
Correction above: Norton Internet Security is a combination Antivirus and Firewall.
0
 
stevenlewisCommented:
You should be able to ping every machine from the others, if not, it is usually a misconfigured setting in tcp (ip address or subnet mask) or a firewall issue. Once you can ping, and get permission errors, then
You don't say if XP home or Pro, but if any of the machines are pro, try this
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled, or if security is an issue, you have to add the other users (of the other machines) to each machine, and give them permissions to the shares (Note: in XP some folders are not sharable, for protection)
0
 
abroughtAuthor Commented:
All of the machines are running xp pro, local security policy editor has been enabled to let everyone permissions apply to anonymous users
0
 
abroughtAuthor Commented:
I can ping each of the adapters, and appears to be working fine. I have enabled guest account, but I don't see it on the logon screen. My account is on all machines, with the same password, but the other users do not have passwords.
0
 
PCableGuyCommented:
A link to a free packet sniffer. It might help to determine where the packets are being dropped.

http://www.ethereal.com/download.html
0
 
stevenlewisCommented:
If you can ping, then that shows connectivity
check the computer browser service, and if possible configure one to be the master borowser
http://www.winguides.com/registry/display.php/54/

1 - On the master computer, set KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\MaintainServerList

to "YES". Set this key to "NO" on the other computers. Note that any computer using

the default setting "AUTO", which is later connected to the network will not be able

to browse until the key has been set to "NO" on that machine.




0
 
abroughtAuthor Commented:
I probably misunderstood teh question about pinging the adapters. I can only ping the host adapter at each station ie I can't ping those that I can't see. For the computers that don't show the workgroup computers at all, I can't ping outside the computers own adapter.
0
 
PCableGuyCommented:
Since this is an upgrade/install, there are a number of possibilities.
A step-by-step approach to troubleshooting would help. For the computers that can't be pinged outside the adapter, I would first rule-out a cabling issue.

Take one of the bad computers and park it where a good one is, and use all the same cables. That might be a bit cumbersome, but it will go a long way towards proving if the cables are suspect.

Assuming that distance is not a problem, if you had a cross-over cable that was long enough, you might be able to bypass cabling and wall-plate cabling and do a pc-to-pc connection.

Persistence will pay-off. Hang in there.
0
 
stevenlewisCommented:
Hmmm, each machine can only ping itself?
all the link lights showing connectivity?
did you wire the cat5 yourself or buy pre-made cables?
using a hub or switch?
any other antivirus programs (some have built in firewalls)
0
 
abroughtAuthor Commented:
Yes I wired the cables myself, but checked with a network cable tester and all lights show correct connectivity. I did make a crossover cable that was long enough to connect two of the computers direct, but it made no difference. I am using a mini switch, 8 port, made by surecom
0
 
stevenlewisCommented:
>>Yes I wired the cables myself, but checked with a network cable tester and all lights show correct connectivity.

did you follow 568 B Specifications?
http://www.softcom.net/users/fdamico/cat5straight.htm
it is important
0
 
PCableGuyCommented:
Did you test the crossover on two good computers?
0
 
PCableGuyCommented:
Check the connection type of the NIC card?

Set to auto-negotiate?
Set to 100MBS Full-duplex?
Set to 100MBS Half-duplex?


Are the problem PCs different?
0
 
abroughtAuthor Commented:
No, I didn't follow 568 B specification, but could you explain to me why it is important? I have set all pins to follow the same protocol, but would readily accept that if this is important, it could be an issue. In addition to the above problems, when I connect one of the "faulty machines" to the switch, using a known "good" cable, the data light on the adapter is on all the time, whereas with the working machines, it flashes - does this give any further info?
0
 
PCableGuyConnect With a Mentor Commented:
Steven is correct, the color coding should be followed.

Another possibility:
If you installed new NIC cards, could be an issue with the NIC or PC hardware.

Have you tried swapping NICs between good and bad machines?
0
 
abroughtAuthor Commented:
I will spend some time with the hardware and cabling issues, thanks for the advice, I will see what comes with that, obvoiusly, it will take a little time to do that. I will get back once I have assessed the impact of these processes.
0
 
youre1mCommented:
I would still disabel Norton Security to make sure you are not having firewall problems. Right click it in the system tray, disable. Now go into computer management, services and stop and services Which begin with Symantec or Norton, and try again.

I've just had a home machine on our LAN with Norton on and it was causing me some grief so I disabled all Norton temporarily and it worked fine. If it does fix it you will need to look at creating rules to sort the issue out.
0
 
crissandCommented:
Uninstall the nic's drivers and download and install the last ones. And don't forget to update using Sp1(a) and the other patches from Microsoft.
0
 
abroughtAuthor Commented:
Thankyou very much for all of the assistance. I had previously a coax network, but didn't realise how much the correct standard connections mattered, according to the spec 568 B. Once I had remade the cables, all worked without a problem. What was particularly interesting was that short lengths of cat5e patch cables work fine, the longer length patch cable that I used was not to 568 B. As soon as I changed it problem over. Thanks to all esp stevenlewis and PCableGuy...have not seen this raised as an issue anywhere on web before. Thankyou
0
 
stevenlewisCommented:
Glad we could help
Steve
0
 
PCableGuyCommented:
abrought,

Thanks for letting us know what happened. All of us benefit from the solution that you followed through with.

stevenlewis: Excellent call--nice work...
0
All Courses

From novice to tech pro — start learning today.