Disable Touchpad? on Compaq Presario 2100

If I put my machine in Stand By mode and then resume, the Synaptics Touchpad re-enables itself (it was disabled before going into Stand By).

What makes this worse is that sometimes, after the machine resumes, when I push on the button above the touchpad to disable it, it does not respond.  Like it's busted.  If I give it a few minutes and try again, then it will disable the touchpad.

Is there a way to permanently disable the touchpad?

FYI - I already know that I can go into the Control Panel, select Mouse Properties, and then Device Settings, and Disable the Synaptics Touchpad.  The problem is that this is not permanent - the thing still re-enables itself after resuming from Stand By.

Thanks in advance.
Who is Participating?
CoolATIGuyConnect With a Mentor Commented:
Try booting into the bios and disabling it from there.  I know it's not the same model, but these instructions may be similar: http://tis.uwstout.edu/hd/kb/misc/How%20to%20Disable%20the%20Touch%20Pad%20on%20the%20Compaq%20N600c.htm

todd_pravataAuthor Commented:
Thanks.  Seems like that should've worked, but it did not.  There were only two options: AUTO and BOTH

AUTO - Disable the touchpad if a PS/2 mouse is detected
BOTH - Both are enabled

When I went into the setup, it was already set to AUTO.  I tried changing in and saving anyway, but no effect.  I'll try changing it to BOTH to see what happens.
todd_pravataAuthor Commented:
I am connecting my external mouse through the USB port.  I like it connecting it in the back (the PS/2 port is on the side) and the mouse happens to be USB by default.  That is, I have to add the PS/2 adapter to plug into the PS/2 port.

Once I select AUTO in the Setup options and plug the mouse into the PS/2 port, it works at it should.  So points should be awarded.  Thanks for the help.

OK, here's the deal - I'd really like to not use that PS/2 adapter (and not buy another mouse).  Maybe you have a solution to this as well?  Is there some way to tell it to detect the external pointing device on the USB port and if it finds one, automatically disable the internal pointing device?
Well, you could try going into device manager and seeing if you can disable it there...not so sure, though. :-(

todd_pravataAuthor Commented:
I did not see any way to disable it.  The only possibilities would be to uninstall the driver (I may have already tried that) or to find a driver that provided the capability to really disable it (not just for the duration of a session).

If you have any other ideas, please let me know.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.