What are the FREE components to connect to a FIREBIRD database?

Hi folks,

I´d like to know what are the FREE components (solutions) to connect to a FIREBIRD database.

I just know ZEOS.

Please, dont recommend me IBX or dbExpress, because these were developed to INTERBASE (not FIREBIRD).

Best regards.
MinimeBoyAsked:
Who is Participating?
 
corsitaConnect With a Mentor Commented:
hi,
ZUpdateSQL is like TUpdateSQL (check the delphi manual)

When u have a complex query ( a JOIN for example) and u change a record of the dataset, is a possible update for 2 or more tables at same time right? this is the case where u should use ZUpdateSQL. ZQuery cant resolve the update for itself. You link the ZQuery with a ZUpdateSQL, and use it to update the data.
It may be some work there, you are right.

if this is a real problem, go for other component, but i still recommend zeos for you.

cheers
0
 
LMuadDIbCommented:
0
 
corsitaCommented:
i HIGHLY recommend ZEOS, totally free, even for commercion apps. open source.
www.zeoslib.net

you can connect to:
Firebird 1.0 - 1.5
InterBase 5.0 - 7.5

i am using them now to connect to mysql, but i have used with firebird embedded for a small aplicattion... they did it well !

cheers!
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
MinimeBoyAuthor Commented:
Thx. guys...

Corsita, i dont know how to use ZQuery with ZUpdateSQL... It seems that there are restrictions to some SQL instructions... Do you know something?
0
 
esoftbgCommented:
I am using native Borland components from the tab InterBase of the Delphi IDE (IBTable, IBQuery, IBDatabase ...).
0
 
Ivanov_GCommented:
"Please, dont recommend me IBX or dbExpress, because these were developed to INTERBASE (not FIREBIRD)."

Interbase and Firebird are almost 100% compartible. I am using IBX (included in D7) with Firebird and I don't have problems...
0
 
MinimeBoyAuthor Commented:
Hi Ivanov, thx. for your comments.

I agree that INTERBASE and FIREBIRD were almost 100% compatible but this happened until the FIREBIRD 1.0. Now, with 1.5 and 1.5.1, it is not almost 100% compatible.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.