flash movie slowing down!!!!

My flash movie is slowing down and im not sure why.  its total size is 160k and when I go to test it the profiler is only over the red line on the first few frames.  Plus I also have a preloader.  I have a pentium 4 3.5 ghz and it sometimes is slow on my machine in a browser.  It runs fine when i go to test it but if i preview in a browser I have all sorts of slowdown (not always but about 50 percent of the time)?  What can I do to fix this???  

here is my site

    www.jasonmartin.org
nosaj462Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
hsmtpConnect With a Mentor Commented:
nosaj462,

I have about 90% CPU and 35MB of RAM used by iExplorer for your website (P4 - 1,5 GHz).
The site only works fine while it is not using 100% of CPU :)
But other aplications having difficulties running with your web-site.
0
 
hsmtpCommented:
I think the main problem in clouds. Could you post a code for moving them here?
0
 
nosaj462Author Commented:
ya i think so as well.  im moving them on the time line in a movieclip.  I dont  know how to move them in actionscript.  Would controlling them in actionscript make a difference? How would I go about moving them in actionscript?

0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
hsmtpCommented:
nosaj462,

there will be no difference in speed if you would use AS.
I had the same problem and I couldn't solve it.

Maybe you can reduce processor load if put this clouds into cycled videoclip (flv) the you will just playing this file and that's all.
But you have it 100% width. So I don't know how to solve it.
0
 
hsmtpCommented:
Here are my clouds: http://promo.samsung.ua/fishka/game/lapta/
About 50% of processor :)
0
 
nosaj462Author Commented:
is the site slowing down for you all????  IM getting feedback from other boards saying it runs fine?  Im confused with whats going on here.
0
 
nosaj462Author Commented:
man i dont get whast sucking up all that memory.  I got rid of all but one or 2 alpha transparency?  
0
 
nosaj462Author Commented:
could someone point me in the right direction as to what is taking up so much memory on my site????  I know that alpha trancparencies take up a lot of memeory so i got rid of 80 percent of them yet it still hogs up about 90 percent of cpu.  Anyone else give me any pointers I might be missing???
0
 
nosaj462Author Commented:
also if the clouds are causing me all the pain how can I animate them using actionscript?
0
 
D3C0YConnect With a Mentor Commented:
Your site is awesome. I love your work. Do you offer graphics services?

Anyway, it works fine on my pc, what do you mean slow-down? Do you think you have any actionscript that is running in any background process (which seems highly unlikely). Either way, great work.

If you animate the clouds using AS, it still would require "graphical processing" for the pc viewing your site, which (i assume) takes the same cpu-usage as a regular animation (because the end "on-screen" result is the same).
0
 
Bharat23Connect With a Mentor Commented:
The high use of gradient causes the file to slow down. Reduce the gradient effects and the file will speed up.
0
All Courses

From novice to tech pro — start learning today.