urgent: windows server 2003- how to avoid IIS connection time out.

Dear expert,

I recently bought a windows server 2003 web edition.  I've set up and run the web site with no problem.  However, I allow the server to run .asp and .aspx application, there is a script excute turn of course.  For some reason, the web server is running fast sometime when i reboot or restart IIS.  If I leave the web server for few hours and have had many people enter the site, then it causes the web run slow.  I don't know the problem due to many script excute or not.  Would anyone have a thought or have an experience of doing something to prevent thing happen like this.  Would you please share..

FYI:  I have two domains set up on the same server:  one runs .asp and .aspx and other runs .html

I don't have any problem with .html web site, but the .asp and .aspx it does

secondly,  How do i set up a remote access from outside to access to web server.?  Just in case I want to restart the IIS or restart local server.   Thanks  
princeofemAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MicrotechCommented:
The second question : do you have a firewall? if so you will need to open port 3389 and NAT it to the internal ip address of your server, and then you will need to accept incoming connections for the server, you do this by right clicking on my computer > properties> then click on the remote tab> then tick the bottom box ...

you will need the credentials of the server... and you will need your static ip to remote desktop to it.... for best security only allow your ip through on the firewall.
0
princeofemAuthor Commented:
i'm using linksys router...i personlly don't install firewall.  But i'm sure the router does..  would you be specific on question 2.  I'm not quite understand.  Where do I open port 3389 and NAT?
0
MicrotechCommented:
Right the router you are using basically is natting router. Basically routes traffic from outside ports to ip addresses to internal ports. on the web interface of your router or telnet interface you should see one of the following > port forwarding > virtual server > or something like that... if you post the exact model I can help out ..... but when we open this port other people will be able to try their luck on port 3389 ( the port used for remote desktop and terminal services).  
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Dave_DietzCommented:
What does Remote Desktop have to do with IIS running slowly?

You only need to open port 3389 for Remote Desktop (Terminal Services).

Ports 80 and 443 are what you need for IIS and you only need 443 if you are using SSL.

The web server running slowly is most likely due to problematic scripts either using a lot of CPU time or leaking resources of one sort or another.

When the scripts are running slowly what does your CPU and Memory useage look like?

Dave Dietz
0
MartijnMoreeCommented:
Is this asp built for IIS5 on Windows 2000? If so, you may have to rebuild the scripts. IIS6 is designed to recycle the worker processes and you have to adjust your code to accomodate that.
0
MicrotechCommented:
Dave I was only answering the second question
0
Dave_DietzCommented:
Oops.  Sorry.  It's a Monday and I didn't see the second part of the question.....  :-(

Dave Dietz
0
princeofemAuthor Commented:
i'm using windows server 2003.  Is there a way to not mess around with code.  My web site is running slow due to script execute.  I'm not sure how to adjust on the server.  I only have 30 users access to my .asp page and after 1 hour, the web site run slow and i have to restart IIS to clear the session.  Do you have any solution?
0
Dave_DietzCommented:
You could set the Application Pool to recycle itself after half an hour or after a certain number of requests.  You could also configure it to recylce after allocating a certain amount of memory, but that would only work if the memory usage is what's making everything run slowly.

Are there any other symptoms other than the scripts running slowly?

Dave Dietz
0
jhautaniCommented:
I have a site which uses heavy SQL queries in ASP scripts. The site was hanging after some 10-20 users before I tweaked the setting below:
 http://www.microsoft.com/resources/documentation/IIS/6/all/techref/en-us/iisRG_SCA_13.mspx
More of tuning IIS 6 can be found at:
http://www.microsoft.com/resources/documentation/IIS/6/all/techref/en-us/iisRG_SCA.mspx

hope this helps
0
princeofemAuthor Commented:
I read this article, but still did not know how to change ASPProcessorThreadMax.  Can you show me where I can change this.  I open IIS Manager, but did not see any thing like ASPProcessorThreadMax

1.
 In the IIS metabase, change ASPProcessorThreadMax from 25 (the default) to 50 threads.
 
2.
 Restart the WWW service.
 
0
jhautaniCommented:
This value and many other parameters must be edited directly to Metabase.xml, which is the IIS config file.

-At command prompt type iisreset /stop, and press ENTER. Leave the command window open.
-Open MetaBase.xml with notepad. The file is located in the systemroot\System32\Inetsrv folder.
-Search for string 'AspProcessorThreadMax' and change the value within quotes
            AspProcessorThreadMax="25"
-Save changes to MetaBase.xml.
-At the command prompt, type iisreset /start, and then press ENTER.

Manual to Metabase editing is here:
http://www.microsoft.com/resources/documentation/IIS/6/all/techref/en-us/iisRG_MET.mspx

 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
princeofemAuthor Commented:
I have changed ASPProcessorThreadMax to 50, but after 40 users using the web, and the respond time is running slow.  I have access to your link above, hearing there is a nonblocking and blocking request.  I'm not sure what is that mean.  I have changed the Applicationpools recycle work processes from 1740 down to 120 minutes, and also 192 MB for CPU memory.  I don't know if there any other option that helps server respond time quicker.  Do you have any suggestion.?  Thank you for your help.
0
jhautaniCommented:
Increase worker processes in your application pool. Setting is AppPool's Properties->Performance->Web Garden

You can try IISState tool from IIS6 Resource Kit to find out what is causing slowness. Downloadable here:
http://www.microsoft.com/downloads/details.aspx?familyid=56fc92ee-a71a-4c73-b628-ade629c89499&displaylang=en
0
princeofemAuthor Commented:
Thanks for your help.  The server is getting better now.
0
MicrotechCommented:
have you managed to NAT the firewall for external access?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.