Solved

Bios not detecting hard drive -- intermittent

Posted on 2004-08-02
11
2,261 Views
Last Modified: 2012-05-05
Suddenly, without any apparent reason, neither of my 2 hard drives are detected during boot, sometimes.  Meaning... they weren't detected using auto detect.  I changed BIOS settings to USR and put in the numbers, still not detected.  Switched back to auto detect.  I figured it might be the cable, so I put in a brand new one.  On first boot, they were detected, everything was fine.  Yippee, problem solved.  Nope.  Rebooted, again not detected.  Jiggled things around, they were detected.  Plugged in my other drives (CD, floppy) and they (the hard drives) weren't detected.  Unplugged the other drives, still not detected.  Removed/replaced the hard drive connector, they were detected.  I don't see any bent pins.   I don't know if my jiggling/replacing had any real effect -- might have just been coincidence, since sometimes that method was not effective.  Right now I am using this system while it detected the drives, so the drives are fine.  I've had these 2 drives working for at least 6 months and haven't made any changes inside the chassis recently.

If it isn't the cable or the connector, and it isn't the drives or the BIOS, what could it be?
0
Comment
Question by:robin286
  • 3
  • 3
  • 2
  • +3
11 Comments
 
LVL 44

Expert Comment

by:CrazyOne
ID: 11694613
Could be where the cables hook to the motherboard and that connector on the board could have a problem
0
 
LVL 69

Expert Comment

by:Callandor
ID: 11694618
Two possibilities: your CMOS battery is failing, or your IDE devices are causing interference.  Try each one separately, on the other IDE channel, and in another machine.
0
 
LVL 7

Expert Comment

by:magus123
ID: 11694681
options to reduce the possibilities.


A. if the hd these are using the primary ide slot , consider putting on the secondary , and doing
reboots to see if the drives continully get noticed in auto detection , if they work perfectly in
this scenario  consider adding 1 of the cd-rom drives to the primary controller and see
if gets atuotdetected , if it keeps appearing every once in a while , your primary ide
slot has failures.

1. insert a new or used hd in that tower that has never "ever" been plugged into it ,and see if the
same problems occur , if they do , then it could be power/motherboard issues. since you already
rulled out bentpins/bios configs,cables and etc.

2. insert the drives that are in that case on to another computer and see if the problems
are not being caused by the drives itself.

3. is the ribbon your using ata100 or udma66. problems like mentioned can be caused
by a incompatible ribbon cable.

4. open the case and leave 1 panel off, check to see  when the hd's are being detected
if the motor in the hd is actually performing by  looking for sounds or motion in the hd.
dont touch any of the underlying electronicsof the hds while on.

5. if the drives are farelly newer than the board , and the hd's were replacments .
they may have problems with older boards , bios upgrade would help this scenario.

6.running a manufacture diagnostic tool on the hds , can help you determine if any errors
occur durring the tests , if so the hds can be the problem

7. in testing hd issues its best to only use 1 drive in the tower.

9. molex power issues ,  consider using another molex on the drives that is being used by another
or free molex for the hd drive . a bad molex can have bad effects on startups.

these are the options that id consider taking , at the moment i cant remember of anymore,
but either way in your situation its all a matter of troubleshooting consider starting from
#1,  and crossing the checklist. it sounds like your very competent on what your doing
so id think you will be able to find the cause very soon
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 7

Expert Comment

by:magus123
ID: 11694687
to slow :] "sorry if repeat"
0
 

Author Comment

by:robin286
ID: 11694764
To rule out failing cmos battery -- I'm not getting any specific messages that indicate this.  Is there a test I can run that will show me how the battery is doing?
0
 
LVL 69

Expert Comment

by:Callandor
ID: 11694823
Either temporarily take one from another board or buy a new one - they don't cost that much.
0
 

Author Comment

by:robin286
ID: 11695223
I tilted my case to look at the battery, system froze up, had to reboot, hard drives not detected.  I removed the connector and replaced it, and then they were detected.  I neglected to mention that the system freezing up was what happened to me in the first place yesterday, forcing the reboot in which the HDs weren't detected. I'm running XP and haven't added anything new lately.  I run antivirus and spyware checks daily and keep those current.  Don't know if that info is relevant, but I thought I'd include it just in case.

So, I will replace CMOS battery and see if that helps.  I have a lot of cables laying around.  How can I visually tell the difference between ATA and UDMA?  (The cable I am using now has the blue connecting into the MB, with a black connector to the master and gray to the slave, with the red stripe along pin 1.)

If it is the connector (molex?) itself -- how can I replace that? It doesn't look like a removable part on the MB.  I have a MSI 845E Max (MS-6566e ATX Mainboard).

When BIOS does detect the drives, everything appears fine.  And like I said, it's been doing fine for months -- this just happened out of the blue.  Which leads me to believe that something has now gone bad or is going bad.  
0
 
LVL 31

Assisted Solution

by:rid
rid earned 100 total points
ID: 11695460
System freezing when you tilt it?
Sounds like a bad connection somewhere, not necessarily to do with the hard drives. Check all components for proper seating (CPU/heatsink, RAM modules, etc) and make sure there are no loose screws or similar that may be doing intermittent mischief as you reseat connectors and such. Also, power connectors should be checked and all cabling to floppy drive too.
/RID
0
 
LVL 69

Accepted Solution

by:
Callandor earned 150 total points
ID: 11695574
If the system froze up when you tilted it, you have something loose or shorting.  Follow RID's advice and check connections and cables.  This may be the source of your problems, and not the CMOS battery.
0
 
LVL 92

Expert Comment

by:nobus
ID: 11701862
if necessary, remove everything from the case, inspect all connectors and fixings, and rebuild it from scratch.

nobus
0
 

Author Comment

by:robin286
ID: 11705119
I pushed around on all connections, a couple of them felt slightly loose but I didn't have any "eureka" moments.  However, I was able to plug in all drives and have the darn thing boot properly several times, so that must have been it.  Thanks for all the help, guys!!
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
File copy time stamp question 6 83
deduplication > shared folder size weirdness? 1 44
Drivers  Repository for Win 7 13 58
SAS 12gb/s Drives on SAS 6gb/s Controller? 3 33
Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question