Solved

How to end a process on task manager

Posted on 2004-08-02
21
1,658 Views
Last Modified: 2013-12-03
How do i end a process on the task mangager.
I tried to stop it but it says opeartion failed.
The process is Called "tmsrv.exe" and is using 99% since the server started. It's is slowing down the server( which is DB) and nobody can use it on the network.

Help
0
Comment
Question by:Ygal_Benabou
  • 5
  • 4
  • 3
  • +8
21 Comments
 
LVL 1

Expert Comment

by:jesselavaca
ID: 11695396
Press CTRL+SHIFT+ESC to bring up the proccesses window...

Right click the process..
Try ending the process, try ending the process tree, and if that doesn't work you could change the priority so that other applications can still run.

If you wanted to prevent it from starting up, click Start -> Run
type msconfig
and remove it from the Startup tab. note: there might be administrative issues with this if you are on a network (i.e. having the correct permissions to load msconfig).

Hope that helps...

-Jess
0
 

Author Comment

by:Ygal_Benabou
ID: 11695425
I can't end it it says operation failed because of administrative rights, but i'm logged as the admin.
Also i can't change the priority of the process.
By the way the process is "termsrv.exe" i don't know if it can help.

Please i need an anwer.

Thank you guys
0
 

Author Comment

by:Ygal_Benabou
ID: 11695432
Ms Config will not run, same thing operation failed....
0
 
LVL 1

Expert Comment

by:jesselavaca
ID: 11695466
What version of Windows?  Have you tried Safe Mode?  You could try running msconfig in Safe Mode (or manually allowing/disallowing each option) so you can keep this from loading.  

-Jess
0
 
LVL 1

Expert Comment

by:jesselavaca
ID: 11695539
Just another general thought...
Make sure all critical updates are installed..
Internet Explorer - Tools -> Windows Update
and make sure the latest Virus Definitions for your antivirus are installed, just in case it's some sort of bug or virus.

I'm looking into termserv.exe right now...

-Jess
0
 
LVL 1

Expert Comment

by:jesselavaca
ID: 11695635
Sounds like a virus.  

I just read an article on security, hackers tend to hide things using that name.

Here's the content of the slide called Hacker Tricks (2):
"What they do:
-Hide folders
-Make folders “hidden/system”
-Hide under “\System Volume Information”
-Use “invalid” names: \winnt\system32\spool\help\aux\.tmp
-Use plausible names: termserv.exe"

So another option to kill this problem would be to use a bootable CD-ROM (or floppy) that has an antivirus program on it.  Hopefully loading with that will identify and kill the process.  More freeware options are Ad-Aware, HijackThis, Spybot Search & Destroy, and PestPatrol.  

Let us know as things happen...

-Jess


0
 
LVL 6

Expert Comment

by:JaffaKREE
ID: 11696330
termsrv.exe is terminal services.

try stopping the service.

also, check this for commands -

http://dev.remotenetworktechnology.com/cmd/tscmd.htm
0
 

Author Comment

by:Ygal_Benabou
ID: 11697597
I can't stop termsrv.exe
Also i can't acces msconfig, it says cannot find msconfig...
I ran adaware on the server in safe mode. It allowed the server to boot normally and wasn't slow anymore, but the process is still here and i can't stop it..

0
 
LVL 20

Accepted Solution

by:
DVation191 earned 350 total points
ID: 11697665
If you are using windows 2000, thats why msconfig doesn't work. if you are using winxp, thats almost certainly virus activity.

try getting windows startup inspector here .. http://www.windowsstartup.com/download.php
it should let you disable that process from startup.

if you are using xp, and msconfig is missing, check for viruses... http://housecall.antivirus.com/
0
 
LVL 20

Expert Comment

by:DVation191
ID: 11697710
You can always use Process Explorer to end a process as well.. it's free..
http://www.sysinternals.com/files/procexpnt.zip
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 

Expert Comment

by:DANNiED
ID: 11697864
ok the reason you cant find msconfig is becasue that is only in versions of win95,98, and ME

In win2k and xp this file dose not exsist.

what i would reccomend doing is going to the start run menu and typing in regedit

once in regedit highlight the computer on the left half of the window press F3 (also "find" on the top edit menu) type in the name of the file, in your case "termsrv.exe" and when you find the tab/window on the left that says

HKEY_LOCAL_MACHINE
         \SOFTWARE
                 \Microsoft
                       \Windows
                               \CurrentVersion
                                                   \Run

In the main window on the right you will see a list of items that load on startup Im almost possitive you will find it in there just delete the key and you should be good to go or at least not loading it when the unit starts.
                   
0
 
LVL 20

Expert Comment

by:DVation191
ID: 11697945
msconfig is definitely in windows xp, and if you are unfamilar with the registry, using a program to make the changes is a much safer procedure.
0
 
LVL 4

Expert Comment

by:miloudi
ID: 11698756

Hi,

You have win2000(server may be), msconfig is not available..
tmsrv.exe is from i found out a Sample timecard application.
So did u install that lately, try t remeber what you added to the server lately...?
If you don't know your way out in the registry please don't go there.
msconfig for win2000:
http://www.onecomputerguy.com/windows2000_tips.htm#msconfig
Try it and let us know....

PS: 98-ME-XP all have their versions of msconfig except 2000-2000 server

 
0
 
LVL 4

Expert Comment

by:miloudi
ID: 11698866


forgot to mention that when you save the zip file to your desktop, you should save it onto winnt\system32 directory...
..
0
 
LVL 20

Expert Comment

by:DVation191
ID: 11699108
just thought i'd point out that tmsrv.exe is actually a Terminal Server Emulator that is part of Windows 2000...although there certainly exists the possibility that there are other applications that use the same name.
0
 
LVL 8

Expert Comment

by:MarkDozier
ID: 11701396
tmserv.exe is not terminal services it is part of a sample timecard application.

Here is a replacemtn for msconfig
Startup Control Panel from  http://mlin.net/

It beats the pants off MSCONFIG
I bet you sovle the problem using startip control panel
0
 
LVL 20

Expert Comment

by:DVation191
ID: 11703450
Yea sorry about that...searched for the wrong .exe
0
 
LVL 1

Expert Comment

by:Invalidlogin
ID: 11711568
You can go to a xp machine, search for msconfig.exe copy it to a floppy copy it to your machine and run it, done this many times works for me

Good Luck
0
 
LVL 23

Expert Comment

by:DanCh99
ID: 11714097
if it is TERMSRV.EXE then it is Terminal Services.  As stated above, you should be able to stop the service, and this will stop the process.  Once this is done, remove Terminal Services as a Windows Component from Add/Remove Programs.  This will probably need a reboot.

if it completely won't die, the 2000 Server Resource Kit tool, KILL.EXE can be handy
usage (in this case):
KILL TERMSRV.EXE
or you can use the PID aka Process ID (shown in Task Manager, on the Processes tab):
KILL 404
(your PID number will be different!)

you might also want to check why TS is going berzerk - if it's not used, I'd just uninstall it; if it is, use it's management console to check who's connecting, and what they're doing.  Maybe even uninstall, reboot, and reinstall.
0
 

Expert Comment

by:fatp
ID: 11727864
I allready saw a msaccess comsuming 50% of the cpu on a session that was allready disconnected....the solution was to reboot the server.  
0
 
LVL 1

Expert Comment

by:stepstraight
ID: 11781925
snag a program called prcview, it works great at killing applications....effectiveness ranks up there with xkill on linux boxes...
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Is it worth it to buy an Echo? In a word, yes! For me it was definitely worth it. I use mine on a daily basis. Prologue & Privacy At first, I was very skeptical about the Amazon Echo. In general, I don't like voice assistants. I don't li…
this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now