Solved

Crystal RAS and Active X or Java Plugins

Posted on 2004-08-02
7
954 Views
Last Modified: 2013-11-18
How do you use Active X or Java with eportfolio.  I tried to uncomment the active X and Java plugins so that i can select it in the viewer selection in preferences. When I try to run a report in RAS it installs the plugins but  I get "Error Ocurred on Server. -2147217394 : Missing Parameters"  The report works fine using HTML.

Please help, urgent.

Thanks!
0
Comment
Question by:jkokado
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 42

Expert Comment

by:frodoman
ID: 11696909
What version of Crystal Enterprise are you running?  If it's 9, try installing all patches (which you can get here http://support.businessobjects.com/fix/hot/si75/default.asp?ref=default.asp_wwwjump#Crystal%20Enterprise%20Service%20Packs ) and hotfixes (from here: http://support.businessobjects.com/fix/hot/mhf/crystalenterprise.asp#01).

This sounds like one of several parameter related bugs w/ CE9.

If you're not running CE9 please advise which version you do have.

frodoman
0
 

Author Comment

by:jkokado
ID: 11698759
Thanks for replying frodoman.  

I am using CE 9 Report Application Server (RAS).    

As to your hunch... I downloaded the service pack 2 for CE9. But, I am getting an error "Failed to create backup folder -110" when trying to install it.   I am trying to resolve this.  But, in the mean time if you  know what the problem with this error is please let me know.  It doesn't seem to be a security issue nor HD space.    

Thanks again for trying help...
0
 
LVL 42

Expert Comment

by:frodoman
ID: 11704017
Sure sounds like a permissions issue - like Crystal is trying to create a backup folder to copy files and is unable to do so.  Does it indicate which folder it's trying to create?  You may want to open up permissions in that folder while you install the patch and then close them down after.

I'll check around and let you know if I find anything.

frodoman
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 42

Expert Comment

by:frodoman
ID: 11704054
Page 5 of this document shows the typcial folders where the backup would be placed so you can check there for permissions: http://support.businessobjects.com/communityCS/TechnicalPapers/hot_fix_faq.pdf

Also note that the service packs read the system registry to find the location where CE was originally installed and look there for the files to be replaced.  If for any reason you've moved the folder containing CE or moved the relevant files to another folder then the service pack installation will fail.

frodoman
0
 

Author Comment

by:jkokado
ID: 11708036
I found out I was installing the wrong service pack.  I have all the hot fixes installed now.  Still the same error occurring when I run the report.  

I did some more reading and it looks like I will need to develop on my own active x or java to work for eportfolio to support database logins and parameters.  I have the samples but do not know where to start.  I have no idea where to place these samples in a virtual directory etc..

Looks like this is a long road ahead.

Any advice?  
0
 
LVL 42

Accepted Solution

by:
frodoman earned 500 total points
ID: 11714426
>>> I did some more reading and it looks like I will need to develop on my own active x or java to work for eportfolio to support database logins and parameters

I'm guessing you don't have the full version of Crystal Enterprise - are you running CE Express?  If so then unfortunately I don't have any advice for you as we're running the full version.  You may want to look around and see if there are third party plugin's already available though - I'm not sure about licensing issues but it may be worth checking before you go through all the effort of developing your own.

Good luck,

frodoman
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Before we dive into the marketing strategies involved with creating an effective homepage, it’s crucial that EE members know what a homepage is. In essence, a homepage is the introductory, or default page, of a website that typically highlights the …
Never store passwords in plain text or just their hash: it seems a no-brainier, but there are still plenty of people doing that. I present the why and how on this subject, offering my own real life solution that you can implement right away, bringin…
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question