Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Cisco PIX 501 - Remote Desktop over VPN?

Posted on 2004-08-02
2
Medium Priority
?
2,783 Views
Last Modified: 2013-11-16
Hope someone can help out with this - oh and of course, this is urgent.

Cisco PIX 501 at xxx.xxx.xxx.131

VPN clients using Cisco VPN client 4.0.3 can connect successfully.  Can ping and access server inside at 192.168.1.50.  

Now trying to RDP to a Windows XP workstation at 192.168.1.111 with no luck.  Stumped.  Help is much appreciated.  Here's my config:


PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password NctHeUP226rJyzPl encrypted
passwd CLMaWgGXS98Vph1v encrypted
hostname pixfirewall
domain-name inc
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.50 server
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.100.0 255.255.255.240
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list 101 permit ip any 192.168.100.0 255.255.255.0
access-list outside_cryptomap_dyn_40 permit ip any 192.168.100.0 255.255.255.240
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside XXX.XXX.XXX.131 255.255.255.224
ip address inside 192.168.1.1 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.100.1-192.168.100.10
pdm location server 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 192.168.100.0 192.168.100.0 netmask 255.255.255.0 0 0
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.129 1
route inside 192.168.100.0 255.255.255.0 192.168.1.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map dynmap 10 set transform-set myset
crypto dynamic-map dynmap 30 match address outside_cryptomap_dyn_30
crypto dynamic-map dynmap 30 set transform-set myset
crypto dynamic-map inside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
crypto map mymap1 10 ipsec-isakmp dynamic dynmap
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface inside
isakmp enable outside
isakmp enable inside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup test address-pool ippool
vpngroup test dns-server server
vpngroup test wins-server server
vpngroup test default-domain inc
vpngroup test idle-time 1800
vpngroup test password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80

0
Comment
Question by:rnicolaus
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 36

Accepted Solution

by:
grblades earned 2000 total points
ID: 11697746
Hi rnicolaus,
If you can access one server but not another then it would normally be a configuration issue on the server.
Can you ping 192.168.1.111?
Has the machine got the PIX as the default gateway?
Have you made sure there is no firewall running?
0
 
LVL 6

Author Comment

by:rnicolaus
ID: 11699251
Thank you grblades -

You were right on with the def gateway on the Remote Desktop host!  Changed it to the PIX and it worked immediately.  Thank you for your quick response!
0

Featured Post

Looking for the Wi-Fi vendor that's right for you?

We know how difficult it can be to evaluate Wi-Fi vendors, so we created this helpful Wi-Fi Buyer's Guide to help you find the Wi-Fi vendor that's right for your business! Download the guide and get started on our checklist today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
On Feb. 28, Amazon’s Simple Storage Service (S3) went down after an employee issued the wrong command during a debugging exercise. Among those affected were big names like Netflix, Spotify and Expedia.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question