Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 652
  • Last Modified:

Networking WinXP and WinNT

I have a winNT 4.0 server and all the machines login to that server. I got this new WinXP machine and I dont know how to make the settings in WinXP machine so that it can log in to WinNT. WinNT server is my domain server.

Thanks
0
anujdhingra
Asked:
anujdhingra
  • 5
  • 4
  • 2
  • +3
1 Solution
 
EricIT ManagerCommented:
right click my computer, click properties
click computer name tab
click change button
name the computer, choose domain checkbox, enter domain name
you will need an administrators logon to verify.

This is assuming xp can connect to a 4.0 domain.  I can not think of any reason it would not connect.



0
 
jonoakleyCommented:
If you have XP Home ecszone answer is not applicable. XP Home cannot join a domain
0
 
anujdhingraAuthor Commented:
I have winXP PRO.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
irjeffbCommented:
ecszone is correct, and I can verify that XP will log in to an NT4 domain just fine.  We have probably 50 XP machines in our NT4 domain without any problems.
0
 
jonoakleyCommented:
Follow ecszone for the proper procedure
irjeffb Your XP systems are most likely Pro. If any are XP Home please post how to add them to a domain, I am sure many EE posters would love to read how.
0
 
jonoakleyCommented:
There are some configuration issues having to do with DNS and security policies. But in a standard configuration there shouldn't be any problems.

anujdhingra -- Did esczone solution work for you?
0
 
EricIT ManagerCommented:
Poor Xp having to use netlogon vs GPO  :(
I vote you upgrade to 2003 server while your at it :D

XP home is donkey poo in a pretty box.
0
 
jonoakleyCommented:
You have a higher respect of XP Home than I do. 8 )
0
 
lrmooreCommented:
All of the following is good information, but bottom line up front:
You need two things enabled:
1. Netbios over TCP/IP
2. WINS (or LMHOSTS)
Suggest enabling WINS on the NT server if it is not already.

Create LMHOSTS file with just the domain controller information (two entries)

How to Write an LMHOSTS File for Domain Validation and Other Name Resolution Issues
http://support.microsoft.com/support/kb/articles/Q180/0/94.ASP 

--------------------
Differences between Windows XP Home and Professional
http://www.wown.info/j_helmig/wxpdifs.htm

--------------------
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, PC-cillin (yes, some AV products have built-in firewall), VPN client (Raptor Mobile, Cisco VPN), et al.
-------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP (Pro only) machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
For complete explanation, see here:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;304040

----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines

http://www.wown.com/j_helmig/wxpwin9x.htm
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.
--------------------------

Windows XP (at least PRO) defaults a setting in Local Security Settings to something very unhelpful.
If all this does not solve your problem, check Local Security Settings, Network access: Sharing and security model for local accounts.  This may be set to (default) Guest only - local users authenticate as Guest.  Change this to Classic: local users authenticate as themselves.

Start/run: gpedit.msc
   Local Computer Policy
     Computer Configuration
      +Windows Settings
         +Security Settings
           +Local Policies
             +Security Options
         
          Double-click on Network Access:Sharing and Security Model for local accounts--
                 --change to "Classic - local users authenticate as themselves"
0
 
anujdhingraAuthor Commented:
I was able toconnect to my domain with ecszone's suggestion but the problem is that doing this created a new user and all my prev settings are lost if I log in to that domain. If I log in to the this computer domain, I retain all my prev settings.

Any suggestions??

`A
0
 
AshuraKnightCommented:
Apply your computer settings to that Win NT Server settings.

If i'm not mistaken, when you connect to certain domain then you need username for that domain and the settings applied is from that server, right ?
0
 
EricIT ManagerCommented:
login as old user domain = computer name
Use "files and settings transfer wizzard".
(start | programs | accessories | system tools)
using old computer option
archive settings to a folder on the HD vs. a floppy or what direct connection. (other, browse to root folder or something)
logout
logon as the new domain profile
start wizard again but "new computer" option.
follow the prompts.. done.
Works pretty good... less hastle than manually doing a profile copy.


0
 
EricIT ManagerCommented:
official info:
http://support.microsoft.com/?kbid=293118

it creates a folder with an image in it... when its all done you may want to delete that folder.. (big)
the folder name is something ".usmt"  i think.

Good luck.

Tip: purge temp internet files etc.. to speed up the process. empty recycle.. do a diskcleanup also may help.
took mine about 30 minutes begining to end, but I have a metric sh1tload of stuff to archive.
0
 
EricIT ManagerCommented:
Thanks.
Get all your files xfered?  Use "files and settings xfer wizard"?
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 4
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now