Solved

IE shows blank page, but View Source shows the code???

Posted on 2004-08-02
8
305 Views
Last Modified: 2008-03-04
Hi,

I am using IE 6 and for some reason, I get a blank page when I try to view a file.

For some reason I can view the source of the page,  and see all the code, but it displays a blank page...

It is very frustrating.. any idea what it might be?

the page is like www.abc.com/index2.cfm

Any idea why??

-WS
0
Comment
Question by:Westside2004
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
8 Comments
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 11697984
Hello Westside2004 =)

You cannot open a new Internet Explorer window or nothing occurs after you click a link
http://support.microsoft.com/default.aspx?scid=kb;EN-US;281679

!! GOOD LUCK !!
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 11698050
and if it XP then u can try running this tool:
http://www.mvps.org/sramesh2k/IEFIX.htm
0
 
LVL 1

Author Comment

by:Westside2004
ID: 11698297
Hi,

I can open pages fine... its just for some reason, this one page I can't open.... it just shows a blank window..

I would say I can open 100 web pages easily... and view them all fine... however I am hosting internally my site, and this page is residing on my web server (IIS 5.0) and for some reason it shows blank when I try to view the page...

There are 50+ others pages in my site, and I can view them all fine...

Not sure why one page would not be visible... no error or anything, just a blank window and it says 'done' in the bottom of the screen

-West
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
LVL 36

Expert Comment

by:Zyloch
ID: 11699399
Are you viewing the page from your IIS server? If so, try doing http://localhost/index2.cfm

Regards,
${Zyloch}
0
 
LVL 1

Author Comment

by:Westside2004
ID: 11700577
Hi,

The server is remote.. so I go to our website address.

www.mysite.com/index2.cfm

It seems to be now happening with another file...

Its weird other files in same directory show up fine... but all of a sudden now another file is not showing up.. I view source and all the code is there.. but page is blank..

Weird..

-WEstSiDE
0
 
LVL 36

Accepted Solution

by:
Zyloch earned 125 total points
ID: 11700672
That is odd. Make sure it's not your computer by following these steps:

1) Reboot (if you haven't)
2) Download Adaware from http://www.lavasoftusa.com/
3) Download Spybot S&D from http://www.safer-networking.org/en/index.html
4) Run both and delete what you find.
5) Run Immunize on S&D to prevent future spyware.
6) Start, Run, sfc /scannow.
7) Start, Run, %TEMP% delete everything in there.
8) If still no good after you do all that and restart your computer again, do the steps below:
9) http://www.mvps.org/sramesh2k/IEFIX.htm and download the fix (looks promising)

Regards,
${Zyloch}
0
 
LVL 1

Author Comment

by:Westside2004
ID: 11712429
Hi,

Thanks for the tips, I run S&D already, have been for past 5 months or so.. seems to work fairly good.......

I was able to fix the problem.. it was 1 of 2 things..

On the page that was coming up blank.. it turned out it had some empty <style> tags as if for css, meaning I had them in there, but no actual styles were defined.

It was either that or me running the debugging feature in ColdFusion, I highly doubt it was this, but I deleted the empty style tags, and turned off debugging, and it worked... so most likely it was those empty style tags.... I dont understand why it would make my page blank, but when I view source I see code....

However your idea to the problem is good and what I initially thought months ago. For that reason I had S&D already and cleaned it over and over months ago.  I had this one file in my site that came up blank and all other files get viewed fine... .i would rename the file, didnt matter, couldn't view it...

So I am not sure about the points.. and how it works, don't want to offend someone... can I give you half?

Thanks

-West
0
 
LVL 36

Expert Comment

by:Zyloch
ID: 11715111
The points don't really matter at all. In fact, you can put in a request to refund your points since you solved the problem on your own, but it's mainly your decision
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Now-a-days, indirectly, postal services have been replaced by email services. Yes, whenever we hear the word "email" a lot of people only think of gmail. Some people still think that email and gmail are one and the same thing :-). Let's see some …
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question