Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 269
  • Last Modified:

XP Home File Sharing Continual Failures

I've set the full security settings to allow everyone access to a shared filespace on an XP Home machine (using Admin login) and it works fine...for awhile.  However a few minutes later select files start to be "unavailable" for remote access.  This happens to both exe files, mdb databases, excel files, etc.  I'll be able to open a file remotely, then minutes later suddenly it's "unavailable" becuase it can't be found (or might be locked or encrypted).  This is such insanely poor network coding.  Is there any solution here?  

As I said, I logged in as Administrator and was able to access the full security settings, and all modifications look to be correctly set.  It will work fine, and with no explanation files will become "unavailable" to remote users - no changes, no one logs out or back in, etc.

If XP Home is such a complete load of crap in networking, then would an upgrade to XP Pro solve the problems once and for all?
0
tmlondon
Asked:
tmlondon
2 Solutions
 
norganCommented:
Firstly i will start by saying that XP Home will not connect to domains, so if you want to run a domain then forget XP Home, an upgrade to XP Pro would be highly reccomended here.

If you are not running a domain, then i would be running a ping test on the connections to check for packet loss. If any of the ping times out then you are getting packet loss, this can cause problems communication accross the network.

If that tests out ok then next step would be to check that the networking software is ok, to do this the best bet is to reinstall the components. This can be done in add/remove programs under windows setup.

If you are getting packet loss, then you need to check your:
Cableing
NIC (network cards)
any adaptors or connectors
network software

In that order.

Hope this helps.
0
 
sirbountyCommented:
To expound on what's been said, XP Home can be forced to work within a domain, but not join it.  The trick is simply to name the workgroup the same as your domain.  That said, I haven't read anything here that states you are definitely in a domain...
XP Home wasn't designed for networking - just a single, simple home PC.  The Pro version includes better security and networking features (and Microsoft "wants" you to purchase the upgrade...naturally, it cost more ;)

Try adjusting this setting:

1. Click Start, click Run, type regedit (Windows 2000 or Windows Server 2003) or type regedt32 (Windows NT 4.0), and then click OK.
2. Locate and then click the following key in the registry:

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

3. In the right pane, click the autodisconnect value, and then on the Edit menu, click Modify. If the autodisconnect value does not exist, follow these steps:
4. On the Edit menu, point to New, and then click REG_DWORD.
5. Type autodisconnect, and then press ENTER.
6. Click Hexadecimal.
7. In the Value data box, type ffffffff, and then click OK.

ref: http://support.microsoft.com/?kbid=297684
http://support.microsoft.com/?kbid=138365

Or simply click Start->Run->cmd /k net config server /autodisconnect:-1
to turn off autodisconnect
0
 
Ron MalmsteadInformation Services ManagerCommented:
turn off your xp firewall service or mcafee or norton...if you have it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now