Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Samba Guest acount setup to access from XP-Home-Edition

Posted on 2004-08-02
12
Medium Priority
?
2,759 Views
Last Modified: 2010-04-20
I'm trying to setup Samba so that I can access the Linx box from a windows XP home-edition computer.
My Linux box is Fedora 2 Redhat

I've tried adding a guest user, and I still can't seem to access the Linux box.
I can see it my network, and I have it set with the same workgroup.
But when I double click on it,  I get a popup window asking me for the password.
When I enter the password, and click OK, the popup window just comes back again.

What do I need to do to set this up right?
0
Comment
Question by:Axter
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +1
12 Comments
 
LVL 45

Expert Comment

by:sunnycoder
ID: 11700616
Hi Axter,

add the user using smbpasswd command

smbpasswd -a guest guest

this will set up a samba account with username guest and password guest

Sunnycoder
0
 
LVL 30

Author Comment

by:Axter
ID: 11700622
>>smbpasswd -a guest guest

Thanks for the quick response.
I tried that, but it didn't work.

The Linux box took the command with no errors.
But when I try to access it from the XP box, it still fails to access the Linux box.
0
 
LVL 30

Author Comment

by:Axter
ID: 11700628
On thing I notice that is strange, is that the popup window asking me for the password states "connect to 192"

Also the username is grayed out, and it has "192\Guest" for the user name.

I'm not sure where the 192 is comming from, but I think it has something to do with the failure.

I'm also woundering if the upper case first character "Guest" is throwing it off.
0
Survive A High-Traffic Event with Percona

Your application or website rely on your database to deliver information about products and services to your customers. You can’t afford to have your database lose performance, lose availability or become unresponsive – even for just a few minutes.

 
LVL 45

Expert Comment

by:sunnycoder
ID: 11700630
do you have a system account called guest ?

The account being created should be valid system account name too
0
 
LVL 30

Author Comment

by:Axter
ID: 11700637
>>do you have a system account called guest ?

I already had added an account called guest.
0
 
LVL 45

Expert Comment

by:sunnycoder
ID: 11700641
ok, try this .. from xp box

start->run

\\xx.xx.xx.xx  <two backslash followed by ip adress of the linux box

enter username and password in the pop up ... what do you get ?
0
 
LVL 30

Author Comment

by:Axter
ID: 11700654
>>enter username and password in the pop up ... what do you get ?

I get the same results.
The pop-up window keeps coming back.
0
 
LVL 45

Expert Comment

by:sunnycoder
ID: 11700663
can you post your smb.conf file ? ofcourse you should be editing out personal information such as an IP address
0
 
LVL 9

Accepted Solution

by:
e-tsik earned 2000 total points
ID: 11700721
Hi :-)

The changes you need to do to open a guest account (on /etc/samba/smb.conf):

on the [global] section:
map to guest = bad user
guest ok = yes
hosts allow = 127.0.0.1,1.2.3.4
security = user
encrypty passwords = yes

Replace 1.2.3.4 with your windows XP ip address - opening this guest account surely compromises your security...
You could also try 'map to guest = bad password' if you have the same users defined on the XP and the Linux machine.

On your share definition:
guest ok = yes
force user = root
force group = root

Afterwards, restart the samba service
service smb restart

Enjoy!
0
 
LVL 30

Author Comment

by:Axter
ID: 11700746
That was it.

Thanks a lot.

And thank you sunnycoder for trying.
0
 

Expert Comment

by:__init__
ID: 11928682
force user = root???  A good way for suicide ;)
0
 
LVL 9

Expert Comment

by:e-tsik
ID: 11928833
Not exactly, init.

It only allows specific hosts to connect, plus, it has nothing to do with your authentication method. You can allow access to a share only to a specific user, and then 'force user = root' to it, to allow access, and automatically set the owner to root.
0

Featured Post

What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question