Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

fatal error C1083

Posted on 2004-08-03
10
Medium Priority
?
2,813 Views
Last Modified: 2010-08-05
I'm trying to compile this code I got from someone.
I keep on getting "fatal error C1083: Cannot open include file: 'xxx.h': No such file or directory" (where xxx.h is the name of the file).
The file xxx.h exists in the project, but I guess the file that has the include "xxx.h" can't find it.
What can be wrong? What should I check?

Thanks.
0
Comment
Question by:chayahd99
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +2
10 Comments
 
LVL 12

Expert Comment

by:andrewjb
ID: 11703175
Compiler?

Make sure the directory where the .h file is is on the 'include path'. This'll probably be somewhere in the project options for your application. Depends upon the platform.
0
 

Author Comment

by:chayahd99
ID: 11703232
I'm using Visual C++.
I can't find in Project --> Settings where to define this.
Besides, why should I need to define it manualy? Isn't the 'include' statment enough ?
0
 
LVL 12

Expert Comment

by:andrewjb
ID: 11703308
Sorry - haven't VC++ installed, and can't remember exactly where it is. (It's reasonably obvious, through!)

The #include is fine if you include the full directory of the file. Otherwise it needs to know where to go looking on your drive!
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 16

Accepted Solution

by:
nonubik earned 150 total points
ID: 11703416
Project --> Settings -> c/c++ -> Category 'preprocessor' -> 'Additional include directories' field
0
 
LVL 9

Expert Comment

by:tinchos
ID: 11704706
You have 3 possibilities

1)
You can place the complete path to the file, something like.....

#include "c:\development\myProj\Include\xxx.h"

2) If the include directory is a directory where include files from all projects can be included

you can do

Tools -> Options -> Projects -> VC++ Directories -> Include files and add the directory there.

3) you can do nonubik suggestion.
Suggestion number 2 would be the same as using number 3 for every project you use in Visual Studio......

Hope this helps

Tincho


0
 

Author Comment

by:chayahd99
ID: 11704710
Thanks nonubik.
I followed the steps you wrote & saw that the directory which containes the h file is written properly, together with other paths.
What else can it be ?
0
 
LVL 9

Expert Comment

by:tinchos
ID: 11704794
Try the suggestions I posted

Tincho
0
 
LVL 16

Expert Comment

by:nonubik
ID: 11705133
Let's take the MSDN explanations, step by step. Could be one of:

-File, subdirectory, or disk is read-only.
-No access permission for file or directory. (not likely)
-Not enough file handles. Close some applications and recompile. (not likely at all)
-An #include directive uses double quotation marks around a path specification, which causes the standard directories to be skipped.
0
 
LVL 55

Expert Comment

by:Jaime Olivares
ID: 11705433
Are directories in your settings separated by commas or other sign?
0
 

Author Comment

by:chayahd99
ID: 11713790
nonubik's solution is basicly what I needed to do, but for a different file.

Meaning:

file b includes file a.
file c include file  b.

in the code & settings for file b, file a was marked as an include file.
in the code & settings for file c, file b was marked as an include file.

I added to the settings of file c an include to file a & that solved the problem.
I'm not sure why this is required, but it worked.

I'll be glad to get an explanation.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: SunnyDark
This article's goal is to present you with an easy to use XML wrapper for C++ and also present some interesting techniques that you might use with MS C++. The reason I built this class is to ease the pain of using XML files with C++, since there is…
Many modern programming languages support the concept of a property -- a class member that combines characteristics of both a data member and a method.  These are sometimes called "smart fields" because you can add logic that is applied automaticall…
The goal of the tutorial is to teach the user how to use functions in C++. The video will cover how to define functions, how to call functions and how to create functions prototypes. Microsoft Visual C++ 2010 Express will be used as a text editor an…
The goal of the video will be to teach the user the concept of local variables and scope. An example of a locally defined variable will be given as well as an explanation of what scope is in C++. The local variable and concept of scope will be relat…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question