Solved

Static LAN IP Address

Posted on 2004-08-03
17
457 Views
Last Modified: 2010-04-11
Hello
I just got a New Linksys WRT54G Router but im having a little bit of hard time trying to
have static IPs on my computers

1st computer  192.168.1.100
2nd computer  192.168.1.101
3rd computer  192.168.1.102
4th computer  192.168.1.103

im using (Internet Connection Type "PPPoE"). I connect to internet perfectly
but when the electricity of the house goes down and I turn back on everything
my 4 computers, they all have different ips

1st computer  192.168.1.102
2nd computer  192.168.1.101
3rd computer  192.168.1.103
4th computer  192.168.1.100

any idea of how I can make my computers to have the same IP if the power goes down?
0
Comment
Question by:Xtry
  • 4
  • 4
  • 4
  • +2
17 Comments
 
LVL 7

Expert Comment

by:crazijoe
ID: 11704669
Is the router configured to issue DHCP?
0
 

Author Comment

by:Xtry
ID: 11704712
Setup > Network Setup > Network Address Server Settings (DHCP) > Enable or Disable
I had it on Disable and I couldn't get online so I left it on enable.
0
 
LVL 27

Assisted Solution

by:pseudocyber
pseudocyber earned 120 total points
ID: 11704835
I believe by default, the DHCP scope starts at .100.  If you want to assign static IP's to your machines, you should use addresses < .100.  I would start around .20 and go up from there, just personal preference really.

Linksys doens't have the ability to RESERVE IP addresses for certain MAC addresses like other DHCP servers do.  So, you need to configure your PC's to have static addresses if you don't want them to change.
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 
LVL 7

Expert Comment

by:crazijoe
ID: 11704838
The DHCP in this configuration needs to be disabled. When you had it disabled could you see the other computers on the network?
0
 
LVL 2

Assisted Solution

by:jonpaulr
jonpaulr earned 120 total points
ID: 11704924
It sounds like you have each computer setup for DHCP! If the problem is really that simple, simply go into the TCP/IP settings for each computers network properties and specify a static IP address for each one! It wouldn't matter if you had 10,000 routers on your network trying to give those computers an IP address once you do that. They're already set to static and are not looking for a router/server assigned IP address...
0
 
LVL 3

Accepted Solution

by:
krazieintent earned 155 total points
ID: 11705098
in reply to pseudocyber reply, starting at .20 would be a static address, but if dhcp is configured on the router. Then when the power goes off and the computers and routers are reset, the dhcp sever, in this case your new router will still assign ip address to your hosts.

When your power went off, the router was shut off, and in doing so, its routing table and dhcp client table was reset.

When you rebooted all of your computers, dhcp automatically assigned everything to get the network up and running again. If you choose, to assign a number lower then .100 it will not over ride the dhcp settings.

to prevent this from happening again. turn off dhcp on the router.

You said you couldnt go online when dhcp was off, my only explaination for this as of now with the current information told is that the wrong gateway address was set on the computers.

to set up static ip address on your computers do the following.

1. Open the my connections folder
2. right click on your local lan connection (if you have more then one select the connection assigned to the NIC that connects to your lan) and select properties
3. in the items box for the NIC, scroll down until you see tcp/ip and select properties
4. Select the option that says use the following ip address

give the ips as follows:

1st computer  IP address ...192.168.1.100

2nd computer  192.168.1.101
3rd computer  192.168.1.102
4th computer  192.168.1.103





0
 
LVL 3

Expert Comment

by:krazieintent
ID: 11705168
for some reson the page automatically posted it self, in continuation to my reply.....

1st computer
ip................192.168.1.100
MASK ........ 255.255.255.0
GATEWAY...192.168.1.1

2nd computer
IP...............192.168.1.101
MASK..........255.255.255.0
GATEWAY....192.168.1.1

3rd computer
IP ..............192168.1.102
MASK.........255.255.255.0
GATEWAY...192.168.1.1

4th computer
IP..............192.168.1.103
MASK........255.255.255.0
GATEWAY...192.168.1.1

select option obtain DNS server address automatcially for all computers.

Hope this helps, if you are still not abale to connect to the internet, let us know

Hope this helps,

Kevin
0
 
LVL 7

Assisted Solution

by:crazijoe
crazijoe earned 105 total points
ID: 11705218
jonpaulr is correct the computer's TCP/IP properties need to be set with static IP's
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 11705248
I said he/she needed static ip addresses if they didn't want the machines to change.  And rather than turn DHCP off, I was saying assign static IP's outside the DHCP server's (the router) scope.
0
 
LVL 2

Expert Comment

by:jonpaulr
ID: 11705249
What krazieintent just wrote can be used, but only considering your "GATEWAY" (which is your routers LAN address and the Linksys default) is 192.168.1.1. If it is not, replace the "GATEWAY" IP address with your routers LAN address.
0
 

Author Comment

by:Xtry
ID: 11706104
ok thanks everyone for the help!
0
 

Author Comment

by:Xtry
ID: 11706145
Who I’m supposed to give the Points?
0
 
LVL 7

Expert Comment

by:crazijoe
ID: 11706181
I would spit it between pseudocyber, krazieintent and
jonpaulr
0
 
LVL 2

Expert Comment

by:jonpaulr
ID: 11706198
My opinion:

pseudocyber started the correct path by suggesting the static IP's on each computer
jonpaulr (me) stated the same and why
krazieintent gave step by step instructions
jonpaulr agreed w/ one modification to his gateway suggestion

split up the points... That's my personal opinion, but I'm not the moderator.
0
 
LVL 2

Expert Comment

by:jonpaulr
ID: 11706203
Funny crazijoe. We think alike.
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 11706856
My only suggestion for the points is to assign a grade of A - the points are multiplied by the letter assignment.
0
 

Author Comment

by:Xtry
ID: 11707604
there we go :-)
0

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question