Solved

Amavis-new, spamassassin, with postfix - Spam is set to clinet with out ***SPAM*** in the subject line.

Posted on 2004-08-03
18
36,415 Views
Last Modified: 2013-12-15
I have been trying to get amavis and spamassassin to modify the subject
line on all mail that it finds as spam.

The mail server is running SUSE 9.1 with Postfix, clamd av, amavis-new,
and spamassassin. Everything seems to be working great except for the
spam filter. The system is finding spam mail, however it is not
marking the subject line with ***SPAM*** before it relays the mail to the client.

/var/log/mail

Aug  3 08:13:41 pippin amavis[7353]: (07353-15) spam_scan: hits=19.447
tests=BEEN_TURNED_DOWN,EXCUSE_3,FORGED_RCVD_NET_HELO,HTML_40_50,HTML_FONTCOLOR_RE
D,HTML_FONT_BIG,HTML_MESSAGE,HTML_MIME_NO_HTML_TAG,MIME_HTML_NO_CHARSET,MIME
_HTML_ONLY,MIME_HTML_ONLY_MULTI,RAZOR2_CF_RANGE_51_100,RAZOR2_CHECK,RCVD_IN_
BL_SPAMCOP_NET,RCVD_IN_DSBL,RCVD_IN_DYNABLOCK,RCVD_IN_SBL,RCVD_IN_SORBS

Aug  3 08:13:41 pippin amavis[7353]: (07353-15) SPAM,
<test1@test1.net> -> <test@xxxx.net>, Yes, hits=19.4
tag1=-999.0 tag2=5.0 kill=0.0 tests =BEEN_TURNED_DOWN, EXCUSE_3,
FORGED_RCVD_NET_HELO, HTML_40_50, HTML_FONTCOLOR_RED, HTML_FONT_BIG,
HTML_MESSAGE, HTML_MIME_NO_HTML_TAG, MIME_HTML_NO_CHARSET,
MIME_HTML_ONLY, MIME_HTML_ONLY_MULTI, RAZOR2_CF_RANGE_51_100,
RAZOR2_CHECK, RCVD_IN_BL_SPAMCOP_NET, RCVD_IN_DSBL, RCVD_IN_DYNABLOCK,
RCVD_IN_SBL, RCVD_IN_SORBS

Aug  3 08:13:41 servername amavis[7353]: (07353-15) FWD via SMTP:
[127.0.0.1]:10025 <test1@test1h.net> -> <test@xxxx.net>

Aug  3 08:13:41 servername amavis[7353]: (07353-15) Passed,
<test1@test1.net> -> <test@xxxx.net>, quarantine
spam-481ed72eaba6940fb1f708dc4e144e49-20040803-081341-07353-15,
Message-ID: <EDVOPKJDDHQVWGSYCDXOL@lycos.ne.jp>, Hits: 19.447

Aug  3 08:13:41 servername postfix/qmgr[7314]: 944161C8BA:
from=<test1@test1.net>, size=2747, nrcpt=1 (queue active)

Aug  3 08:13:41 servername amavis[7353]: (07353-15) TIMING [total 3172 ms] -
SMTP EHLO: 2 (0%), SMTP pre-MAIL: 1 (0%), SMTP pre-DATA-flush: 4 (0%),
SMTP DATA: 38 (1%), body hash: 1 (0%), mime_decode: 19 (1%),
get-file-type: 20 (1%), decompose_part: 2 (0%), parts: 0 (0%),
AV-scan-1: 1029 (32%), SA msg read: 2 (0%), SA parse: 2 (0%), SA check:
1964 (62%), fwd-connect: 11 (0%), fwd-mail-from: 2 (0%), fwd-rcpt-to: 3
(0%), write-header: 4 (0%), fwd-data: 0 (0%), fwd-data-end: 58 (2%),
fwd-rundown: 2 (0%), unlink-1-files: 7 (0%), rundown: 0 (0%)

Aug  3 08:13:41 servername postfix/smtp[7507]: 3ACDF1C8E6:
to=<test@xxxx.net>, relay=localhost[127.0.0.1], delay=10, status=sent
(250 2.6.0 Ok, id=07353-15, from MTA: 250 Ok: queued as 944161C8BA)

Config files

Spamassassin
/etc/mail/spamassassin/local.cf

# Add your own customisations to this file.  See 'man
Mail::SpamAssassin::Conf'
# for details of what can be tweaked.
#
# rewrite the Subject: line with ****SPAM**** .* if set to 1 (default=1)
rewrite_subject 1

# report briefly, recommended for report_header==1 (default=0)
use_terse_report 1

# How many hits before a message is considered spam.
required_hits 5.0

# Text to prepend to subject if rewrite_subject is used
subject_tag *****SPAM*****

# Encapsulate spam in an attachment
report_safe 1

# Enable the Bayes system
use_bayes 1
bayes_path /var/spool/amavis/.spamassassin/bayes_seen

# Enable Bayes auto-learning
auto_learn 1

# Enable or disable network checks
skip_rbl_checks         0
use_razor2              1
use_dcc                 0
use_pyzor               0

# Mail using languages used in these country codes will not be marked
# as being possibly spam in a foreign language.
ok_languages            all

# Mail using locales used in these country codes will not be marked
# as being possibly spam in a foreign language.
ok_locales              all

Amavis
/etc/amavisd.conf

# SpamAssassin settings

# $sa_local_tests_only is passed to Mail::SpamAssassin::new as a value
# of the option local_tests_only. See Mail::SpamAssassin man page.
# If set to 1, SA tests are restricted to local tests only, i.e. no
tests
# that require internet access will be performed.
#
$sa_local_tests_only = 0;   # (default: false)
#$sa_auto_whitelist = 1;    # turn on AWL (default: false)

#$sa_timeout = 30;           # timeout in seconds for a call to
SpamAssassin
                            # (default is 30 seconds, undef disables it)
#$sa_mail_body_size_limit = 150*1024; # don't waste time on SA if mail
is la
rger
                            # (less than 1% of spam is > 64k)
                            # default: undef, no limitations
# default values, can be overridden by more specific lookups, e.g. SQL
$sa_tag_level_deflt  = -999; # add spam info headers if at, or above
that level
$sa_tag2_level_deflt = 5.0;
#$sa_kill_level_deflt = 20.0;
#$sa_kill_level_deflt = $sa_tag2_level_deflt; # triggers spam evasive
actions
                            # at or above that level:
bounce/reject/drop,
                            # quarantine, and adding mail address
extension
#$sa_dsn_cutoff_level = 10;  # spam level beyond which a DSN is not
sent,
                            # effectively turning D_BOUNCE into
D_DISCARD;
                            # undef disables this feature and is a
default;

#
# The $sa_tag_level_deflt, $sa_tag2_level_deflt and $sa_kill_level_deflt
# may also be hashrefs to hash lookup tables, to make static
per-recipient
# settings possible without having to resort to SQL or LDAP lookups.

# a quick reference:
#   tag_level  controls adding the X-Spam-Status and X-Spam-Level
headers,
#   tag2_level controls adding 'X-Spam-Flag: YES', and editing Subject,
#   kill_level controls 'evasive actions' (reject, quarantine,
extensions);
# it only makes sense to maintain the relationship:
# tag_level <= tag2_level <= kill_level < $sa_dsn_cutoff_level

# string to prepend to Subject header field when message exceeds tag2
level
$sa_spam_subject_tag = '***SPAM***';    # (defaults to undef, disabled)
                             # (only seen when spam is not to be
rejected
                             # and recipient is in local_domains*)

#$sa_spam_modifies_subj = 1; # may be a ref to a lookup table, default
is true

# Example: modify Subject for all local recipients except
user@example.com
#$sa_spam_modifies_subj = [qw( !user@example.com . )];

/etc/postfix/main.cf

readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = servername.domain.net
mydomain = domain.net
myorigin = $mydomain
mynetworks = 10.0.0.0/24, 192.168.0.0/16, 127.0.0.0/8
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
mydestination = $myhostname, localhost.$mydomain
relay_domains = $mydestination, hash:/etc/postfix/relay_domains
defer_transports =
disable_dns_lookups = no
relayhost =
content_filter = smtp:127.0.0.1:10024
#vscan:
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks, check_relay_domains, reject_unauth_destination
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
0
Comment
Question by:ddburton23
18 Comments
 
LVL 36

Expert Comment

by:grblades
ID: 11707064
Hi ddburton23,
If you have a look at the 3rd item in the amavisd-new FAQ you will see that amavis does not permit spamassassin to modify the email
http://www.ijs.si/software/amavisd/#faq-spam

The way around this is to disable spam filtering in amavis and change the postfix configuration so that when amavis passes the email back into the queue it is then sent onto the spam filter.
0
 
LVL 36

Accepted Solution

by:
grblades earned 500 total points
ID: 11707127
I use suse openexchange and it basically has this setup. This are the relevant entries in my postfix master.cf file:-

smtp      inet  n       -       n       -       -       smtpd -o content_filter=smtp-amavis:[127.0.0.1]:10024
smtp-amavis unix -      -       n       -       3       smtp -o smtp_data_done_timeout-1200 -o disable_dns_lookups=y
es
127.0.0.1:10025 inet n  -       n       -       -       smtpd -o content_filter=procmail:spamfilter -o local_recipie
nt_maps= -o relay_recipient_maps= -o smtpd_restriction_classes= -o smtpd_client_restrictions= -o smtpd_helo_restrict
ions= -o smtpd_sender_restrictions= -o smtpd_recipient_restrictions=permit_mynetworks,reject -o mynetworks=127.0.0.0
/8 -o strict_rfc821_envelopes=yes

Make sure that the content filter is blank in the main.cf otherwise when spamassassin puts the email into the queue it goes through the default filter and you get mail going round in a loop :)
My mail system used the spamd daemon version of spamassassin.
0
 

Author Comment

by:ddburton23
ID: 11707912
Thanks for your help, however after I made the changes I get the following errors in the mail log:

Aug  3 11:04:10 servername postfix/qmgr[8864]: 0E8901C923: to=<angelat@xxx-xx.org>, relay=none, delay=3, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Aug  3 11:04:12 servername postfix/smtpd[8915]: disconnect from unknown[xxx.xxx.xxx.138]

/etc/postfix/main.cf

readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = pippin.nxstech.net
mydomain = nxstech.net
myorigin = $mydomain
mynetworks = 10.0.0.0/24, 192.168.0.0/16, 66.182.73.192/26, 127.0.0.0/8
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
mydestination = $myhostname, localhost.$mydomain
relay_domains = $mydestination, hash:/etc/postfix/relay_domains
defer_transports =
disable_dns_lookups = no
relayhost =
content_filter =
#vscan:
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks, check_relay_domains, reject_unauth_destination
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000

/etc/postfix/master.cf

smtp      inet  n       -       n       -       2       smtpd -o content_filter=smtp-amavis:[127.0.0.1]:10024
smtp-amavis unix -      -       n       -       3       smtp -o smtp_data_done_timeout-1200 -o disable_dns_lookups=no
127.0.0.1:10025 inet n  -       n       -       -       smtpd -o content_filter=procmail:spamfilter -o local_recipient_maps= -o relay_recipient_maps= -o smtpd_restriction_classes= -o smtpd_client_restrictions= -o smtpd_helo_restrictions= -o smtpd_recipient_restrictions=permit_mynetworks,reject -o mynetworks=127.0.0.0/8 -o strict_rfc821_envelopes=yes
#smtps    inet  n       -       n       -       2       smtpd -o smtpd_tls_wrappermode=yes -o content_filter=smtp:[localhost]:10024                     #  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes               #submission     inet    n       -       n       -       -       smtpd       #  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes                   #628      inet  n       -       n       -       -       qmqpd               pickup    fifo  n       -       n       60      1       pickup              cleanup   unix  n       -       n       -       0       cleanup             qmgr      fifo  n       -       n       300     1       qmgr                #qmgr     fifo  n       -       n       300     1       oqmgr               rewrite   unix  -       -       n       -       -       trivial-rewrite     bounce    unix  -       -       n       -       0       bounce              defer     unix  -       -       n       -       0       bounce              trace     unix  -       -       n       -       0       bounce              verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       n       -       -       smtp
relay     unix  -       -       n       -       -       smtp
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
localhost:10025 inet    n       -       n       -       -       smtpd -o content_filter=
0
 
LVL 36

Expert Comment

by:grblades
ID: 11708018
Is amavis running?
Check the amavis configuration file to make sure it contains the line :-
$inet_socket_port = 10024;   # accept SMTP on this local TCP port(s) (Postfix)
0
 
LVL 7

Expert Comment

by:troopern
ID: 11708027
$sa_tag_level_deflt  = -999; # add spam info headers if at, or above that level
I woudl change that line to a more proper value.
Like 4 or 4.5 or something like that.
Too bad I can't check on my own config right now.
0
 

Author Comment

by:ddburton23
ID: 11708065
I am sorry I fixed the one problem: Aug  3 11:04:10 servername postfix/qmgr[8864]: 0E8901C923: to=<angelat@xxx-xx.org>, relay=none, delay=3, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)

However, do I need to setup the procmail filter to get this setup to work?

here is the new error:
Aug  3 11:20:04 servername postfix/pipe[9136]: B258D1C950: to=<wagner@ulcu.com>, relay=procmail, delay=0, status=deferred (temporary failure. Command output: procmail: Couldn't read "/etc/procmailrc" )

Thanks for all your help.

0
 
LVL 36

Expert Comment

by:grblades
ID: 11708181
It looks as if your procmail configuration file in /etc/procmailrc does not exist.

Here is the contents of mine:-

#LOGFILE=/tmp/procmail.log
#VERBOSE=yes
SENDER=$1
SHIFT=1
# Until now, mail is untagged, you may add rules for
# mail that must not be tagged
:0 hbfw
| /usr/bin/spamc
# Now mail is tagged by spamassassin
# You may insert other rules here
:0
| /usr/sbin/sendmail -i -f "$SENDER" -- "$@"

I haven't looked at procmail myself as it came already configured on our mail server.
0
 

Author Comment

by:ddburton23
ID: 11708275
Procmail is not installed on this system.

it is only using postfix amavis and spamassassin. In the postfix master.cf I see this line:
127.0.0.1:10025 inet n  -       n       -       -       smtpd -o content_filter=procmail:spamfilter -o local_recipient_maps= -o relay_recipient_maps= -o smtpd_restriction_classes= -o smtpd_client_restrictions= -o smtpd_helo_restrictions= -o smtpd_recipient_restrictions=permit_mynetworks,reject -o

Should I hve smothing different for procmail:spamfilter? I would like to have all the domains relay through postfix. So is there a way to tel postfix to use the spamassassin or do I have to install procmail?

Cheers
0
 
LVL 36

Expert Comment

by:grblades
ID: 11708369
I am not sure abount this. My mail server came with the spam filter already configured and had the following line already in the postfix master.cf file:-
smtp      inet  n       -       n       -       2       smtpd -o content_filter=procmail:spamfilter
I just moved the content filter so that it got passed after the virus scanning was done.

Using procmail as the interface between postfix and spamassassin does seem to be the standard method:-
http://ist.uwaterloo.ca/~dkeenan/talks/spamassassin/systemwide.html
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:ddburton23
ID: 11708441
Thanks for everything! I will get the procmail installed right now.
0
 

Author Comment

by:ddburton23
ID: 11710294
Has anyone been able to get around this error?

postfix/qmgr[13919]: warning: connect to transport promail: No such file or directory
0
 

Author Comment

by:ddburton23
ID: 11710318
or

postfix/qmgr[13988]: warning: connect to transport spamfilter: No such file or directory
0
 
LVL 36

Expert Comment

by:grblades
ID: 11712915
> postfix/qmgr[13919]: warning: connect to transport promail: No such file or directory
It sais 'promail' instead of 'procmail'. Are you sure you didnt make a typo anywhere?
0
 

Author Comment

by:ddburton23
ID: 11716714
I have gone through all the config files, however I am not seeing a typo anywhere! Here are the error messages I get when SPAM gets passed through:

postfix/smtp[25353]: A0B871CA75: to=<pegasus@domain.com>, relay=127.0.0.1[127.0.0.1], delay=0, status=sent (250 Ok: queued as BCD541CA76)
postfix/qmgr[25114]: A0B871CA75: removed
spamd[25406]: info: setuid to nobody succeeded
spamd[25406]: processing message <20040804152142.A0B871CA75@ourserver.domain.net> for nobody:65534
spamd[25406]: identified spam (5.9/5.0) for nobody:65534 in 0.2 seconds, 3179 bytes.
postfix/pipe[25355]: BCD541CA76: to=<pegasus@domain.com>, relay=procmail, delay=1, status=deferred (temporary failure)
postfix/qmgr[25114]: warning: connect to transport promail: No such file or directory
postfix/qmgr[25114]: warning: connect to transport spamfilter: No such file or directory

It looks like it could be a problem with Procmail and spamassassin.
Are there any settings that need to be setup in amavis-new for porcmail?

/etc/procmailrc
SENDER=$1
SHIFT=1
:0fw
| /usr/bin/spamc

/etc/postfix/master.cf
smtp      inet  n       -       n       -       2       smtpd -o content_fil
ter=smtp-amavis:[127.0.0.1]:10025
#smtps    inet  n       -       n       -       2       smtpd -o smtpd_tls_w
rappermode=yes -o content_filter=smtp:[localhost]:10024
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission     inet    n       -       n       -       -       smtpd
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628      inet  n       -       n       -       -       qmqpd
pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       n       -       -       smtp
relay     unix  -       -       n       -       -       smtp
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
#localhost:10025 inet   n       -       n       -       -       smtpd -o content_filter=
127.0.0.1:10025 inet    n       -       n       -       -       smtpd -o content_filter=procmail:spamfilter -o local_recipient_maps= -o relay_recipient_maps= -o relay_recipient_maps= -o smtpd_restriction_classes= -o smtpd_helo_restrictions= -o smtpd_sender_restrictions= -o smtpd_recipient_restrictions=permit_mynetworks,reject -o mynetworks=127.0.0.0/8 -o strict_rfc821_envelopes=yes
smtp-amavis     unix    -       -       n       -       2       smtp -o smtp_data_done_timeout=1200 -o disable_dns_lookups=yes

/etc/postfix/main.cf
readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = ourserver.domain.net
mydomain = domain.net
myorigin = $mydomain
mynetworks = 10.0.0.0/24, 192.168.0.0/16, 66.182.73.192/26, 127.0.0.0/8
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
mydestination = $myhostname, localhost.$mydomain
relay_domains = $mydestination, hash:/etc/postfix/relay_domains
defer_transports =
disable_dns_lookups = no
relayhost =
content_filter =
#vscan:
mailbox_command = /usr/bin/procmail
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
0
 

Author Comment

by:ddburton23
ID: 11717729
I have fixed the problem now.

Procmail was putting all of the spamd messages in to a queue, and then it it had no way to send them.

Thanks
0
 
LVL 36

Expert Comment

by:grblades
ID: 11718182
Glad you got it working.

The default for spamd includes the -L parameter which disables network checks. If you remove this parameter from the spamd startup file it should improve the spam detection but you will get a bit more DNS traffic as it looks up the senders on various blacklists.

You might also want to ahve a look at.
http://razor.sourceforge.net/
0
 

Author Comment

by:ddburton23
ID: 11726396
Thanks for the tip!
0
 

Expert Comment

by:Pollywog
ID: 12034779
I think the reason for the refused connections in the original replies is that Postfix is not listening on all interfaces, specifically localhost.  That is not really a problem, but some changes need to be made.

My main.cf has this at the bottom:

content_filter = smtp-amavis:[192.168.0.1]:10024

That is because my Postfix listens there, not at 127.0.0.1

My master.cf has this:

192.168.0.1:10025 inet n - n - - smtpd
        -o content_filter=
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o mynetworks=192.168.0.0/24
        -o strict_rfc821_envelopes=yes
        -o smtpd_error_sleep_time=0
        -o smtpd_soft_error_limit=1001
        -o smtpd_hard_error_limit=1000


The problem with the setup I use is that using Amavisd with Spamassassin does not allow me to have per-user SA configs and this is not working well for me.  SA catches more spam but there are also many false positives.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

The purpose of this article is to demonstrate how we can use conditional statements using Python.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now