Solved

Ethernet Speeds

Posted on 2004-08-03
17
679 Views
Last Modified: 2010-04-11
I have two computers connected directly to each other via a crossover cat-5/ethernet cable.  Both NICs are set at 100Meg/Full Duplex (not auto-detect), but I'm only getting about 1.7 MB/sec transfer.  Why is my rate so slow?  If I have 100baseT, shouldn't I be getting in the neighborhood of 12.5 MB/sec?
0
Comment
Question by:lofiched
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +5
17 Comments
 
LVL 36

Expert Comment

by:grblades
ID: 11707878
Hi lofiched,
Yes you should be getting a much faster speed. A more typical speed would be between 11-12MB/s
What spec are the machines?
Perhaps the hard disks cannot keep up if they are old?
Have you tried a different cable?
0
 

Author Comment

by:lofiched
ID: 11707930
Tried different cable, no fix.  One machine is a new (less than a year) Dell, the other is an older HP LH3 Server, but it's running dual 400MHz and uses 10,000 RPM SCSI drives.  I'd think that would be able to keep up without any problem.  Also, right now, these two machines aren't doing anything expcept the transfer.
0
 
LVL 36

Expert Comment

by:grblades
ID: 11708033
How are you testing the transfer speed?
Between what two applications?
0
Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

 

Author Comment

by:lofiched
ID: 11708243
doing a large file transfer and using performance monitor to watch network interface 'bytes sent'.  Perfmon reports an average of about 1.7MB/s, a max of about 2.3MB/s, and a min of 1.1MB/s.

Also, it took between 2 and 2.5 hours to transfer a 14GB file, which if you do the math, comes out to somewhere between 1.5 and 1.9 MB/s.
0
 
LVL 36

Expert Comment

by:grblades
ID: 11708295
Do you have a 3rd machine you can experiment with?
I would connect the 3rd machine to each of the other two in turn and check the transfer speed to see which one is having a problem.
Then you can try changing the network card etc... on the affected machine.

I assume you were transfering the file via normal windows file sharing?
0
 

Author Comment

by:lofiched
ID: 11708356
I can't really experiment right now.  The server is one of our Exchange servers and we had to rebuild one of the arrays and now we're moving our saved databases back to that drive.  Anyway, I can't mess with it at all , really, because it's been down for 2 days and people are getting antsy.  Then, of course, once it's up, I won't be able to take it down to test it.  

I was kinda hoping someone new of a reason off the top of their head, assuming all normal troubleshooting practices have already been executed.  For now though, I guess we'll just have to live with it.  Maybe some night, on like a weekend or something, I can take it down and check it out some more.
0
 
LVL 13

Expert Comment

by:ocon827679
ID: 11708550
Can you try setting it to Half/Duplex?
0
 

Author Comment

by:lofiched
ID: 11708626
Unfortunately, no.  I can't do anything that will disruspt the file transfer.  As it stands right now, it's gonna take between 6 and 8 hours to complete the transfer, and if have to start it over, I know I will be called in to talk to people I don't want to talk to.
0
 
LVL 13

Expert Comment

by:ocon827679
ID: 11708743
drag dude - understand your predicament!
0
 
LVL 4

Expert Comment

by:Kooroo
ID: 11709530
check fragmentation of your volumes. I had a server on channel bonded 10/100 FD NICs putter around at like 5Mbps once because of massive file fragmentation.
I *think* you could get a fragmentation report without disrupting the transfer, diskkeeper analysis is usually a safe thing to run.

man, I sympathize with you tho.
0
 
LVL 4

Expert Comment

by:ErikPhilips
ID: 11713607
I had a similar incident.  Manually changing my cards from auto to half duplex fixed the problem.  I’m not happy about doing it, but it’s a good temporary solution, after all I get 100mbit speed vs the same thing you are seeing.
0
 
LVL 5

Expert Comment

by:scottman29
ID: 11716722
I don't really think it's a harddrive issue.  I'm not saying that the harddrive couldn't be a bottle neck, but if you think about it, the hard drives should be able to keep up with NIC's, they are usually a bottleneck when being accessed directly like a database or something.

I was curious if it could be a protocol issue, or a bind order issue.  You would need a network monitor to really test and see if there is any type of translation going on.  However if it's all windows, then that really shouldn't be an issue.  Are you running any sort of compression or encryption?

-yours, Scott
0
 

Author Comment

by:lofiched
ID: 11716865
I need to check the fragmentaion, but I Have higher priority things going on right, like complete site public folder restore...but that's another story.

I also want to try switching to half duplex, even though that doesn't make much sense to me, but you're the second person I've seen say that.

Both systems are all Windows.



BTW - The recovery of that server went off without a hitch, aside from taking like 10 total to complete.
0
 
LVL 11

Assisted Solution

by:PennGwyn
PennGwyn earned 20 total points
ID: 11717743
Although you can set both cards for full duplex, as you've done, that doesn't always guarantee the result you want.  I had a case here recently where if I set the switch to auto, it would negotiate a fast full-duplex connection with the server, but if I set the switch to full, throughput dropped to a trickle.  I think the server was a DEC/Compaq/HP box....

The other common cause I've seen of poor Ethernet performance has been damaged/defective cables.  You might try replacing that crossover and test again.

0
 
LVL 1

Accepted Solution

by:
tropsmr2 earned 30 total points
ID: 11741330
PennGwyn is right.  I highly suspect that one of the NIC cards is not actually fixed at 100Full.

Ethernet negotiation is probably one of the most misunderstood protocols in networking.
(nor was it really spec'd well either, but that's another story).

When setting for auto, both sides MUST be set for auto.  Negotiation is a two way street here.

With one side set for auto, the other fixed (half or full), the auto side has no partner to negotiate with and will default to HALF.  So, if one side is FULL and the other AUTO, then you end up with FULL and HALF.

When you end up with FULL and HALF, you get really poor tput.  The number of dropped packets have little bearing on low-load protocols like ping, but are death for transfer-intensive applications like FTP.

I cannot tell you the number of times I have seen this during my career, nor how many bugs I've filled with Ethernet hardware engineers for their bad negotiation code :-(.

Try setting both to auto or half.  Beware, you may have to take the link up and down in order for the changes to really take place.  Again, you shouldn't have to, but it depends on how the engineer coded the MAC.

0
 
LVL 4

Expert Comment

by:ErikPhilips
ID: 11741875
>tropsmr2

Interesting.  Maybe I should update my drivers.  The weird part about my problem was that when I copy a file TO the server its slow, really slow.  When I copy a file FROM the server, its normal speed (fast).  Setting Half duplex fixed it, which doesnt' make sense to me.  It also happened after upgrading Win2000SBS to 2003.  Setting it to Full Duplex didn't fix the problem.  I'm going to look into replacing my Netgear Switch, see if that fixes it :)  (ps. it was manually set to 100).
0
 
LVL 1

Expert Comment

by:tropsmr2
ID: 11742646
Sounds like you are getting closer.  The fact that the problem is directional can make sense.  Data transfers are traffic-heavy in a unidirectional fashion - one directions has large packets going one way, the ACKs are a very small stream (like pings) going the other way.

I've sorta lost the configuration you are talking about. Thought it was back-to-back x-over; where did the switch come from :-)

Anyway, the fact that it works when you set one side to half tells me that the other side probably wasn't actually at full (it was probably at half).

Now that we know it works at half, you might want to try both at auto before changing the infrastructure.  Upgrades to the NIC drivers may also give you some relief.

I'd like to hear more about the actual configuration, including the switch.....

t
0

Featured Post

How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question